Bug 60919 - Updated kernel refuses to work with IDE
Updated kernel refuses to work with IDE
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 20:21 EST by Michal Jaegermann
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 12:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-03-08 20:21:12 EST
Description of Problem:
An updated kernel 2.4.9-31 inherited an afliction reported elsewhere but
not against 7.1.  Namely while booting UP1100 with IDE drives the following
happens:

hda: 20010816 sectors (10246 MB) w/512KiB Cache, CHS=19852/16/63
hdb: 17803440 sectors (9115 MB) w/1966KiB Cache, CHS=17662/16/63, UDMA(33)
hdc: 30015216 sectors (15368 MB) w/2048KiB Cache, CHS=29777/16/63
Partition check:
 hda: hda1 hda2 hda3 hda4 hda5
 hdb:hdb: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdb: status error: status=0x58 { DriveReady SeekComplete DataRequest }
hdb: drive not ready for command
 hdb1 hdb2 hdb3 hdb4 <hdb: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdb: status error: status=0x58 { DriveReady SeekComplete DataRequest }
hdb: drive not ready for command
 hdb5hdb: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hdb: status error: status=0x58 { DriveReady SeekComplete DataRequest }
hdb: drive not ready for command
 hdb6 >
 hdc: hdc1 hdc2 hdc3 hdc4 hdc5 hdc6

I can boot the machine because it happens to have a root file system on
/dev/hda and neither /dev/hdb nor /dev/hdc is really mounted (a pure
accident) in the test configuration but otherwise I would be in a big
trouble.  After boot everything is verrry slooow....

Of course other kernels, configured for this Alpha, do not have
even a whiff of the problem.

The real layout of IDE disks on the machine in question happens to be:

 hda: hda1 hda2 hda3 hda4 hda5
 hdb: hdb1 hdb2 hdb3 hdb4 < hdb5 hdb6 >
 hdc: hdc1 hdc2 hdc3 hdc4 hdc5 hdc6

(Yes, hdb indeed has a FAT type partition table while hda and hdc a "BSD
label").

Version-Release number of selected component (if applicable):
kernel-2.4.9-31

How Reproducible:
On every boot.
Comment 1 Alan Cox 2003-06-08 12:50:25 EDT
Alpha is no longer supported (although the community alpha folks are still
fixing IDE bugs obviously)

Note You need to log in before you can comment on or make changes to this bug.