Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609333 - out-of-bounds memory access for valuators > MAX_VALUATORS
out-of-bounds memory access for valuators > MAX_VALUATORS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-evdev (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 21:24 EDT by Peter Hutterer
Modified: 2010-11-15 08:46 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-evdev-2.3.2-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 08:46:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2010-06-29 21:24:02 EDT
Description of problem:
An evdev device with more than 36 axes overruns internal array boundaries. This can currently only happen with absolute devices since the kernel does not provide for > 36 relative axes.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.3.2-6.el6

How reproducible:
Plug in a device with more than 36 absolute axes (uinput may be used). 
EvdevAddAbsClass will overwrite memory when resetting pEvdev->vals. There's no visible output because the structs overwritten are internal to evdev. Verification by inspection or with gdb.
  
Additional info:
https://bugs.freedesktop.org/show_bug.cgi?id=28809

Example uinput device to reproduce this behaviour is here:
http://cgit.freedesktop.org/~whot/testdevices/commit/?id=e6a09f8caa8617aa6efb4af133f560be5aa670c4
Comment 1 RHEL Product and Program Management 2010-06-29 21:43:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Peter Hutterer 2010-06-30 00:10:12 EDT
MODIFIED

xorg-x11-drv-evdev-2.3.2-7.el6 is available in brew.
Comment 4 Vladimir Benes 2010-11-15 07:29:09 EST
using in comment #0 mentioned test device w/ 63 axes I can see warning in /var/log/Xorg.0.log:

(II) XINPUT: Adding extended input device "allaxes test device" (type: TOUCHPAD)
(WW) allaxes test device: found 63 axes, limiting to 36.
(WW) Device 'allaxes test device' has 36 axes, only using first 36.

which is correct behaviour
-> VERIFIED
Comment 5 releng-rhel@redhat.com 2010-11-15 08:46:28 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.