Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609356 - [abrt] crash in wicd-common-1.7.0-1.fc13: wicd-daemon.py:1780:main:ValueError: I/O operation on closed file
[abrt] crash in wicd-common-1.7.0-1.fc13: wicd-daemon.py:1780:main:ValueError...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:818d73b5
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 00:36 EDT by Donald Harper
Modified: 2010-07-12 21:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 21:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (705 bytes, text/plain)
2010-06-30 00:36 EDT, Donald Harper
no flags Details
File: comment (2.44 KB, text/plain)
2010-06-30 00:36 EDT, Donald Harper
no flags Details

  None (edit)
Description Donald Harper 2010-06-30 00:36:44 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python -O /usr/share/wicd/daemon/wicd-daemon.py
Attached file: comment
component: wicd
executable: /usr/share/wicd/daemon/wicd-daemon.py
kernel: 2.6.33.5-124.fc13.i686.PAE
package: wicd-common-1.7.0-1.fc13
reason: wicd-daemon.py:1780:main:ValueError: I/O operation on closed file
release: Fedora release 13 (Goddard)

backtrace
-----
wicd-daemon.py:1780:main:ValueError: I/O operation on closed file

Traceback (most recent call last):
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1838, in <module>
    main(sys.argv)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1780, in main
    print 'unable to chmod log file to %s' % wpath.log_perms
ValueError: I/O operation on closed file

Local variables in innermost frame:
auto_connect: True
no_poll: False
do_daemonize: True
args: []
logpath: '/var/log/wicd.log'
redirect_stdout: True
argv: ['/usr/share/wicd/daemon/wicd-daemon.py']
redirect_stderr: True
backup_location: '/var/lib/wicd/resolv.conf.orig'
kill: False
output: ManagedStdio('/var/log/wicd.log', 360000, 3)
opts: []

How to reproduce
-----
1.boot
2.try to restart wicd
3.
Comment 1 Donald Harper 2010-06-30 00:36:46 EDT
Created attachment 427855 [details]
File: backtrace
Comment 2 Donald Harper 2010-06-30 00:36:48 EDT
Created attachment 427856 [details]
File: comment
Comment 3 David Cantrell 2010-07-12 21:15:19 EDT
I am unable to reproduce the problem described in the opening comment.  If you can reproduce it and have more details, feel free to reopen the bug.

The SELinux problem in comment #2 is a bug against selinux-policy, so you should file a new bug report for it.

Note You need to log in before you can comment on or make changes to this bug.