Bug 609363 - Resolutions above 1280x720 unavailable using NEC LCD3090WQXi
Summary: Resolutions above 1280x720 unavailable using NEC LCD3090WQXi
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 05:45 UTC by Braden McDaniel
Modified: 2010-06-30 08:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 08:49:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Braden McDaniel 2010-06-30 05:45:34 UTC
Description of problem:
As of the 0.0.16-7.20100423git13c1043.fc13 update, resolutions above 1280x720 are now unavailable when using an NEC LCD3090WQXi monitor. This monitor has a native resolution of 2560x1600; and that resolution was available (and used by default) prior to this update. I am observing this same problem on both and ION machine and one with a 9800GT card.

Version-Release number of selected component (if applicable):
0.0.16-7.20100423git13c1043.fc13

Comment 1 Braden McDaniel 2010-06-30 05:46:52 UTC
Possibly related to this: system-config-display now crashes on startup with the following terminal output:

$ system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 60, in update_ui
    label.set_text(_("%s with %s")%(self.state.get_monitor_name(), self.state.get_videocard_name()))
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 14-16: invalid data
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 60, in update_ui
    label.set_text(_("%s with %s")%(self.state.get_monitor_name(), self.state.get_videocard_name()))
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 14-16: invalid data
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 378, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 658, in __init__
    self.update_ui()
  File "/usr/share/system-config-display/xConfigDialog.py", line 60, in update_ui
    label.set_text(_("%s with %s")%(self.state.get_monitor_name(), self.state.get_videocard_name()))
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 14-16: invalid data

Comment 2 Ben Skeggs 2010-06-30 06:00:59 UTC
Nothing changed in -7 which could have caused this.

Can you post /var/log/Xorg.0.log and the output of "dmesg" please.

Comment 3 Braden McDaniel 2010-06-30 08:49:40 UTC
I suspected the update since it happened around the same time; but this turned out to be a monitor issue.


Note You need to log in before you can comment on or make changes to this bug.