Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609374 - pv guest install failed caused by anaconda bug
pv guest install failed caused by anaconda bug
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.5
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: Bill Peck
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 02:22 EDT by Eryu Guan
Modified: 2012-10-04 02:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 02:08:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2010-06-30 02:22:04 EDT
Description of problem:
PV guest won't be installed when doing virt test, see installation log here
https://beaker.engineering.redhat.com/logs/2010/13/2513/4855/45548///guest-rhel5u5_i386_pv.log

This may be caused by bug 517051, "xconfig --startxonboot" in kickstart file may lead to headless system failed in installation.
A possible workaround can be found at bug 517051 comment 4

In RHTS kickstart has no "xconfig --startxonboot"


Version-Release number of selected component (if applicable):
0.5.45

How reproducible:
always

Steps to Reproduce:
Submit a job installing headless system as pv guest
Or just clone job 2513
  
Actual results:
fail to install pv guest

Expected results:
pv guest can be installed as in RHTS

Additional info:
Here is a failed job not in a virtual environment
https://beaker.engineering.redhat.com/jobs/5564

More failed jobs
https://beaker.engineering.redhat.com/jobs/2522
https://beaker.engineering.redhat.com/jobs/2519
https://beaker.engineering.redhat.com/jobs/2511
https://beaker.engineering.redhat.com/jobs/2518
https://beaker.engineering.redhat.com/jobs/2505
https://beaker.engineering.redhat.com/jobs/2504
https://beaker.engineering.redhat.com/jobs/2503
Comment 1 David Kovalsky 2010-08-10 12:09:23 EDT
This has been discussed on today's Beaker meeting. "SkipX" fix is easy to do, we just need to make sure that we're not introducing regressions elsewhere (for other teams). 

The next step is to have the testing packages on beaker-stage, where people can give it some hands on to see if everything works as expected.

Gurhan, any thoughts?
Comment 2 David Kovalsky 2010-08-10 12:12:10 EDT
Guan Eryu, bug 517051 is ON_QA. 

Can you give it another shot (with the updated packages) if this is still an issue for you?
Comment 3 Gurhan Ozen 2010-08-10 14:38:48 EDT
(In reply to comment #1)
> This has been discussed on today's Beaker meeting. "SkipX" fix is easy to do,
> we just need to make sure that we're not introducing regressions elsewhere (for
> other teams). 
> 
> The next step is to have the testing packages on beaker-stage, where people can
> give it some hands on to see if everything works as expected.
> 
> Gurhan, any thoughts?    

Yes indeed. skipx is the most appropriate fix here. I think, in fact I am pretty sure, we have used it in many (all?) guest kickstarts in RHTS, not sure what in cobbler have put in xconfig line. It should be ok to put in skipx in all guests' kickstarts.
Comment 4 Eryu Guan 2010-08-10 23:27:48 EDT
(In reply to comment #2)
> Guan Eryu, bug 517051 is ON_QA. 
> 
> Can you give it another shot (with the updated packages) if this is still an
> issue for you?    

I think I couldn't test it with the updated anaconda, as the virtual workflow has to install 5.5 GA version first then install new kernel in guest(I want to test new kernels in guest).
Comment 5 David Kovalsky 2010-11-18 11:32:09 EST
Hey Bill, 

this bug got the target milestone set to 0.5.59. Did it just slip through the cracks when bugs got switched to modified, on_qa, closed - or the patch isn't in at all? 

This is one of the bugs that is tracked as a SignOff Blocker (and suggested as a BeakerBlocker).
Comment 8 David Kovalsky 2010-12-10 02:35:04 EST
The ticket mentioned in comment #6 has been resolved. Resolving this bug too as there seems to be no negative feedback. 

Please reopen if the issue is not resolved according to your needs.
Comment 9 Igor Zhang 2011-01-14 01:37:14 EST
(In reply to comment #8)
> The ticket mentioned in comment #6 has been resolved. Resolving this bug too as
> there seems to be no negative feedback. 
> 
> Please reopen if the issue is not resolved according to your needs.

Hi David,
This week, many of my virt testing jobs failed due to pv or hvm guest installation failure. And their symptoms are different from Comment 0.
https://beaker.engineering.redhat.com/jobs/45562
https://beaker.engineering.redhat.com/jobs/45561
https://beaker.engineering.redhat.com/jobs/45560
https://beaker.engineering.redhat.com/jobs/45558

Could you have a look at above jobs and logs in them?

Thanks
Igor
Comment 12 Dan Callaghan 2012-10-04 01:55:06 EDT
Assuming this is now fixed.

Note You need to log in before you can comment on or make changes to this bug.