Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 609426 - IOException: Input/output error during write on /dev/sdc
IOException: Input/output error during write on /dev/sdc
Status: CLOSED DUPLICATE of bug 831549
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
anaconda_trace_hash:8da4eaf597155723d...
: Reopened
Depends On:
Blocks: 562808 846704
  Show dependency treegraph
 
Reported: 2010-06-30 05:33 EDT by Alexander Todorov
Modified: 2013-05-07 06:37 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-07 06:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (396.67 KB, text/plain)
2010-06-30 05:33 EDT, Alexander Todorov
no flags Details
dmesg info (26.31 KB, text/plain)
2013-05-06 06:24 EDT, langfang
no flags Details

  None (edit)
Description Alexander Todorov 2010-06-30 05:33:26 EDT
The following was filed automatically by anaconda:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 213, in commit
    return self.__disk.commit()
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in commit
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 244, in commit
    self.partedDisk.commit()
  File "/usr/lib/anaconda/storage/devices.py", line 1354, in destroy
    self.disk.originalFormat.commit()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 218, in execute
    self.device.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 700, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1335, in nextClicked
    self.anaconda.dispatch.gotoNext()
IOException: Input/output error during write on /dev/sdc
Comment 1 Alexander Todorov 2010-06-30 05:33:30 EDT
Created attachment 427924 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexander Todorov 2010-06-30 05:35:20 EDT
This was on KVM domU with 3 disks where:
disk #1 is IDE disk
disk #2 is SCSI disk
disk #3 is USB disk - this is sdc.

Default patitioning "Use all space"
Comment 3 RHEL Product and Program Management 2010-06-30 05:43:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Alexander Todorov 2010-06-30 06:00:33 EDT
Note: the underlying I/O error is most likely kernel or related to KVM. I'm not sure how well USB disk devices are supported.
Comment 5 David Cantrell 2010-06-30 08:46:39 EDT
Looks like a hardware problem.  From the syslog:

<6>sd 0:0:0:0: [sdc] Unhandled error code
<6>sd 0:0:0:0: [sdc] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
<6>sd 0:0:0:0: [sdc] CDB: Write(10): 2a 00 00 00 00 00 00 00 08 00
<3>end_request: I/O error, dev sdc, sector 0
<3>Buffer I/O error on device sdc, logical block 0
<4>lost page write due to I/O error on sdc
Comment 6 Alexander Todorov 2010-06-30 10:04:57 EDT
Re-opening and moving to kernel. 

This happens when I add an image file as USB disk in KVM domU. The same file will work when it is added as virtio disk.
Comment 8 Gerd Hoffmann 2010-07-07 11:22:08 EDT
Wild guess: timeouts are too short.

Some facts backing this assumtion:

 * I've seen issues with USB 1.1 only.  Remember that USB 1.1 is *slow*.
 * I've seen this on both real hardware (old laptop with only USB 1.1 support)
   and in kvm (emulates only USB 1.1).
 * I could make the issues going away in kvm by making the uhci emulation poll
   usb devices 10.000 times per second (real hardware does 1.000/sec).
Comment 9 RHEL Product and Program Management 2010-07-15 10:11:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 10 RHEL Product and Program Management 2011-10-07 11:07:36 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 11 Jes Sorensen 2013-02-27 09:37:16 EST
sounds like a limitation in the KVM USB emulation most likely in qemu-kvm?
reassigning to qemu-kvm
Comment 12 Ademar Reis 2013-04-30 17:49:58 EDT
Is this still an issue? Can it be reproduced with recent kernel/qemu packages?
Comment 13 langfang 2013-05-02 07:47:54 EDT
(In reply to comment #12)
> Is this still an issue? Can it be reproduced with recent kernel/qemu
> packages?

   Hi Ademar de Souza Reis Jr.Itest on the latest rhel6 version,not hit the problem.And not sure if my steps are right . By the way ,could can give the steps for reproduce this bug? And the CLI.Thanks.


Host :
# uname -r
2.6.32-369.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.360.el6.x86_64

Gust:
2.6.32-358.el6.x86_64

Steps:
1.Boot guest(ide disk) with virtio disk and usb-storage
...-drive file=/home/storage.qcow2,if=none,id=storage0,media=disk,cache=none,format=qcow2 -usb -device usb-storage,drive=storage0 ..

(qemu)info usb
(qemu) info usb
  Device 0.2, Port 1, Speed 12 Mb/s, Product QEMU USB Tablet
  Device 0.3, Port 2, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.4, Port 2.1, Speed 12 Mb/s, Product QEMU USB MSD

2.After guest boot up, write data on usb-storage
 #mkfs.ext3 /dev/sdb
 #dd if=/dev/zero of=/dev/sdb bs=3M count=200

Results:
not see any error info


MY CLI:
 /usr/libexec/qemu-kvm -M rhel6.4.0  -enable-kvm -m 2G -smp 2 -uuid `uuidgen`  -nodefaults -rtc base=utc -drive file=/home/RHEL-Server-6.4-64-virtio.qcow2,if=none,id=drive-system-disk,format=qcow2,cache=none,serial=QEMU-DISK1 -device ide-drive,drive=drive-system-disk,id=system-disk,bootindex=0  -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:60:3f:29,addr=0x4 -monitor stdio -boot menu=on,order=d -vnc :10 -vga std -usb -device usb-tablet,id=input0 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -drive file=/home/virtio-disk.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=2  -drive file=/home/storage.qcow2,if=none,id=storage0,media=disk,cache=none,format=qcow2 -usb -device usb-storage,drive=storage0 -serial unix:/tmp/tty0,server,nowait -boot order=c,menu=on -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-1-0,id=ide0-1-0
Comment 14 langfang 2013-05-02 07:52:14 EDT
  Hi Ademar de Souza Reis Jr.Itest,could you can test on the latest version for the bug . By the way ,what's the kernel and qemu-kvm version for the bug you hit. 





best regards 
fang lang
Comment 15 langfang 2013-05-02 21:50:35 EDT
Hi,Alexander

    Please help me see comment13 and comment14.Could you can give me the steps and version for reproduce this bug ? Thanks very much.
Comment 16 langfang 2013-05-06 06:22:23 EDT
  Try to install guest(virtio-blk) with three disk : disk1: IDE disk2:virtio disk:usb-storge .Not see any problem


Test version: 
Host:
# uname -r
2.6.32-373.el6.x86_64
[root@localhost home]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.362.el6.x86_64

Guest:
2.6.32-353.el6.x86_64


steps:
1.Install guest 
 /usr/libexec/qemu-kvm -M rhel6.4.0  -enable-kvm -m 2G -smp 2 -uuid `uuidgen`  -nodefaults -rtc base=utc -drive file=/home/bug609426-new3.qcow2,if=none,id=drive-system-disk,format=qcow2,cache=none,serial=QEMU-DISK1 -device virtio-blk-pci,drive=drive-system-disk,id=system-disk,bootindex=0  -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:60:3f:29,addr=0x4 -monitor stdio  -vnc :10 -vga std -usb -device usb-tablet,id=input0 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -drive file=/home/ide-disk.qcow2,if=none,id=drive-system-disk-1,format=qcow2,cache=none -device ide-drive,bus=ide.1,unit=0,drive=drive-system-disk-1,id=system-disk-1 -drive file=/home/virtio-disk.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=2  -drive file=/home/storage.qcow2,if=none,id=storage0,media=disk,cache=none,format=qcow2  -device usb-storage,drive=storage0 -serial unix:/tmp/tty0,server,nowait  -drive file=/home/RHEL6.4-20130109.1-Server-x86_64-DVD1.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-1-0,id=ide0-1-0
(qemu) info usb
  Device 0.2, Port 1, Speed 12 Mb/s, Product QEMU USB Tablet
  Device 0.3, Port 2, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.4, Port 2.1, Speed 12 Mb/s, Product QEMU USB MSD

Results:

Not see any problem ,dmesg info see attachment.Usb-storage is sdb
Comment 17 langfang 2013-05-06 06:24:59 EDT
Created attachment 744060 [details]
dmesg info
Comment 18 langfang 2013-05-07 06:02:52 EDT
Reproduce this bug as following version
# uname -r
2.6.32-37.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.80.el6.x86_64

Guest:
2.6.32-71.el6.x86_64

steps :
1.qemu-img create -f qcow2 storage-disk.qcow2 5G
2.Install rhel guest 
 /usr/libexec/qemu-kvm -M rhel6.0.0 -enable-kvm -m 2192 -smp 2,sockets=2,cores=1,threads=1 -name bug-test -uuid 333c70a8-6ec1-7944-5c29-4dcedcdd1348 -nodefconfig -nodefaults -monitor stdio -rtc base=utc  -drive file=/home/RHEL-Server-6.0-64.qcow2,if=none,id=drive-ide0-0-0,boot=on,format=qcow2,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/home/virtio-disk.qcow2,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/home/ide-disk.qcow2,if=none,id=drive-ide0-0-1,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -drive file=/home/storage-disk.qcow2,if=none,id=drive-usb-disk0,format=qcow2 -device usb-storage,drive=drive-usb-disk0,id=usb-disk0 -netdev tap,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:87:af:c1,bus=pci.0,addr=0x3 -usb -vnc :10 -vga cirrus -device AC97,id=sound0,bus=pci.0,addr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5 -serial unix:/tmp/tty0,server,nowait

2.After install finished,format the usb-storage disk 
#mkfs.ext3 /dev/sdc--->usb storage

Results: Wait about 5~10 min,
#nc -U /tmp/tty0
Red Hat Enterprise Linux Server release 6.0 (Santiago)
Kernel 2.6.32-71.el6.x86_64 on an x86_64

localhost.localdomain login: end_request: I/O error, dev sdc, sector 720
Buffer I/O error on device sdc, logical block 90
end_request: I/O error, dev sdc, sector 480
Buffer I/O error on device sdc, logical block 60
Buffer I/O error on device sdc, logical block 61
Buffer I/O error on device sdc, logical block 62
Buffer I/O error on device sdc, logical block 63
Buffer I/O error on device sdc, logical block 64
Buffer I/O error on device sdc, logical block 65
Buffer I/O error on device sdc, logical block 66
Buffer I/O error on device sdc, logical block 67
Buffer I/O error on device sdc, logical block 68
end_request: I/O error, dev sdc, sector 0
Buffer I/O error on device sdc, logical block 0
Buffer I/O error on device sdc, logical block 1
Buffer I/O error on device sdc, logical block 2
Buffer I/O error on device sdc, logical block 3
Buffer I/O error on device sdc, logical block 4
Buffer I/O error on device sdc, logical block 5
Buffer I/O error on device sdc, logical block 6
Buffer I/O error on device sdc, logical block 7
Buffer I/O error on device sdc, logical block 8
Buffer I/O error on device sdc, logical block 9
end_request: I/O error, dev sdc, sector 240
Buffer I/O error on device sdc, logical block 30
Buffer I/O error on device sdc, logical block 31
Buffer I/O error on device sdc, logical block 32
Buffer I/O error on device sdc, logical block 33
Buffer I/O error on device sdc, logical block 34
Buffer I/O error on device sdc, logical block 35
Buffer I/O error on device sdc, logical block 36
Buffer I/O error on device sdc, logical block 37
Buffer I/O error on device sdc, logical block 38
Buffer I/O error on device sdc, logical block 39
end_request: I/O error, dev sdc, sector 728
Buffer I/O error on device sdc, logical block 91
Buffer I/O error on device sdc, logical block 92
Buffer I/O error on device sdc, logical block 93
Buffer I/O error on device sdc, logical block 94
Buffer I/O error on device sdc, logical block 95
Buffer I/O error on device sdc, logical block 96
Buffer I/O error on device sdc, logical block 97
Buffer I/O error on device sdc, logical block 98
Buffer I/O error on device sdc, logical block 99
Buffer I/O error on device sdc, logical block 100
end_request: I/O error, dev sdc, sector 968
Buffer I/O error on device sdc, logical block 121
Buffer I/O error on device sdc, logical block 122
Buffer I/O error on device sdc, logical block 123
Buffer I/O error on device sdc, logical block 124
Buffer I/O error on device sdc, logical block 125
Buffer I/O error on device sdc, logical block 126
Buffer I/O error on device sdc, logical block 127
Buffer I/O error on device sdc, logical block 128
Buffer I/O error on device sdc, logical block 129
Buffer I/O error on device sdc, logical block 130
end_request: I/O error, dev sdc, sector 1208
Buffer I/O error on device sdc, logical block 151
Buffer I/O error on device sdc, logical block 152
Buffer I/O error on device sdc, logical block 153
Buffer I/O error on device sdc, logical block 154
Buffer I/O error on device sdc, logical block 155
Buffer I/O error on device sdc, logical block 156
Buffer I/O error on device sdc, logical block 157
Buffer I/O error on device sdc, logical block 158
Buffer I/O error on device sdc, logical block 159
Buffer I/O error on device sdc, logical block 160
end_request: I/O error, dev sdc, sector 1448
....

#dmesg 
...
Buffer I/O error on device sdc, logical block 600
lost page write due to I/O error on sdc
Buffer I/O error on device sdc, logical block 601
lost page write due to I/O error on sdc
usb 1-1: reset full speed USB device using uhci_hcd and address 2
usb 1-1: reset full speed USB device using uhci_hcd and address 2
usb 1-1: reset full speed USB device using uhci_hcd and address 2
usb 1-1: reset full speed USB device using uhci_hcd and address 2
usb 1-1: reset full speed USB device using uhci_hcd and address 2
usb 1-1: reset full speed USB device using uhci_hcd and address 2
sd 2:0:0:0: [sdc] Unhandled error code
sd 2:0:0:0: [sdc] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
sd 2:0:0:0: [sdc] CDB: Write(10): 2a 00 00 00 00 00 00 00 08 00
end_request: I/O error, dev sdc, sector 0
...

Test on latest version:
# uname -r
2.6.32-373.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.362.el6.x86_64

Guest:
2.6.32-71.el6.x86_64

Steps as same as reproduce ,Tried about 10 times,not hit the problem

Atttional info:for reproduce this bug ,you no need to install new guest ,this trigger by usb-storage.
Comment 19 langfang 2013-05-07 06:27:42 EDT
HI ,Gerd
    Could you please help me see comment18 ? And if we can closed this bug .



thanks 
fang lang
Comment 20 Gerd Hoffmann 2013-05-07 06:37:59 EDT
Most likely it is a dup of 831549.  uhci emulation used to be an order of magnitude slower than on real hardware, which probably was the issue here.

*** This bug has been marked as a duplicate of bug 831549 ***

Note You need to log in before you can comment on or make changes to this bug.