Bug 609431 - Symbol lookup error of libspice-server.so
Summary: Symbol lookup error of libspice-server.so
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server   
(Show other bugs)
Version: 6.0
Hardware: All Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: TestBlocker
: 610031 (view as bug list)
Depends On: 482556
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 09:54 UTC by Amos Kong
Modified: 2015-05-25 00:05 UTC (History)
5 users (show)

Fixed In Version: spice-server-0.4.2-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 14:07:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Amos Kong 2010-06-30 09:54:18 UTC
Description of problem:
After updated spice-server to 0.4.2-13.el6, I touched a problem :
# qemu-kvm -h
qemu-kvm: symbol lookup error: /usr/lib64/libspice-server.so.0: undefined symbol: gl_canvas_draw_stroke

Version-Release number of selected component (if applicable):
qemu-kvm: 0.12.1.2-2.90.el6
# rpm -qa |grep spice
spice-server-0.4.2-13.el6.x86_64
ffmpeg-spice-libs-0.4.9-0.15.5spice.20080908.el6.x86_64
cairo-spice-1.8.7.1-4.el6.x86_64
pixman-spice-0.13.3-5.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. execute  "# qemu-kvm -h"

Comment 1 Amos Kong 2010-06-30 10:07:48 UTC
This bug caused qemu-kvm could not be executed. Adjust the Priority to urgent.

Comment 4 Amos Kong 2010-06-30 10:28:15 UTC
Moved back to spice-server component.

Comment 5 Uri Lublin 2010-06-30 14:07:18 UTC
The issue was solved via #482556 in spice-server-0.4.2-14.el6
Closing as CURRENTRELEASE.
Amos Kong, thanks for the quick report.

Comment 6 Uri Lublin 2010-07-07 07:00:39 UTC
*** Bug 610031 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.