Bug 60945 - can't view trivial file with gv
Summary: can't view trivial file with gv
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gv   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901 67218 79579
TreeView+ depends on / blocked
 
Reported: 2002-03-10 05:30 UTC by Jonathan Kamens
Modified: 2014-03-17 02:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-24 20:41:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PostScript file that gv can't view (12.45 KB, application/postscript)
2002-03-10 05:31 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2002-03-10 05:30:27 UTC
I have:

  gv-3.5.8-15
  ghostscript-6.53-4
  XFree86-4.2.0-6.39

I am reporting this as an XFree86 bug because I believe the only thing that has
changed recently is XFree86.

When I attempt to view the attached trivial PostScript file with gv, I get an
error dialog that says this:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  73 (X_GetImage)
  Serial number of failed request:  36
  Current serial number in output stream:  36

Error: PostScript interpreter failed in main window.

Oddly enough, I can view the file if I convert it to PDF with ps2pdf.

Comment 1 Jonathan Kamens 2002-03-10 05:31:05 UTC
Created attachment 48044 [details]
PostScript file that gv can't view

Comment 2 Tim Waugh 2002-05-22 11:01:21 UTC
Changing component to gv.

Comment 3 Elliot Lee 2003-02-21 21:33:24 UTC
Works here with rawhide-ish X/gv/ghostscript.

Comment 4 Jonathan Kamens 2003-02-22 23:22:46 UTC
I have gv-3.5.8-22, XFree86-4.2.0-72, and ghostscript-7.05-27, and it's still
failing for me.  Unfortunately I can't upgrade these packages to current Raw
Hide because to do that would require upgrading others that would break
compatibility with vmware.  However, I've got more current packages on my
machine at work, so I'll try there on Monday and see what happens.


Comment 5 Jonathan Kamens 2003-02-24 20:41:54 UTC
Yup, works for me with current raw hide.



Note You need to log in before you can comment on or make changes to this bug.