Bug 609495 - SELinux is preventing /sbin/ebtables "search" access .
SELinux is preventing /sbin/ebtables "search" access .
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
setroubleshoot_trace_hash:4ae00ef9eeb...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 08:39 EDT by Matěj Cepl
Modified: 2012-10-16 06:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-32.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:35:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2010-06-30 08:39:32 EDT
Souhrn:

SELinux is preventing /sbin/ebtables "search" access .

Podrobný popis:

[ebtables je v toleratním režimu (virtd_t). Přístup byl povolen.]

SELinux denied access requested by ebtables. It is not expected that this access
is required by ebtables and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Další informace:

Kontext zdroje                system_u:system_r:virtd_t:s0-s0:c0.c1023
Kontext cíle                 system_u:object_r:sysctl_kernel_t:s0
Objekty cíle                 None [ dir ]
Zdroj                         ebtables
Cesta zdroje                  /sbin/ebtables
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          ebtables-2.0.9-5.el6
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.7.19-27.el6
Selinux povolen               True
Typ politiky                  targeted
Vynucovací režim            Enforcing
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.32-37.el6.x86_64 #1
                              SMP Sun Jun 20 19:29:35 EDT 2010 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               St 30. červen 2010, 14:32:33 CEST
Naposledy viděno             St 30. červen 2010, 14:32:33 CEST
Místní ID                   3e63d132-40ea-40b4-97e4-331630494b0f
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1277901153.94:14): avc:  denied  { search } for  pid=2014 comm="ebtables" scontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysctl_kernel_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1277901153.94:14): arch=c000003e syscall=2 success=yes exit=73014444160 a0=3c8b60b37a a1=0 a2=3c8b810da0 a3=7fff71c577b0 items=0 ppid=2013 pid=2014 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ebtables" exe="/sbin/ebtables" subj=system_u:system_r:virtd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,ebtables,virtd_t,sysctl_kernel_t,dir,search
audit2allow suggests:

#============= virtd_t ==============
allow virtd_t sysctl_kernel_t:dir search;
Comment 2 RHEL Product and Program Management 2010-06-30 09:03:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Miroslav Grepl 2010-06-30 09:59:01 EDT

*** This bug has been marked as a duplicate of bug 609493 ***
Comment 4 Miroslav Grepl 2010-07-01 12:55:52 EDT
This is different issue.

Matej,
could you try to execute

chcon -t iptables_exec_t /sbin/ebtables
Comment 5 Miroslav Grepl 2010-07-08 03:56:25 EDT
Virt folks,
are you seeing any problems relating to ebtables and libvirt? Could you test it?
Comment 6 Daniel Walsh 2010-07-12 11:28:08 EDT
Miroslav this is the label we have in Rawhide, so lets make it this in RHEL6.
Comment 7 Miroslav Grepl 2010-07-12 11:38:43 EDT
Yes, I added it to Rawhide and will update F13/RHEL6 policy.
Comment 10 Miroslav Grepl 2010-07-14 10:28:18 EDT
Fixed in selinux-policy-3.7.19-32.el6.noarch
Comment 13 releng-rhel@redhat.com 2010-11-10 16:35:07 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.