Bug 609531 - Gpk-Service-Pack. Can't make service pack.
Gpk-Service-Pack. Can't make service pack.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 10:13 EDT by Krystian
Modified: 2013-01-10 01:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 15:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krystian 2010-06-30 10:13:50 EDT
Description of problem:

Fedora 13, Gpk-service-pack from gnome-package-extra. I can't create list of installed packages in system:

"Nie można zapisać pliku: Utworzenie pliku "/var/lib/PackageKit/system.package-list.GRD0EV" się nie powiodło: Brak dostępu"

In english: Can't write the file, no permissions. OK, but when i run gpk service package as root, program freeze, i click create packages list option but application never create this file, status is always on 0%, even after 1 hour. I saw video tutorial, where base are created by normal user i /home - why i can't? Console says nothing about this. 

But i run app as root and copy /var/lib/PackageKit/system.package.list (gpk create this file, but program sill freeze on 0% progress). Next i run gpg-service-pack as normal user and drag and drop this file to app window (gpk can't see this file normally, i don't know why, he should). Now when i want to create service pack i have:

"The package id's '' are not valid"

Why i can't create this damn service pack?  >:-/

See - on this vtutorial everything works as Normal User: http://www.youtube.com/watch?v=WfLTmiaDCe4

Version-Release number of selected component (if applicable): from Fedora 13 repository.


How reproducible: Try to make service pack using gpk-service-pack


Steps to Reproduce:
1.Run gpg-service pack
2.Try to create system package list
3.
  
Actual results:

One big fail.


Expected results:

Successfully create system service pack 

Additional info:
Comment 1 Jesse Keating 2010-06-30 12:10:28 EDT
Guessing it's gnome-packagekit given the "gpk".
Comment 2 Krystian 2010-07-01 08:13:04 EDT
Yes - gpk = gnome-packagekit. Problem are with app called gpk-service pack from gnome-packagekit-extra package. I found workaround to build service pack with this script:

"#!/bin/sh

# verify all tools available
if [ ! -f /usr/bin/yumdownloader ] ; then
  echo This script requires that the yum-utils package be installed
  exit 1
fi
if [ ! -f /usr/bin/mkisofs ] ; then
  echo This script requries that the genisoimage package be installed
  exit 1
fi

# download RPMS
cd /tmp
mkdir -p rpmCD
cd rpmCD
for pkg in `rpm -qa | sort` ; do
  if [ ! -f $pkg.rpm ] ; then
    echo Downloading $pkg
    yumdownloader -y $pkg >& /dev/null
    if [ $? -ne 0 ] ; then
      echo ERRRO: unable to download $pkg
    fi
  else
    echo $pkg already downloaded
  fi
done
cd ..

# prepare CD image
mkisofs -J -R -o rpmCD.iso rpmCD

# EOF"

But it's not a solution - still i want to use gpk-service-pack, but i can't.
Comment 3 Richard Hughes 2010-07-01 09:46:30 EDT
I've just applied the following fixes:

commit 96cbef5d16e32616e8b1763c52ab9ba52cf42ae2
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Jul 1 14:45:55 2010 +0100

    Ensure we reset the UI to sensitive after creating the system package list

:100644 100644 6d6bba5... 0c5056f... M  src/gpk-service-pack.c

commit eaed0d47955698daba1c7b5e1e3a14987847670b
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Jul 1 14:45:06 2010 +0100

    Save the package lists to the specified directory, not the system default. Fixes rh#609531

:100644 100644 091d916... 6d6bba5... M  src/gpk-service-pack.c

commit 7b17ee4d0f9637cd592f65fc51a616a1f13a41ed
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Jul 1 13:31:46 2010 +0100

    Ensure files created with gpk-service-pack do not have ';' in them
Comment 4 Krystian 2010-07-01 11:20:42 EDT
So fixed version will be soon in system updates?
Comment 5 Richard Hughes 2010-07-01 11:44:21 EDT
(In reply to comment #4)
> So fixed version will be soon in system updates?    

Yes, I'll do a 2.30.2 at the beginning of next week.
Comment 6 Krystian 2010-07-01 11:51:06 EDT
Thank You very much. So i wait to next week. If something still will be wrong - i write here :-)
Comment 7 Bug Zapper 2011-06-01 11:10:12 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2011-06-27 15:11:48 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.