Bug 609540 - Right-clicking on totem player plugin window in Firefox freezes browser
Summary: Right-clicking on totem player plugin window in Firefox freezes browser
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: totem   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 14:37 UTC by Tomasz Zieja
Modified: 2010-06-30 16:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 16:24:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomasz Zieja 2010-06-30 14:37:23 UTC
Description of problem:

The problem applies to totem plugin for mozilla Firefox web browser. When one opens page containing multimedia content that should be played using totem plugin and presses right mouse button "over" player window - firefox freezes and must be restarted. If you do not press right mouse button - plugin works correctly and multimedia content is played.


Version-Release number of selected component (if applicable):
totem-mozplugin-2-30.2-1.fc13

How reproducible:
Every time you click right mouse button.

Steps to Reproduce:
1. Click right mouse button on totem player in mozilla web browser.

  
Actual results:
Firefox freezes.

Expected results:
Totem preferences should open.

Additional info:
Flashplayer seems to work fine, Firefox doesn't freeze and properties are displayed

Comment 1 Bastien Nocera 2010-06-30 15:37:48 UTC
I really don't see how that could happen, given that Totem's plugin (the one that actually plays the video) runs in a different process.

Feel free to prove me wrong with a backtrace of the problem when Firefox is hung.

Comment 2 Tomasz Zieja 2010-06-30 16:24:16 UTC
After some tweaking I realized I have completely missed the point in this report. The problem was not with totem but with nspluginwrapper process which was launched and hanged the browser. Firefox resumed operation when I killed it. I don't know why it was launched though. After deinstalling nspluginwrapper everything seems to be fine.


Note You need to log in before you can comment on or make changes to this bug.