Bug 609551 - coretemp of RHEL5.5 kernel-2.6.18-194.3.1.el5 does not support CPUs since 0x17
coretemp of RHEL5.5 kernel-2.6.18-194.3.1.el5 does not support CPUs since 0x17
Status: CLOSED DUPLICATE of bug 559228
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 11:19 EDT by Gerrit Slomma
Modified: 2010-09-01 14:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 09:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerrit Slomma 2010-06-30 11:19:53 EDT
Description of problem:

The coretemp.ko of RHEL 5.5 does not suppot Intel CPUs since 0x17 (at least, earlier models could be affected as well)

Version-Release number of selected component (if applicable):

kernel-2.6.18-194.3.1.el5

How reproducible:

every time.

Steps to Reproduce:
1. install lm_sensors
2. run sensors-detect
3. coretemp is detected (on Core2-Family, on Nehalem family it is NOT detected!)
  
Actual results:

no sensors found, kernel-message generated as follows on Core 2 Quad Q9550 or Xeon L5408:

# dmesg
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17

Expected results:

on Core 2 Quad Q9550:

# sensors|grep Core
Core 3:      +42.0°C  (high = +76.0°C, crit = +100.0°C)
Core 2:      +43.0°C  (high = +76.0°C, crit = +100.0°C)
Core 1:      +44.0°C  (high = +76.0°C, crit = +100.0°C)
Core 0:      +49.0°C  (high = +76.0°C, crit = +100.0°C)

on Xeon W3520 (Nehalem)

# sensors|grep Core
Core 0:      +49°C  (high =  +100°C)
Core 1:      +48°C  (high =  +100°C)
Core 2:      +49°C  (high =  +100°C)
Core 3:      +47°C  (high =  +100°C)
Core 4:      +49°C  (high =  +100°C)
Core 5:      +48°C  (high =  +100°C)
Core 6:      +49°C  (high =  +100°C)
Core 7:      +47°C  (high =  +100°C)

Additional info:

backport as described here:

http://kerneltrap.org/mailarchive/linux-kernel/2010/5/10/4567713

works, lead to the above posted values.
Comment 1 Prarit Bhargava 2010-07-07 09:20:00 EDT
Please be advised, that Bugzilla is not a support tool. It is an
Engineering and Community tool. So although all changes to Enterprise
Linux go through Bugzilla and Red Hat considers issues directly entered
into Bugzilla valuable feedback, there is no SLA around it.

If this is a production issue, please report it to your Red Hat Support contact.

Thank you.
Comment 2 Gerrit Slomma 2010-07-07 13:17:24 EDT
Do you mean via TAM or Customer Center? The last time i file a bug there and in bugzilla the bug was fixed for Fedora but NOT for RHEL. Another filed bug needed almost half a year to get fixed. This was my reason to NOT extend my subscription: Not the slightest benefit from it. I would try via my company's subscriptions tomorrow (we have 50+). I thought it was the philosophy of Red Hat to provide a stable business platform? Those CPUs are out now for months and up to RHEL 5.5 there even wasn't support for those sensors, now there is support but with one very old kernel-module, i can't believe it, i have to backport the module myself.
Comment 3 Prarit Bhargava 2010-09-01 09:29:14 EDT
Gerrit,

Bugzilla is an open community tool by which the general public and our customers can report bugs.  Red Hat cannot possibly handle all feature requests from the general public.

By not reporting this issue through your TAM or customer support center, this request was pooled in with other general public feature requests.

Support and Engineering cannot adequately determine who is a customer and who isn't a customer because users tend to have multiple bugzilla accounts with different email addresses.

In the future, you should request additional feature support through your TAM.

Thanks,

P.
Comment 4 Dean Nelson 2010-09-01 14:28:38 EDT
(In reply to comment #2)
> subscriptions tomorrow (we have 50+). I thought it was the philosophy of Red
> Hat to provide a stable business platform? Those CPUs are out now for months
> and up to RHEL 5.5 there even wasn't support for those sensors, now there is
> support but with one very old kernel-module, i can't believe it, i have to
> backport the module myself.

The following upstream commit has been backported to RHEL5.6 and will resolve the issue you've reported by using a CPUID instruction to detect whether an Intel CPU has a thermal sensor or not.

  http://git.kernel.org/linus/5db47b009d17d69a2f8d84357e7b24c3e3c2edec

This was done as a part of backporting a 2-patch patchset for bug 580699.

I'm marking this bug as a duplicate of bug 559228 which does report the same problem as reported by this bug. It was resolved for RHEL5.6 by refreshing drivers/hwmon/coretemp.c to be as much like upstream as possible. It did get the list of supported CPUs 'current' for that time (including 0x17).

Since that time, the fore-mentioned commit was added to linux-2.6 and it replaced the list of CPUs by actually detecting whether a CPU has a thermal sensor. The backport of this commit for bug 580699 brings the issue reported by this bug and bug 559228 to a better closure.

Dean

*** This bug has been marked as a duplicate of bug 559228 ***

Note You need to log in before you can comment on or make changes to this bug.