Bug 609674 - strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:159 fail tracker
strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:159 fail tracker
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
: Tracking
: 603941 609645 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 16:12 EDT by Rex Dieter
Modified: 2014-03-04 14:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 14:00:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-06-30 16:12:50 EDT
OK, here's the next big class of nepomuk/strigi related abrt crashers coming in, they all have a backtrace similar in form to:

#3  0x006e2da8 in __assert_fail (assertion=0x6a72f2c "m_parentpath == \"\"", 
    file=
    0x6a72d08 "/builddir/build/BUILD/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp", line=159, function=
    0x6a72f80 "Strigi::AnalysisResult::Private::Private(const std::string&, time_t, Strigi::IndexWriter&, Strigi::StreamAnalyzer&, const std::string&, Strigi::AnalysisResult&)") at assert.c:81
        buf = 
    0xb54720c0 "nepomukservicestub: /builddir/build/BUILD/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:159: Strigi::AnalysisResult::Private::Private(const std::string&, time_t, Strigi::IndexWriter&, Strigi::Str"...
#4  0x06a2a6ec in Strigi::AnalysisResult::Private::Private (this=0xb5434950, 
    p="/", mt=1277895147, w=..., indexer=..., parentpath="/", t=...)
    at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:159
        i = <value optimized out>
        pos = 0
#5  0x06a2a7eb in Strigi::AnalysisResult::AnalysisResult (this=0xb5f0c068, 
    path="/", mt=1277895147, w=..., indexer=..., parentpath="/")
    at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:177
No locals.
#6  0x00260ae4 in Nepomuk::IndexScheduler::analyzeFile (this=0x8da1ac8, file=
    ..., analyzer=0xb5f0c27c)
    at /usr/src/debug/kdebase-runtime-4.4.4/nepomuk/services/strigi/indexscheduler.cpp:416
Comment 1 Rex Dieter 2010-06-30 16:13:09 EDT
*** Bug 609645 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2010-06-30 16:16:53 EDT
*** Bug 603941 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2014-03-04 14:00:22 EST
Haven't seen these in a long while (and since nepomuk isn't based on strigi anymore).... closing.

Note You need to log in before you can comment on or make changes to this bug.