Bug 609678 - Sporadic cluster_test failure in testConnectionKnownHosts
Summary: Sporadic cluster_test failure in testConnectionKnownHosts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp   
(Show other bugs)
Version: beta
Hardware: All Linux
high
medium
Target Milestone: 1.3
: ---
Assignee: Alan Conway
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 20:15 UTC by Alan Conway
Modified: 2013-02-25 10:38 UTC (History)
1 user (show)

Fixed In Version: 0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 10:38:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Conway 2010-06-30 20:15:39 UTC
Description of problem:

cluster_test fails with:
cluster_test.cpp(547): error in "testConnectionKnownHosts": check kb0 == kb2 failed [42179 57640  != 44199 57640 ] 

Version-Release number of selected component (if applicable): r59419


How reproducible: not very. Occurred once under ptol


Steps to Reproduce: Cannot reproduce so far.

  
Actual results: test fails


Expected results: test pass


Additional info:

Comment 1 Alan Conway 2010-07-01 19:21:34 UTC
Not reproduced but by analysis this is a test problem, test can end up using out of date cluster membership from connection's initial-broker list.

Fixed r959751


Note You need to log in before you can comment on or make changes to this bug.