Bug 60968 - pdftexinfo.tex mishandles all cross-references
pdftexinfo.tex mishandles all cross-references
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
http://www.tug.org/pipermail/pdftex/2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-10 16:31 EST by George Moody
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-14 08:27:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Moody 2002-03-10 16:31:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
The recent tetex update broke texinfo's handling of cross-references
when using texinfo's '--pdf' option (which invokes pdflatex).  The
tetex package from Rawhide has the same problem.  The tetex package
from 7.1 and the original version that came with 7.2 did not exhibit
the problem.  The problem must be fixed within the tetex package, not
within texinfo.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get any texinfo-format file that contains at least one
   cross-reference (i.e., a use of @xref or @pxref) -- for the
   example, suppose its name is 'foo.tex'.
2. Verify that it's syntactically correct by generating a DVI file
   from it:
	texi2dvi foo.tex	 
3. Try to format it as PDF:
	texi2dvi --pdf foo.tex

	

Actual Results:  texi2dvi --pdf foo.tex
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C 7.3.3.1)
(/tmp/t2d12612/xtr/foo.tex{/usr/share/texmf/pdftex/config/pdftex.cfg}
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman,
italian, nohyphenation, loaded.
(/usr/share/texmf/pdftex/texinfo/texinfo.tex
(/usr/share/texmf/pdftex/texinfo/pdftexinfo.tex
Loading texinfo [version 1999-03-26.17]:
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex) Basics, fonts,
page headings, tables, conditionals, indexing, sectioning, toc, environments,
defuns, macros, cross references, (/usr/share/texmf/tex/plain/dvips/epsf.tex)
localization, and turning on texinfo input format.)) [1{/usr/share/texmf/dvips/
config/pdftex.map
Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxphvbo': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxphvro': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxptmbo': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxptmro': SlantFont/ExtendFont can be used only with embedded T1 fonts
}] [2] [-1] [-2] (Preface)
! Undefined control sequence.
@xrefX ...ename .pdf} name{#1}@else @pdfannotlink 
                                                  attr{/Border [0 0 0]}goto ...
l.134 ...g programs that use them (@pxref{Sources}
                                                  , for information
? x

(The warnings about invalid entries in pdftex.map are symptoms of
a different problem, but that problem is much less serious.)

Expected Results:  texi2dvi --pdf foo.tex
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C 7.3.3.1)
(/tmp/t2d12924/xtr/foo.tex{/usr/share/texmf/pdftex/config/pdftex.cfg}
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman,
italian, nohyphenation, loaded.
(/usr/share/texmf/pdftex/texinfo/texinfo.tex
Loading texinfo [version 2001-06-21.10]: Basics, pdf,
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex) fonts, page headings,
tables, conditionals, indexing, sectioning, toc, environments, defuns, macros,
cross references, (/usr/share/texmf/tex/plain/dvips/epsf.tex) localization,
and turning on texinfo input format.) [1{/usr/share/texmf/dvips/config/pdftex.m
ap
Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxphvbo': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxphvro': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxptmbo': SlantFont/ExtendFont can be used only with embedded T1 fonts

Warning: pdftex (file /usr/share/texmf/dvips/config/pdftex.map): invalid entry 
for `rtxptmro': SlantFont/ExtendFont can be used only with embedded T1 fonts
}] [2] [-1] [-2] (Preface)
Cross reference values unknown; you must run TeX again. [1] [2] [3] [4]
[5] [6] [7] Chapter 1 [8] [9] [10] [11] [12] [13] [14] Chapter 2 [15] [16]
[... more output, ending with ...]
(see the transcript file for additional information)</usr/share/texmf/fonts/typ
e1/bluesky/cm/cmr9.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmb10.pfb></usr
/share/texmf/fonts/type1/bluesky/cm/cmsltt10.pfb></usr/share/texmf/fonts/type1/
bluesky/cm/cmti10.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmsl10.pfb></usr
/share/texmf/fonts/type1/bluesky/cm/cmtt10.pfb></usr/share/texmf/fonts/type1/bl
uesky/cm/cmsy10.pfb></usr/share/texmf/fonts/type1/bluesky/cm/cmr10.pfb></usr/sh
are/texmf/fonts/type1/bluesky/cm/cmbx12.pfb>
Output written on foo.pdf (130 pages, 519700 bytes).


Additional info:

See texinfo's ChangeLog entry for 2001-06-13:
 (\xrefX): pdf link defs no longer use @, so link refs shouldn't use @
 either. (All xrefs in pdf were failing.)
This problem was corrected in texinfo-4.0d, but tetex comes with its
own copy of texinfo.tex (named pdftexinfo.tex), which is considerably
older.  The previous tetex package didn't exhibit the error because of
some other bug in pdflatex -- but now that has been fixed, and the
problem I'm reporting reappears.  I fixed this problem on my 7.2
system like this:
 cp /usr/share/automake/texinfo.tex /usr/share/texmf/pdftex/texinfo/
The "expected results" above are what I obtained after applying this
fix.
Comment 1 Tim Waugh 2002-03-12 11:47:55 EST
Thanks for the report.  This seems easy to fix, as you say.
Comment 2 Tim Waugh 2002-03-14 06:12:20 EST
Presumably you mean:

cp /usr/share/automake/texinfo.tex /usr/share/texmf/pdftex/texinfo/pdftexinfo.tex

?
Comment 3 George Moody 2002-03-14 08:27:44 EST
As far as I can tell, it doesn't matter if the new texinfo.tex is installed
as texinfo.tex or as pdftexinfo.tex (since pdftex's existing texinfo.tex just
inputs pdftexinfo.tex).

I picked the newer texinfo.tex from automake because it was handy, but I notice
that the PDFs generated using it still have cross-reference problems (references
from the TOC work, but those within the text don't).  The latest texinfo.tex
from ftp://ftp.gnu.org/gnu/texinfo.tex (from texinfo-4.1, with texinfoversion
2002-03-01.06) is a better choice for a replacement since all cross-refs appear
to work properly.
Comment 4 Tim Waugh 2002-03-21 16:23:12 EST
Should be fixed in 1.0.7-45.

Note You need to log in before you can comment on or make changes to this bug.