Bug 609686 - Anaconda debug fail (MSDOS partition -> Software Raid)
Anaconda debug fail (MSDOS partition -> Software Raid)
Status: CLOSED DUPLICATE of bug 570474
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 16:32 EDT by Mike McGrath
Modified: 2010-06-30 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 17:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The dump from this error (31.98 KB, application/x-gzip)
2010-06-30 17:08 EDT, Mike McGrath
no flags Details
plaintext exception report (178.25 KB, text/plain)
2010-06-30 17:55 EDT, David Lehman
no flags Details

  None (edit)
Description Mike McGrath 2010-06-30 16:32:49 EDT
Description of problem:

I incorrectly filed #609651.  In telling anaconda to install the boot loader on /dev/md0, both of those partitions got converted to a partition table (MSDOS) type.  

When attempting to re-install, I now see sd[b-c]1 set as the MSDOS partition type.  When clicking edit, then changing format as to software raid, anaconda throws an error message.  Upon clicking debug it prints just:

Entering debugger...
> /usr/lib/anaconda/storage/devices.py(697)_setFormat()
-> raise DeviceError("cannot replace active format", self.name)


Version-Release number of selected component (if applicable):

Whatever comes with RHEL6 beta 2 that shipped today

How reproducible:

Every time.
Comment 1 Chris Lumens 2010-06-30 16:48:43 EDT
Can you please attach the complete /tmp/anaconda-tb-* file to this bug report?  There are several bugs with this same message, and it'd be helpful seeing the exact circumstances leading to it before knowing which is the dupe.
Comment 3 RHEL Product and Program Management 2010-06-30 17:03:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Mike McGrath 2010-06-30 17:08:45 EDT
Created attachment 428100 [details]
The dump from this error
Comment 5 Mike McGrath 2010-06-30 17:09:20 EDT
FWIW, I've tried a few different options from the partition selection menu (clear all parts, manual, etc) all of them error out.
Comment 6 Mike McGrath 2010-06-30 17:50:29 EDT
More details on this.  The partition type being reported in anaconda does not match what fdisk reports:

Command (m for help): p

Disk /dev/sdb: 146.8 GB, 146814976000 bytes
255 heads, 63 sectors/track, 17849 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0007d83f

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          64      512000   fd  Linux raid autodetect
Partition 1 does not end on cylinder boundary.
Comment 7 David Lehman 2010-06-30 17:55:38 EDT
Created attachment 428123 [details]
plaintext exception report
Comment 8 David Lehman 2010-06-30 17:58:40 EDT
This was fixed in anaconda-13.21.24 (bug 570474) and then more completely/correctly in anaconda-13.21.50-1 (bug 593637).

*** This bug has been marked as a duplicate of bug 570474 ***

Note You need to log in before you can comment on or make changes to this bug.