Bug 60972 - Upgrade overwrites grub.conf
Upgrade overwrites grub.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-10 22:03 EST by Kevin - The Alchemist - Sonney
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 11:14:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin - The Alchemist - Sonney 2002-03-10 22:03:42 EST
Description of Problem:
When performing an upgrade frmo 7.2 -> Hampton B2, grub overwrites the exising
grub.conf with only the data provided in th anaconda session

How Reproducible:
Very. Reproduced on a 7.2 -> Hampton Upgrade, and a fresh install where 2K,
FreeBSD, and a Linux partition shared a grub.conf.  In the latter case, the
FreeBSD was lost, but the 2K (since it was a bootable primary) was retained in
anaconda.

Steps to Reproduce:
Add your own kernel to gurb.conf and do an upgrade. The "user" kernel will be
gone on the post-upgrade reboot.

Additional Information:
The expectation is that my custom settings from the prior install will be
retained, or at least modified, not just blown away in one big swoop. If the rpm
upgrade fo a kernel can do it, why can't anaconda?
Comment 1 Jeremy Katz 2002-03-11 15:09:42 EST
Because anaconda is rewriting the GRUB config because there's no way to *know*
where to install GRUB.  A lot of these questions were going to get addressed by
new bootloader code that isn't landing with the new Hampton schedule.  I'll see
what I can this week, but this may well end up just being deferred :(
Comment 2 Jeremy Katz 2002-03-13 00:35:10 EST
Okay, implemented new screens to handle this today.  I would appreciate testing
of this as much as possible during the next beta.

Note You need to log in before you can comment on or make changes to this bug.