Bug 60981 - Anti-Aliasing doesn't work in KDE 2.2.1
Anti-Aliasing doesn't work in KDE 2.2.1
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
pensacola
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-11 04:11 EST by Peter H.S.
Modified: 2007-03-26 23:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 04:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H.S. 2002-03-11 04:11:55 EST
Description of Problem:
Anti-Aliasing doesn't work in KDE 2.2.1.

Version-Release number of selected component (if applicable):
XFree86*-4.1.0-15

How Reproducible:
Always

Steps to Reproduce:
1. Start kcontrol.
2. Select: "Look & Feel", -> "Fonts"
3. Select the box: "Use Anti-Aliasing for fonts and icons"
4. Restart KDE

Actual Results:
Anti-Aliasing doesn't work.
Also, the "Fixed with" font always defaults to the rather annoying "Arioso" font,
 as long as "Use Anti-Aliasing for fonts and icons" is selected. (at first, one is allowed to choose
a "Fixed with" font, but when returning to the font selection menu, or when using a KDE
application showing a fixed with font, the system defaults to the Arioso font.


Expected Results:
A-A fonts should work in KDE.
The A-A fixed with font should be the one, one chooses, not the random first one on
the fontlist (Arioso)

Additional Information:
It looks like, that this is a XFree 4.1 problem in XFree86-libs-4.1.0-15.
See "Kernel Cousin KDE #34 For 1 Mar ( 7. XFree86 Render Extension Loading Bug Found)
Also, http://lists.kde.org/?l=kde-core-devel&m=101456495731750&w=2
The problem is fixed in XFree 4.2. (can we have that version, pretty please?)
There seem to exist patch to QT (se maillist above), that works as a workaround.


My system:
White-box pc (Celeron, BX chipset)
Graphic adapter: Ati Rage IIC (ATI Mach64 GZ rev 122)

The "Render" modules seems to load allright:
From  "/var/log/XFree86.0.log"
"...
(II) Module ABI versions:
        XFree86 ANSI C Emulation: 0.1
        XFree86 Video Driver: 0.4
        XFree86 XInput driver : 0.2
        XFree86 Server Extension : 0.1
        XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.2
..."

Relevant Packages installed:
XFree86-xfs-4.1.0-15
XFree86-75dpi-fonts-4.1.0-15
XFree86-twm-4.1.0-15
XFree86-4.1.0-15
XFree86-100dpi-fonts-4.1.0-15
XFree86-ISO8859-15-100dpi-fonts-4.1.0-15
XFree86-tools-4.1.0-15
XFree86-devel-4.1.0-15
XFree86-libs-4.1.0-15
XFree86-ISO8859-15-75dpi-fonts-4.1.0-15
XFree86-xdm-4.1.0-15

KDE* 2.2.2-1
qt-2.3.1-5

freetype-2.0.3-7
freetype-devel-2.0.3-7
ttfm-0.9.1-8
ttfonts-1.0-4
Comment 1 Peter H.S. 2002-03-11 04:15:51 EST
Whoops, "Kernel Cousin KDE" lives on: http://kt.zork.net/
eg.: http://kt.zork.net/kde/latest.html#7
Comment 2 Mike A. Harris 2002-03-11 04:28:24 EST
I am using 4.1.0-15 with KDE with AA fonts right now to type this.
The X render extension is working just fine.  Note that RENDER does not
work with all video hardware currently.

The Arioso default font thing is covered in other bug reports already.

Note You need to log in before you can comment on or make changes to this bug.