Bug 609831 - Windows 7 guest installed in RHEL5 BSODs on shutdown when booted in RHEL6
Windows 7 guest installed in RHEL5 BSODs on shutdown when booted in RHEL6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
: 754921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 05:17 EDT by Jes Sorensen
Modified: 2013-01-09 17:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:30:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BSOD of windows 7 during shutdown (11.35 KB, image/png)
2010-07-01 05:17 EDT, Jes Sorensen
no flags Details
BSOD viostor.sys (70.60 KB, image/pjpeg)
2012-03-18 12:53 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Jes Sorensen 2010-07-01 05:17:28 EDT
Created attachment 428214 [details]
BSOD of windows 7 during shutdown

Description of problem:
Initial tests for win7 with the 1.1.6 drivers on win7 installed under
RHEL5 then rebooted into RHEL6 are showing similar problems as reported
earlier :( Install under rhel5, then reboot under rhel6. I get the
network re-classification process, plus I see that it has reinstalled
drivers after boot the first time. Then on reboot it crashes and hits
fsck. After fsck it seems to be running, but when I then shut it down
I get a new BSOD, see attached screen shot, and on reboot it comes up
wanting to start windows in rescue mode and back into fsck.....

Version-Release number of selected component (if applicable):
virtio-win-1.1.6-0

How reproducible:


Steps to Reproduce:
On RHEL5:
/usr/libexec/qemu-kvm -m 1G -smp 2 -drive file=/var/lib/libvirt/images/win7-new-1.1.6.img,if=virtio,cache=none,boot=on -net nic,model=virtio,vlan=1,macaddr=02:00:40:3F:55:10 -net tap,vlan=1,script=/etc/kvm-ifup.sh -boot dc -uuid 17544ecc-d3a1-4d3c-a386-12daf50015f1 -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now -name xp-ide-test -cdrom /home/isos/en_windows_7_ultimate_x64_dvd_x15-65922.iso -vnc 127.0.0.1:0 -fda ~jes/virtio-win-1.1.6-0.vfd

On RHEL6:
/usr/libexec/qemu-kvm -m 1G -smp 2 -drive
file=/var/lib/libvirt/images/win7-new-1.1.6.img,if=virtio,cache=none,boot=on
-net nic,model=virtio,vlan=1,macaddr=02:00:40:3F:55:10 -net
tap,vlan=1,script=/etc/kvm-ifup.sh -boot dc -uuid
17544ecc-d3a1-4d3c-a386-12daf50015f1 -usbdevice tablet -rtc-td-hack
-no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now
-name xp-ide-test -cdrom
/home/isos/en_windows_7_ultimate_x64_dvd_x15-65922.iso -vnc 127.0.0.1:0

  
Actual results:


Expected results:


Additional info:
Comment 2 Vadim Rozenfeld 2010-07-15 08:17:50 EDT
Looks like RHEL5 viostor driver will always fail while trying to start on RHEL6.
One possible workaround would be:
- start VM on rhel6 with "cache=writethrough" option,
- update viostor driver with the latest one from http://download.lab.bos.redhat.com/devel/RHEV/virtio-win/1.1.8-0/,
- shutdown VM,
- turn cache back to "off",
- start VM.
Comment 3 Shirley Zhou 2010-07-16 04:02:27 EDT
Verify win7 guest with virtio-win-1.1.8-0, this bug does not exist.
I verified this bug as Jes and Vadim steps:
1)install win7 guest on RHEL5.5 host with virtio-win-1.1.8-0
1.run win7 guest above on RHEL6.0 with cli:
/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu qemu64,+x2apic  -usbdevice tablet -drive file=/root/win7-32.qcow2.el5,if=none,id=drive-virtio0,boot=on,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0  -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=00:00:14:3F:20:1f,bus=pci.0 -uuid a4f4127c-e6e3-4e67-95da-8dd0a8891cc4  -name win7-32  -qmp tcp:0:4445,server,nowait   -monitor stdio -vnc :1
2.do restart and shutdown, then start this guest again, this bug does not exist,win7 guest can be run smoothly.

2)using win7 guest installed on RHEL5.5 host with RHEL5 viostor driver.
1.Start win7 guest above RHEL6.0 with cli:
/usr/libexec/qemu-kvm   -m 2G -smp 2 -cpu qemu64,+x2apic  -usbdevice tablet -drive file=/mnt/win7-32-virtio.qcow2,if=none,id=drive-virtio0,boot=on,werror=stop,rerror=stop,cache=writethrough -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=02:00:16:3F:20:1f,bus=pci.0 -uuid 1234127c-1233-4e67-95da-8dd0a8891cc4  -name win7x64  -qmp tcp:0:4444,server,nowait  -boot c -monitor stdio -boot c -vnc :1
2.update virtio blk driver to virtio-win-1.1.8-0
3.quit this guest
4.start this guest on RHEL6.0 again with cli:
/usr/libexec/qemu-kvm   -m 2G -smp 2 -cpu qemu64,+x2apic  -usbdevice tablet -drive file=/mnt/win7-32-virtio.qcow2,if=none,id=drive-virtio0,boot=on,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=02:00:16:3F:20:1f,bus=pci.0 -uuid 1234127c-1233-4e67-95da-8dd0a8891cc4  -name win7x64  -qmp tcp:0:4444,server,nowait  -boot c -monitor stdio -boot c -vnc :1
This guest can be start successfully.

So this bug has been resolved.
Comment 4 Issue Tracker 2010-08-20 09:31:47 EDT
Event posted on 08-20-2010 09:31am EDT by jkachuck

------- Comment From anantyog@in.ibm.com 2010-08-20 03:49 EDT-------
This issue still occurs with virtio drivers in Snap10 supplement CD
Info about the RPM installed:
rpm -qi virtio-win-1.0.0-8.2.41879.el6.noarch
Name        : virtio-win                   Relocations: (not relocatable)
Version     : 1.0.0                             Vendor: Red Hat, Inc.
Release     : 8.2.41879.el6                 Build Date: Tuesday 06 July
2010 04:29:36 PM EDT
Install Date: Friday 20 August 2010 02:33:08 AM EDT      Build Host:
x86-003.build.bos.redhat.com
Group       : Applications/System           Source RPM:
virtio-win-1.0.0-8.2.41879.el6.src.rpm
Size        : 17125341                         License: Red Hat
Proprietary
Signature   : RSA/8, Thursday 08 July 2010 02:10:16 PM EDT, Key ID
938a80caf21541eb
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.redhat.com/
Summary     : VirtIO para-virtualized drivers for Windows(R)
Description :
VirtIO para-virtualized Windows(R) drivers for 32-bit and 64-bit
Windows(R) guests.



This event sent from IssueTracker by jkachuck 
 issue 1207333
Comment 5 Jes Sorensen 2010-08-22 04:08:56 EDT
Same as in BZ#609838, virtio-win-1.0.0 is known to be bad, they need
1.1.8 or later.

Jes
Comment 6 releng-rhel@redhat.com 2010-11-11 11:30:33 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.
Comment 8 Ronen Hod 2012-03-18 12:46:32 EDT
*** Bug 754921 has been marked as a duplicate of this bug. ***
Comment 9 IBM Bug Proxy 2012-03-18 12:53:54 EDT
Created attachment 570916 [details]
BSOD viostor.sys
Comment 10 IBM Bug Proxy 2012-04-04 09:30:36 EDT
---Problem Description---
We are trying to migrate an old Windowsw 2008 R2 image with old virtio drivers
from RHEL5.6 to RHEL6.1. The old drivers are not compatible with RHEL6.1


Contact Information = Red Hat

Reverse Mirror of 754921
Hi Mihai,

Could you please upload memory dump file together with VM command line?

Best regards,
Vadim.
(In reply to comment #3)
> ---Problem Description---
> We are trying to migrate an old Windowsw 2008 R2 image with old virtio drivers
> from RHEL5.6 to RHEL6.1. The old drivers are not compatible with RHEL6.1
>
>
> Contact Information = Red Hat
>
> Reverse Mirror of 754921

Is this Bug related to sysprep ? I tried following steps ,can not reproduce

1.install windows 2008R2 host with virtio-win-1.0.3-1.52454.el5.noarch.rpm
CLI#/usr/libexec/qemu-kvm -no-hpet -no-kvm-pit-reinjection -usbdevice trtc-td-hack -startdate now -name win2k8R2 -smp 2 -k en-us -m 2048 -boot dc -net nic,vlan=0,macaddr=00:11:4b:40:19:01,model=virtio -net tap,vlan=0,ifname=virtio_tap0,script=/etc/qemu-ifup,downscript=no -drive file=/home/win08R2.qcow2,media=disk,if=virtio,cache=none,boot=on,format=qcow2,werror=stop -monitor stdio -spice host=0,ic=on,port=5930,disable-ticketing -qxl 1
2.install virtio-netkvm and virtio-blk driver during guest installation
3.copy the image to RHEL6u2 host
4.start the image on RHEL6 host
5.make a copy-on-write image based on the image in step4
#qemu-img create -f qcow2 win08R2.sp1 -b win08R2.qcow2
6.start guest on RHEL6 host with the image created in step 5

Actual Results???
after step 4 ,guest could start successfully ,no BOSD happened
after step 6 ,guest could start successfully ,no BSOD happened .

Hello ,IBM
Could you give more details how I can reproduce this bug ?

Thanks,
Mike
Sounds exactly like the following one:
https://bugzilla.redhat.com/show_bug.cgi?id=609831

Let's close it.
*** This bug has been marked as a duplicate of bug 609831 ***

Note You need to log in before you can comment on or make changes to this bug.