Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 609838 - XP installed under RHEL55 has missing sys files on 2nd reboot under RHEL6
XP installed under RHEL55 has missing sys files on 2nd reboot under RHEL6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
: 621995 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 05:59 EDT by Jes Sorensen
Modified: 2013-01-09 17:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 11:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL55 installed XP hanging on 2nd reboot under RHEL6 (2.70 KB, image/png)
2010-07-01 05:59 EDT, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2010-07-01 05:59:57 EDT
Created attachment 428224 [details]
RHEL55 installed XP hanging on 2nd reboot under RHEL6

Description of problem:
An install of XP as a guest under RHEL55, when rebooted under RHEL6 it
first comes up, but on the second reboot it comes up claiming that
<Windows root>\system32\hal.dll is missing.

It could be either general disk corruption or something specific with
this file.

Version-Release number of selected component (if applicable):
virtio-win-1.1.6-0.vfd
kernel-2.6.32-37.el6.x86_64
seabios-0.5.1-0.11.20100108git669c991.el6.x86_64
qemu-kvm-0.12.1.2-2.78.el6.x86_64

How reproducible:


Steps to Reproduce:
Installed in RHEL55 using this command:
/usr/libexec/qemu-kvm -m 1G -smp 2 -drive file=/var/lib/libvirt/images/xp-new-1.1.6.img,if=virtio,cache=none,boot=on -net nic,model=virtio,vlan=1,macaddr=02:00:40:3F:55:10 -net tap,vlan=1,script=/etc/kvm-ifup.sh -boot dc -uuid 17544ecc-d3a1-4d3c-a386-12daf50015f1 -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now -cdrom /home/isos/en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -vnc 127.0.0.1:0 -fda ~jes/virtio-win-1.1.6-0.vfd

Then booted in RHEL6 like this:
/usr/libexec/qemu-kvm -m 1G -smp 2 -drive file=/var/lib/libvirt/images/xp-new-1.1.6.img,if=virtio,cache=none,boot=on -net nic,model=virtio,vlan=1,macaddr=02:00:40:3F:55:10 -net tap,vlan=1,script=/etc/kvm-ifup.sh -boot dc -uuid 17544ecc-d3a1-4d3c-a386-12daf50015f1 -usbdevice tablet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now -cdrom /home/isos/en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -vnc 127.0.0.1:0

Went through it coming up, clicked around a bit, then tried to reboot
it from within XP. It didn't get far, and stopped at a black screen
with the message. See attachment.

Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-07-01 06:23:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Shirley Zhou 2010-07-16 04:49:07 EDT
Verify this bug on virtio-win-1.1.8.0, this bug does not happen, steps as following:
1.Install windows xp x86 on RHEL5.5 host with virtio-win-1.1.8.0 driver
 /usr/libexec/qemu-kvm -m 2G -smp 2 -drive file=/home/samba/winxp.qcow2,if=virtio,cache=none,boot=on -net nic,model=virtio,vlan=1,macaddr=03:11:40:3F:55:10 -net tap,vlan=1,script=/etc/qemu-ifup -boot dc -uuid 12344ecc-d3a1-4d3c-a386-12daf50015f1 -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now -name win7-32 -cdrom /nfs/WindowsXP-32.iso -fda /root/virtio-win-1.1.8-0.vfd
2.Start this image on RHEL6.0 host after installation finished
/usr/libexec/qemu-kvm   -m 2G -smp 2 -cpu qemu64,+x2apic  -usbdevice tablet -drive file=/root/winxp.qcow2,if=none,id=drive-virtio0,boot=on,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=02:00:16:3F:20:1f,bus=pci.0 -uuid 1234127c-1233-4e67-95da-8dd0a8891cc4  -name win7x64  -qmp tcp:0:4444,server,nowait  -boot c -monitor stdio -boot c -vnc :1
3.do restart and shutdown a few times

This issue does not exist after step3, so this bug has been resolved.
Comment 5 Dor Laor 2010-08-17 18:12:12 EDT
*** Bug 621995 has been marked as a duplicate of this bug. ***
Comment 6 Issue Tracker 2010-08-20 09:29:04 EDT
Event posted on 08-20-2010 04:01am EDT by Glen Johnson

------- Comment From anantyog@in.ibm.com 2010-08-20 03:49 EDT-------
This issue still occurs with virtio drivers in Snap10 supplement CD
Info about the RPM installed:
rpm -qi virtio-win-1.0.0-8.2.41879.el6.noarch
Name        : virtio-win                   Relocations: (not relocatable)
Version     : 1.0.0                             Vendor: Red Hat, Inc.
Release     : 8.2.41879.el6                 Build Date: Tuesday 06 July
2010 04:29:36 PM EDT
Install Date: Friday 20 August 2010 02:33:08 AM EDT      Build Host:
x86-003.build.bos.redhat.com
Group       : Applications/System           Source RPM:
virtio-win-1.0.0-8.2.41879.el6.src.rpm
Size        : 17125341                         License: Red Hat
Proprietary
Signature   : RSA/8, Thursday 08 July 2010 02:10:16 PM EDT, Key ID
938a80caf21541eb
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.redhat.com/
Summary     : VirtIO para-virtualized drivers for Windows(R)
Description :
VirtIO para-virtualized Windows(R) drivers for 32-bit and 64-bit
Windows(R) guests.

Internal Status set to 'Waiting on Support'
Status set to: Waiting on Tech

This event sent from IssueTracker by jkachuck 
 issue 1207333
Comment 7 Jes Sorensen 2010-08-21 15:33:59 EDT
virtio-win-1.0.0-8.2.41879.el6.noarch is known to be bad, they need 1.1.8 or later.

Jes
Comment 8 releng-rhel@redhat.com 2010-11-11 11:30:48 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.