Bug 609859 - ksplice : does not adhere to Static Library Packaging Guidelines
Summary: ksplice : does not adhere to Static Library Packaging Guidelines
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: ksplice (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 10:40 UTC by Michael Schwendt
Modified: 2010-07-06 17:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 17:42:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2010-07-01 10:40:17 UTC
ksplice-0.9.9-1.fc12.src
is missing
BuildRequires: binutils-static

[...]

https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries_2

If a library you depend on only provides a static version your package can link against it provided that you BuildRequire the *-static subpackage. Packagers in such a situation should be aware that if a shared library becomes available, that you should adjust your package to use the shared library.

Comment 1 Jochen Schmitt 2010-07-06 17:42:01 UTC
Bacause there are general issues to build ksplice to build agains kernel-2.6.32, I would like to defer this issue until the gneral issues are fixed.


Note You need to log in before you can comment on or make changes to this bug.