Bug 60986 - Specifying full configuration for CIPE interface in both places results in non-working configuration
Specifying full configuration for CIPE interface in both places results in no...
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: cipe (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-11 10:37 EST by Thais Smith
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thais Smith 2002-03-11 10:37:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
The /etc/sysconfig/network-scripts/ifup-cipcb script checks for configuration in
both /etc/cipe/options.<interface> and
/etc/sysconfig/network-scripts/ifcfg-<interface>. It constructs options which it
feeds to /usr/sbin/ciped-cb on the command line. In the case where a full
configuration is specified in both places, the $ME information on the command
line ends up broken.

The problem is illustrated by the fragment:

if [ -z "$ME" ] && ! grep "^me[         ]" $cipeconfig > /dev/null; then
    ME=0.0.0.0
#   ME=$(/sbin/findroute `echo ${PEER} | sed 's/:.*//'` 2> /dev/null)
    if [ -z "$ME" ]; then
        echo "Unable to find a suitable route to peer ${PEER}"
        exit 1
    fi
fi

if [ -n "$MYPORT" ]; then
    ME="${ME}:${MYPORT}"
fi

If 'me' is specified in the options file *and* in the ifcfg file, the variable
'ME' will end up set to something like ":$MYPORT". Since the value on the
command line overrides the value in the options file, this will cause it to fail.

Curiously, in order for the PEER to work, it must be specified as host:port -
this is inconsistent with the ME/MYPORT specification for the local end.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above	

Actual Results:  See Description

Expected Results:  See Description

Additional info:
Comment 1 Bill Nottingham 2006-08-07 13:38:03 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 10:38:50 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.