Bug 609901 - tiffcp ends with segmentation fault
tiffcp ends with segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtiff (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tom Lane
qe-baseos-daemons
:
Depends On: 460653
Blocks: 580448
  Show dependency treegraph
 
Reported: 2010-07-01 06:58 EDT by Jan Ščotka
Modified: 2013-07-02 23:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 460653
Environment:
Last Closed: 2010-11-11 11:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2010-07-01 06:58:11 EDT
+++ This bug was initially created as a clone of Bug #460653 +++
(RHTS log: http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=15001514)

Description of problem:
The tiffcp utility segfaults when processing one of the official libtiff test images -- zackthecat.tif .

Version-Release number of selected component (if applicable):
libtiff-3.6.1-12.el4_7.2

How reproducible:
Always

Steps to Reproduce:
1. Go to http://www.remotesensing.org/libtiff/images.html .
2. Download the latest archive of test images (
ftp://ftp.remotesensing.org/pub/libtiff/pics-3.8.0.tar.gz ).
3. Unpack the file zackthecat.tif .
# tiffcp zackthecat.tif temp.tif
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 512 (0x200) encountered.
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 519 (0x207) encountered.
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 520 (0x208) encountered.
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 521 (0x209) encountered.
zackthecat.tif: Warning, using top-left orientation.
zackthecat.tif: Old-style JPEG compression support is not configured.
Segmentation fault
# echo $?
139
# ls -l zackthecat.tif temp.tif 
-rw-r--r--  1 root 1076    8 Aug 29 10:14 temp.tif
-rw-r--r--  1 root 1076 8258 Aug 29 10:13 zackthecat.tif
# 
  
Actual results:
segmentation fault

Expected results:
no segmentation fault

Additional info:

--- Additional comment from mmalik@redhat.com on 2008-08-29 10:26:08 EDT ---

libtiff-3.5.7-31.el3 on RHEL-3.9 is also affected.

# tiffcp zackthecat.tif temp.tif
zackthecat.tif: Warning, unknown field with tag 512 (0x200) ignored.
zackthecat.tif: Warning, unknown field with tag 519 (0x207) ignored.
zackthecat.tif: Warning, unknown field with tag 520 (0x208) ignored.
zackthecat.tif: Warning, unknown field with tag 521 (0x209) ignored.
zackthecat.tif: Old-style JPEG compression support is not configured.
Segmentation fault
# echo $?
139
# ls -l zackthecat.tif temp.tif 
-rw-r--r--    1 root     devqa8          8 Aug 29 10:22 temp.tif
-rw-r--r--    1 root     devqa8       8258 Aug 29 10:22 zackthecat.tif
#

--- Additional comment from mcermak@redhat.com on 2010-05-31 09:47:17 EDT ---

*** Bug 588784 has been marked as a duplicate of this bug. ***

--- Additional comment from mcermak@redhat.com on 2010-05-31 09:48:23 EDT ---

Tom, ping, any progress on this?

--- Additional comment from tgl@redhat.com on 2010-05-31 10:52:48 EDT ---

I think this is most likely a duplicate of upstream bug
http://bugzilla.maptools.org/show_bug.cgi?id=2097
Doesn't appear they've made any progress on it.

--- Additional comment from mcermak@redhat.com on 2010-05-31 11:06:29 EDT ---

Tom, please consider writing your own patch. You have clear reproducer. This must be easy to locate and fix, don't you think? It's just a question of parsing a binary file. Or is there some serious problem?

--- Additional comment from updates@fedoraproject.org on 2010-06-23 00:14:38 EDT ---

libtiff-3.9.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libtiff-3.9.4-1.fc12

--- Additional comment from updates@fedoraproject.org on 2010-06-23 00:14:56 EDT ---

libtiff-3.8.2-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libtiff-3.8.2-15.fc11

--- Additional comment from updates@fedoraproject.org on 2010-06-23 00:15:10 EDT ---

libtiff-3.9.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libtiff-3.9.4-1.fc13

--- Additional comment from mcermak@redhat.com on 2010-06-23 02:20:11 EDT ---

Yes, I can confirm libtiff-3.9.4-1.fc13 seems to be fixed.

--- Additional comment from updates@fedoraproject.org on 2010-06-24 12:29:59 EDT ---

libtiff-3.8.2-15.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from mcermak@redhat.com on 2010-06-28 10:40:55 EDT ---

Ok, seems to be fixed:

# tiffcp zackthecat.tif temp.tif
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 512 (0x200) encountered.
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 519 (0x207) encountered.
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 520 (0x208) encountered.
TIFFReadDirectory: Warning, zackthecat.tif: unknown field with tag 521 (0x209) encountered.
tiffcp: zackthecat.tif: Can't copy/convert subsampled image.
.live.[root@i386-4as-7-m1 ~]# rpm -q libtiff
libtiff-3.6.1-12.el4_8.5.i386

--- Additional comment from mcermak@redhat.com on 2010-06-28 10:41:19 EDT ---

=> VERIFIED
Comment 2 RHEL Product and Program Management 2010-07-01 07:23:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Tom Lane 2010-07-01 10:27:25 EDT
What's the point of opening this bz?  The bug's already fixed.
Comment 4 Jan Ščotka 2010-07-01 16:09:37 EDT
Hi,
(similar to https://bugzilla.redhat.com/show_bug.cgi?id=609948)
I do tier test of daemons components, and these test fail on RHEL6.0-20100622.1 (public beta2)
So for me it is a regression.

so I clone similar bug for this test because for me it look like same problem?
in jobid: 
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=164860

testlog:
 http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=15001514

test:
/CoreOS/libtiff/Regression/official-test-images

LOG:

:: tiffcp libtiffpic/zackthecat.tif /tmp/tmp.d908rYMIht ::
./test-core.sh: line 68:  3168 Segmentation fault      (core dumped) tiffcp ${INPUT_FILE} ${OUTPUT_FILE} &>/dev/null
	* exit code: 139
	* segfaulted <-- wrong
Comment 5 Tom Lane 2010-07-02 11:36:18 EDT
beta2 doesn't include the build that fixes this, does it?  You failed to specify the package version you're testing, but this is supposed to be fixed in 1.2.44-1, which AFAIK is only pulled in as of snapshot 7.
Comment 6 Tom Lane 2010-07-02 11:38:23 EDT
Wup, make that 3.9.4-1 --- was looking at the wrong specfile.
Comment 7 Tom Lane 2010-07-15 10:06:04 EDT
This should be fixed in snapshot 7 or later. Please retest.
Comment 8 Jan Ščotka 2010-07-15 10:43:58 EDT
Hi,
okay. I'll test it in snap7
Comment 9 RHEL Product and Program Management 2010-07-15 11:00:21 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 10 Jan Ščotka 2010-07-22 07:55:54 EDT
Repaired in snap 7
see RHTS test
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=166547
Comment 11 releng-rhel@redhat.com 2010-11-11 11:20:02 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.