Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 609977 - slang.h vs. slang/ subdirectory
slang.h vs. slang/ subdirectory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: slang (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 07:19 EDT by Karel Zak
Modified: 2010-07-21 10:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 10:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2010-07-01 07:19:08 EDT
Description of problem:

The /usr/include/slang/slcurses.h file contains:

 #include <slang.h>

but it does not work because slang-devel uses slang/ subdirectory for all headers. The another problem is that 

  pkg-config --cflags slang

does not return -I/usr/include/slang.

I think the best way how to fix this problem is to use "#include <slang/slang.h>" in /usr/include/slang/slcurses.h.

It would be also nice to add -I/usr/include/slang to slang.pc.


The workaround is to explicitly include slang.h in all applications where is necessary slcurses.h, for example:

 #include <slang/slang.h>
 #include <slang/slcurses.h>

I didn't test it, but I guess that the same problem exists in F-13 rawhide and RHEL6.
Comment 1 Miroslav Lichvar 2010-07-01 07:30:21 EDT
A better solution might be moving the headers back to /usr/include as they are supposed to be and add symlinks to /usr/include/slang.
Comment 2 Miroslav Lichvar 2010-07-21 10:43:12 EDT
Fixed in slang-2.2.2-2.fc14.

Note You need to log in before you can comment on or make changes to this bug.