Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 610000 - lm_sensors initscript confusion
lm_sensors initscript confusion
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lm_sensors (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Minar
Filip Holec
: Documentation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 07:56 EDT by David Kovalsky
Modified: 2016-04-18 06:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: lm_sensors-3.1.1-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 06:46:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1309 normal SHIPPED_LIVE lm_sensors bug fixes 2012-09-25 10:46:04 EDT

  None (edit)
Description David Kovalsky 2010-07-01 07:56:57 EDT
I installed lm_sensors like I was used to in RHEL5, ran sensors-detect and the found that there is no initscript to load the needed modules. 

sensors-detect says to copy prog/init/lm_sensors.init file <- that's really confusing and should be changed to be more distro-friendly. 

Furthermore, while reading README.initscript - it didn't help me at all how to load the modules. 

I suggest the following changes:
 - if lm_sensors-sensord is not installed with lm_sensors that sensors-detect should point the user that (s)he needs to install the package to get the initscript

 - add a message to sensors-detect pointing user to lm_sensors-sensord package and remove misleading prog/init/lm_sensors.init

 - create a README.redhat with information how lm_sensors are packages. What's in lm_sensors and what in lm_sensors-sensord.
Comment 1 RHEL Product and Program Management 2010-07-01 08:03:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 RHEL Product and Program Management 2011-01-07 11:03:03 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Nikola Pajkovsky 2011-01-25 04:48:38 EST

*** This bug has been marked as a duplicate of bug 623587 ***
Comment 10 errata-xmlrpc 2012-09-25 06:46:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1309.html

Note You need to log in before you can comment on or make changes to this bug.