Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610156 - The qpid::messaging API sometimes uses exceptions from the qpid:: namespace
The qpid::messaging API sometimes uses exceptions from the qpid:: namespace
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
All Linux
urgent Severity medium
: 1.3
: ---
Assigned To: Gordon Sim
MRG Quality Engineering
:
Depends On:
Blocks: 612283
  Show dependency treegraph
 
Reported: 2010-07-01 12:25 EDT by Ted Ross
Modified: 2012-12-11 15:42 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 612283 (view as bug list)
Environment:
Last Closed: 2012-12-11 15:30:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-664 None None None Never

  None (edit)
Description Ted Ross 2010-07-01 12:25:43 EDT
Description of problem:

There is at least one case in which an exception is thrown from the API that does not derive from qpid::messaging::MessagingException.  This is an ABI problem.

Version-Release number of selected component (if applicable):

1.3 beta4


How reproducible:

100%

Steps to Reproduce:

Use the following sequence in the C++ API:

  using namespace qpid::messaging;

  Connection conn = Connection("localhost");
  Session    sess = conn.createSession();

  
Actual results:

Because the connection is not open, the createSession call throws an exception (expected) but the exception is "qpid::Exception" (not expected).


Expected results:

I expect an exception derived from qpid::messaging::MessagingException
Comment 1 Gordon Sim 2010-07-01 15:21:57 EDT
Fixed on trunk (r959721) and in release repo (http://mrg1.lab.bos.redhat.com/git/?p=qpid.git;a=commitdiff;h=9a005978daf378f235f2806a1e50eeb0dd44bd94).

Note You need to log in before you can comment on or make changes to this bug.