Bug 610224 - running 'rmmod wifi-driver-module' in fips mode hangs system
Summary: running 'rmmod wifi-driver-module' in fips mode hangs system
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: John W. Linville
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 582655 608704
TreeView+ depends on / blocked
 
Reported: 2010-07-01 19:24 UTC by Jiri Kastner
Modified: 2010-11-11 16:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 16:05:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IMG00061-20100707-1446.jpg (910.23 KB, image/jpeg)
2010-07-07 18:58 UTC, John W. Linville
no flags Details
jwltest-ath9k-cleanup-init-error-path.patch (1.96 KB, patch)
2010-07-08 20:46 UTC, John W. Linville
no flags Details | Diff

Description Jiri Kastner 2010-07-01 19:24:25 UTC
Description of problem:
in fips mode, every attempt to remove ath9k module hangs/freeze system

Version-Release number of selected component (if applicable):
kernel-2.6.32-37.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. enable fips mode
2. rmmod ath9k
3. system unusable
  
Actual results:
system hangs

Expected results:
removing of module will work as for other modules in fips mode

Additional info:

Comment 1 RHEL Product and Program Management 2010-07-01 19:43:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Stanislaw Gruszka 2010-07-02 11:18:52 UTC
What is fips mode? How to enable it?

Comment 3 John W. Linville 2010-07-02 14:52:26 UTC
FWIW, this likely results from some failed clean-up after ieee80211_register_hw fails...

Comment 4 Jiri Kastner 2010-07-07 08:30:52 UTC
renamed, because i noticed this on iwlagn with john's test kernel

Comment 5 John W. Linville 2010-07-07 18:54:35 UTC
FWIW, I think this actually is ath9k-specific.  The similar behavior on iwlagn was actually caused by the 1st fix attempt in bug 608704.  After fixing that issue, I was still able to get this ath9k failure.  I'll attach a pic of the failure on my local machine.

Comment 6 John W. Linville 2010-07-07 18:58:06 UTC
Created attachment 430156 [details]
IMG00061-20100707-1446.jpg

Note that this is without the fix to allow FIPS mode to work (but with the fix that allows rmmod of iwlagn) -- with that in place I suspect this won't happen at all.

Comment 8 John W. Linville 2010-07-08 20:46:04 UTC
Created attachment 430471 [details]
jwltest-ath9k-cleanup-init-error-path.patch

Comment 9 Jiri Kastner 2010-07-11 09:22:08 UTC
verified with adapters, where i detected. rmmod iwlagn and ath9k works as expected

Comment 13 Aristeu Rozanski 2010-07-26 15:15:54 UTC
Patch(es) available on kernel-2.6.32-52.el6

Comment 16 Vladimir Benes 2010-08-24 08:51:08 UTC
Jiri,
Could you please retest so we can close this? Or you can alternatively write here hostname where we can retest.

thanks,
Vlad

Comment 17 Vladimir Benes 2010-08-26 12:54:41 UTC
tested on frankenstein-wifi-01.rhts.eng.bos.redhat.com, it has several types of wireless devices. Tested with all of them under fips enabled system.
rt61pci,rt73usb, ath5k, ath9k, rtl8180, rtl8187

looks good 
-> VERIFIED

Comment 18 releng-rhel@redhat.com 2010-11-11 16:05:50 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.