Bug 610233 - with gdm disable_user_list=true window is only 1 pixel wide and no one can login
with gdm disable_user_list=true window is only 1 pixel wide and no one can login
Status: CLOSED DUPLICATE of bug 606808
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 15:48 EDT by Gary Gatling
Modified: 2015-01-14 18:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 17:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Gatling 2010-07-01 15:48:57 EDT
Description of problem:
In RHEL 6 beta 2, you cannot set the 
gdm display manager to use the key disable_user_list as true.

When this key is set to true, the login window is only
1 pixel wide and you can't login.

Version-Release number of selected component (if applicable):

RHEL 6 beta 2. i386 and x86_64 bit versions of workstation were tested.

Happens either with open source video drivers or the ones from NVIDIA.

How reproducible:

install RHEL 6 beta 2 workstation. (Either 32 bit or 64 bit)

run this command as root:

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults
 --type bool --set /apps/gdm/simple-greeter/disable_user_list true

log out or reboot.

Notice the the login window is only 1 pixel wide. Thus, you cannot login.

Steps to Reproduce:
1. install RHEL 6 beta 2.
2. run gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults
 --type bool --set /apps/gdm/simple-greeter/disable_user_list true
3. logout and observe login window.
  
Actual results: a gdm window 1 pixel wide you can't type into or log in with.

Expected results:

a gdm window where a user can type "Username" into a text box.

Additional info:
Comment 2 RHEL Product and Program Management 2010-07-01 16:03:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ray Strode [halfline] 2010-07-08 10:26:34 EDT

*** This bug has been marked as a duplicate of bug 606808 ***
Comment 4 Gary Gatling 2010-07-12 13:22:49 EDT
I think this bug is different from bug 606808, because when I run this command as root:

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults --type bool --set /apps/gdm/simple-greeter/disable_user_list true

The gdm log in window becomes only 1 pixel wide. So the command is having some
effect. Just not the desired one. Instead of showing a username text box it collapses the whole window so that it is only one pixel wide. This one
pixel wide thing (window?) also blinks on and off. Like once per second.

There is no way to log in once this happens because there is no where to type your username or to select the user from a long list. Clicking on the one
pixel wide thing doesn't have any effect. There are no widgets. No boxes, nothing
but a vertical blinking line.

Running the above command as root worked on RHEL 6 beta 1. Its broken in RHEL 6 beta 2. The version of the gdm rpm in beta 2 is: 2.30.2-3.el6

I am not trying to run this command as a regular user. I am running this command
as root. (In a %post script of an installing rpm)

Thanks
Comment 5 Ray Strode [halfline] 2010-07-12 17:20:24 EDT
Hi Gary,

The bug you described is what was fixed.  bug 606808 did have a bit of confusion in it regarding how to set disable_user_list, but that's the bug we've been using as the "master" issue for the problem you've described with the blinking thin vertical window.

*** This bug has been marked as a duplicate of bug 606808 ***

Note You need to log in before you can comment on or make changes to this bug.