Bug 610252 - Gnome login chooses US keyboard, even though I selected UK keyboard during install
Summary: Gnome login chooses US keyboard, even though I selected UK keyboard during in...
Status: CLOSED DUPLICATE of bug 595654
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-setup-keyboard   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 508787
TreeView+ depends on / blocked
 
Reported: 2010-07-01 20:31 UTC by Richard W.M. Jones
Modified: 2010-07-08 07:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 07:43:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (16.14 KB, text/plain)
2010-07-07 11:23 UTC, Richard W.M. Jones
no flags Details
Screengrab from login screen showing US keyboard selected (403.34 KB, image/png)
2010-07-07 11:26 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2010-07-01 20:31:00 UTC
Description of problem:

This is most likely a dupe of bug 519739 (for Fedora).

Basically I selected a UK keyboard during the install.  However
at first login, it chooses a US keyboard.  This could mean that
I couldn't type my password if it contained certain punctuation.

Version-Release number of selected component (if applicable):

RHEL 6 beta 2

How reproducible:

Happened once.

Steps to Reproduce:
1. Install using a UK keyboard.
2. Reboot and go through firstboot.
3. Select your name at log in window.
  
Actual results:

Selects US keyboard.

Expected results:

Should respect my installation choice.

Additional info:

Comment 2 RHEL Product and Program Management 2010-07-01 20:43:07 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Thomas Woerner 2010-07-02 07:51:53 UTC
Do you have a UK keyboard mapping on text consoles?

Comment 4 Richard W.M. Jones 2010-07-02 09:03:57 UTC
(In reply to comment #3)
> Do you have a UK keyboard mapping on text consoles?    

Yes.

Comment 5 Thomas Woerner 2010-07-02 09:36:08 UTC
gdm does not seem to honor settings from /etc/sysconfig/keyboard.

Reassigning to gdm.

Comment 6 Richard W.M. Jones 2010-07-02 09:53:43 UTC
Contents of this file on the VM:

$ sudo virt-cat RHEL6beta2x64 /etc/sysconfig/keyboard 
KEYTABLE="uk"
MODEL="pc105"
LAYOUT="gb"
KEYBOARDTYPE="pc"

Comment 7 Peter Hutterer 2010-07-07 02:36:05 UTC
please attach your Xorg.log file.

Comment 8 Richard W.M. Jones 2010-07-07 11:23:51 UTC
Created attachment 430036 [details]
/var/log/Xorg.0.log

Attached is /var/log/Xorg.0.log from the latest boot.

Comment 9 Richard W.M. Jones 2010-07-07 11:26:53 UTC
Created attachment 430037 [details]
Screengrab from login screen showing US keyboard selected

Comment 10 Peter Hutterer 2010-07-08 00:29:42 UTC
Looks like a dupe of Bug 595654 which should be resolved. Can you please verify you have system-setup-keyboard-0.7-4.el6 installed?

In your log, the Power Button device is added with US keyboard, prompting GNOME to assume US as well (see 595654 for mor details). This should be resolved by now, I'm rather confused that it isn't on your machine.

Comment 11 Richard W.M. Jones 2010-07-08 07:43:04 UTC
Yes, it's fixed by installing that update.

*** This bug has been marked as a duplicate of bug 595654 ***


Note You need to log in before you can comment on or make changes to this bug.