Bug 61033 - remove_inode_page NULL dereference
remove_inode_page NULL dereference
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-12 10:17 EST by Clay Cooper
Modified: 2007-04-18 12:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 16:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ksymoops output (3.81 KB, text/plain)
2002-03-12 10:18 EST, Clay Cooper
no flags Details
6450 UP kernel ksymoops output (30.47 KB, text/plain)
2002-03-13 10:47 EST, Clay Cooper
no flags Details
2550 smp kernel ksymoops output (3.99 KB, text/plain)
2002-03-13 11:02 EST, Clay Cooper
no flags Details
4600 bigmem kernel ksymoops output (4.29 KB, text/plain)
2002-03-13 11:04 EST, Clay Cooper
no flags Details
slimmerlot smp kernel ksymoops output (4.73 KB, text/plain)
2002-03-13 17:29 EST, Clay Cooper
no flags Details
Kysmoops output for 6450 (4.16 KB, text/plain)
2002-03-22 10:07 EST, Clay Cooper
no flags Details
Ksymoops output for pe500sc (3.82 KB, text/plain)
2002-03-22 10:11 EST, Clay Cooper
no flags Details
Kymoops output from pe500sc w/ 2.4.18-0.10 installed (4.35 KB, text/plain)
2002-04-02 11:46 EST, Clay Cooper
no flags Details

  None (edit)
Description Clay Cooper 2002-03-12 10:17:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
On a 6450 running hampton beta2 (2.4.18-0.1bigmem) w/ A10 bios, 5GB ram, 2GB
swap, and Perc3/SC as boot controller.  

Kernel oops while running newburn after 18 hours.

Attached ksymoops output.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install hampton beta2 on a 6450 w/ Perc3/SC boot controller
2.  Run newburn and note kernel oops
3.
	

Actual Results:  Kernel Oops

Expected Results:  No kernel oops

Additional info:
Comment 1 Clay Cooper 2002-03-12 10:18:13 EST
Created attachment 48284 [details]
Ksymoops output
Comment 2 Clay Cooper 2002-03-13 10:42:34 EST
Oops reproduced with UP kernel after 7 hours.

Attaching ksymoops output...
Comment 3 Clay Cooper 2002-03-13 10:47:03 EST
Created attachment 48404 [details]
6450 UP kernel ksymoops output
Comment 4 Clay Cooper 2002-03-13 11:00:59 EST
Just saw an oops on a pe2550 running hampton beta 2 (2.4.18-0.1smp).

Attaching ksymoops output...

Would you prefer us to separate these kernel oops issues by platform?  Or is
attaching oops from different platforms on the same issue ok?
Comment 5 Clay Cooper 2002-03-13 11:02:24 EST
Created attachment 48406 [details]
2550 smp kernel ksymoops output
Comment 6 Clay Cooper 2002-03-13 11:03:59 EST
Just saw an oops on a pe4600 running hampton beta 2 (2.4.18-0.1bigmem).

Attching ksymoops output...
Comment 7 Clay Cooper 2002-03-13 11:04:47 EST
Created attachment 48407 [details]
4600 bigmem kernel ksymoops output
Comment 8 Matt Domsch 2002-03-13 11:07:34 EST
Since these are the same oops (the same function dereferences NULL+0x18), just 
reproduced on different platforms, I say keep them together, rename the title 
__remove_inode_page NULL dereference.
Comment 9 Clay Cooper 2002-03-13 17:29:52 EST
Created attachment 48431 [details]
slimmerlot smp kernel ksymoops output
Comment 10 Clay Cooper 2002-03-22 10:06:00 EST
6450 kernel oops w/ beta3 (2.4.18-0.4bigmem)
Attaching ksymoops output...
Comment 11 Clay Cooper 2002-03-22 10:07:18 EST
Created attachment 49684 [details]
Kysmoops output for 6450
Comment 12 Clay Cooper 2002-03-22 10:10:20 EST
Kernel oops on pe500sc while running newburn w/ beta3 (2.4.18-0.4)
Attaching ksymoops output...
Comment 13 Clay Cooper 2002-03-22 10:11:02 EST
Created attachment 49685 [details]
Ksymoops output for pe500sc
Comment 14 Michael K. Johnson 2002-03-26 14:20:03 EST
It will be worth testing this with 2.4.18-0.9 or later.
Comment 15 Clay Cooper 2002-04-02 11:46:53 EST
Created attachment 51864 [details]
Kymoops output from pe500sc w/ 2.4.18-0.10 installed
Comment 16 Arjan van de Ven 2002-04-03 04:56:34 EST
Ah ha!
Found it!
Fixed as of 2.4.18-0.14
Comment 17 Clay Cooper 2002-04-08 10:57:11 EDT
No kernel oops after 3 days of newburn on a beetle (pe500sc) with beta4
(2.4.18-0.13)
Comment 18 Arjan van de Ven 2002-04-08 11:02:51 EDT
Please use 2.4.18-0.16 from now on; it's supposed to have stuff fixed :)
Comment 19 Clay Cooper 2002-04-10 16:50:05 EDT
No kernel oops on a 6450 or a 500sc after 24 hours of newburn w/ kernel
2.4.18-0.16smp/up.
Comment 20 Arjan van de Ven 2002-04-11 08:47:48 EDT
Tentatively closing
If it happens after more testing please reopen this bug

Note You need to log in before you can comment on or make changes to this bug.