Bug 61045 - "Irq routing conflict" reported with UP kernel on a 6450
Summary: "Irq routing conflict" reported with UP kernel on a 6450
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-12 16:53 UTC by Clay Cooper
Modified: 2007-04-18 16:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 15:31:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Up kernel dmesg w/ Perc3/SC and onboard adaptec 7899 (7.78 KB, text/plain)
2002-03-12 16:53 UTC, Clay Cooper
no flags Details
Bigmem kernel dmesg w/ Perc3/SC and onboard adaptec 7899 (14.17 KB, text/plain)
2002-03-12 16:54 UTC, Clay Cooper
no flags Details
Up kernel dump_pirq (2.99 KB, text/plain)
2002-03-12 17:28 UTC, Clay Cooper
no flags Details
Bigmem kernel dump_pirq (2.99 KB, text/plain)
2002-03-12 17:29 UTC, Clay Cooper
no flags Details
Lspci -vv (5.77 KB, text/plain)
2002-03-12 19:05 UTC, Clay Cooper
no flags Details

Description Clay Cooper 2002-03-12 16:53:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
On a 6450 with hampton beta 2 (2.4.9-0.1up), w/ bios A10, 5GB ram, 2GB swap, and
Perc3/SC boot controller.

Dmesg reports Irq routing conflicts with megaraid boot controller and onboard
aic7xxx.

Occurs only on UP kernel.  Smp and bigmem report no errors.

Attached is dmesg from UP kernel showing error and bigmem kernel showing no error. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install hampton beta2 on a 6450 w/ Perc3SC as boot controller
2.  Boot to UP kernel
3.  Check dmesg for Irq routing conflict error

	

Actual Results:  Irq routing conflict with UP kernel

Expected Results:  No error

Additional info:

Comment 1 Clay Cooper 2002-03-12 16:53:58 UTC
Created attachment 48287 [details]
Up kernel dmesg w/ Perc3/SC and onboard adaptec 7899

Comment 2 Clay Cooper 2002-03-12 16:54:51 UTC
Created attachment 48288 [details]
Bigmem kernel dmesg w/ Perc3/SC and onboard adaptec 7899

Comment 3 Matt Domsch 2002-03-12 17:00:25 UTC
Clay, need the output of 'dump_pirq' too.


Comment 4 Clay Cooper 2002-03-12 17:28:49 UTC
Created attachment 48304 [details]
Up kernel dump_pirq

Comment 5 Clay Cooper 2002-03-12 17:29:29 UTC
Created attachment 48305 [details]
Bigmem kernel dump_pirq

Comment 6 Arjan van de Ven 2002-03-12 18:03:29 UTC
is it possible to get an lspci -vv from the up kernel too ?


Comment 7 Clay Cooper 2002-03-12 19:05:37 UTC
Created attachment 48325 [details]
Lspci -vv

Comment 8 Matt Domsch 2002-03-12 20:59:39 UTC
It's interesting that the BIOS (I think) has assigned the interrupts according 
to what's found in the pirq table (so that matches), but values requested in 
the ServerWorks router are different.  How are those values originally set?
-Matt

Comment 9 Clay Cooper 2002-03-21 17:30:18 UTC
Not fixed in beta3

Comment 10 Michael K. Johnson 2002-03-28 16:42:54 UTC
Is this one of the bugs that goes away with the BOOT kernel and
the "apic" boot option?

Comment 11 John A. Hull 2002-04-08 22:30:26 UTC
Any word on this, Clay?

Comment 12 Clay Cooper 2002-04-09 12:51:33 UTC
Using kernel 2.4.18-0.16, and loading with the "apic" option, error message
still appears.

Comment 13 Arjan van de Ven 2002-04-09 12:59:22 UTC
The apic option is ignored by UP kernels since it is assumed that the buggy
bioses are all on SMP machines.

Comment 14 Clay Cooper 2002-04-22 20:29:36 UTC
Reproduced in Hampton Gold.

Comment 15 Michael K. Johnson 2002-08-14 15:31:37 UTC
Adding the "apic" option to the UP kernel is known to break
laptops, so that is not an option.  We are able to install on
those laptops with the "apic" option available, but that's
different from normal operation.

Comment 16 John A. Hull 2002-08-22 16:07:13 UTC
Closing. Good in Milan beta 5


Note You need to log in before you can comment on or make changes to this bug.