Bug 610471 - [system-config-kdump] POT File outdated
Summary: [system-config-kdump] POT File outdated
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact: Ankit Patel
URL:
Whiteboard:
Keywords: i18n, Translation
Depends On:
Blocks: 576455
TreeView+ depends on / blocked
 
Reported: 2010-07-02 07:56 UTC by Ankit Patel
Modified: 2014-01-13 00:12 UTC (History)
7 users (show)

Fixed In Version: system-config-kdump-2.0.2.2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:42:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
control-center gets English message for system-config-kdump entry (155.20 KB, image/png)
2010-07-02 07:56 UTC, Ankit Patel
no flags Details
kdump entry in control-center (42.09 KB, application/octet-stream)
2010-08-15 18:41 UTC, A S Alam
no flags Details

Description Ankit Patel 2010-07-02 07:56:39 UTC
Created attachment 428753 [details]
control-center gets English message for system-config-kdump entry

Description of problem:
system-config-kdump POT file is outdated and the messages from system-config-kdump.desktop.in are not extracted in POT file hence PO files are not having it for translations, as a result for every localized languages these messages are appearing in English.

Version-Release number of selected component (if applicable):
system-config-kdump-2.0.2.1-19.el6.noarch.rpm

How reproducible:
Everytime

Steps to Reproduce:
1. Run "LANG=gu_IN.UTF-8 gnome-control-center"
2. Observe the system-config-kdump entry
3. Also observe the tooltip messages
  
Actual results:
system-config-kdump entry and tooltips both are appearing in English.

Expected results:
system-config-kdump entry and tooltips both should appear in local language.

Additional info:
po/Makefile needs to be updated to include .desktop.in files to grab the messages for translation extraction into POT files.

Comment 2 RHEL Product and Program Management 2010-07-02 08:23:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Roman Rakus 2010-07-02 08:55:29 UTC
Thanks for the report. I will update it.

Comment 5 Roman Rakus 2010-07-22 11:14:29 UTC
Changes commited to git. Awaiting localizations.
I will keep this bug in ASSIGNED state and will update the package right before Snapshot 11 with updated localizations.

Comment 6 Ankit Patel 2010-07-22 11:39:58 UTC
(In reply to comment #5)
> Changes commited to git. Awaiting localizations.
> I will keep this bug in ASSIGNED state and will update the package right before
> Snapshot 11 with updated localizations.    

Well, I can't see changes reflected to any of the POT of PO files.
1. Fedora: https://translate.fedoraproject.org/projects/p/system-config-kdump/c/master/view/po/system-config-kdump.pot
2. RHEL: https://translate.fedoraproject.org/projects/p/system-config-kdump/c/rhel6/view/po/system-config-kdump.pot

Please check again.

Thanks!
Ankit

Comment 7 Roman Rakus 2010-07-22 12:24:02 UTC
http://git.fedorahosted.org/git/?p=system-config-kdump.git;a=log;h=refs/heads/rhel6
It is in git. I don't know when will it appear on the translate.fedoraproject.org.

Comment 8 Ankit Patel 2010-07-22 12:43:54 UTC
(In reply to comment #7)
> http://git.fedorahosted.org/git/?p=system-config-kdump.git;a=log;h=refs/heads/rhel6
> It is in git. I don't know when will it appear on the
> translate.fedoraproject.org.    

got it, thanks, will be done by 6th Aug. to ensure we achieve Snapshot 11 (Aug 11) deadline.

Comment 9 Ankit Patel 2010-08-10 11:09:33 UTC
Completed translations of system-config-kdump for all Red Hat supported languages (except Assamese [as.po], due to no resource) and submitted it upstream: https://translate.fedoraproject.org/projects/p/system-config-kdump/c/rhel6/

Could you please grab the translations from there and make a new build?

Thanks!
Ankit

Comment 10 Roman Rakus 2010-08-10 14:46:06 UTC
(In reply to comment #9)
> Completed translations of system-config-kdump for all Red Hat supported
> languages (except Assamese [as.po], due to no resource) and submitted it
> upstream:
> https://translate.fedoraproject.org/projects/p/system-config-kdump/c/rhel6/
> 
Thanks.
> Could you please grab the translations from there and make a new build?
> 
Sure.
> Thanks!
> Ankit

Comment 11 Roman Rakus 2010-08-10 16:15:22 UTC
Fixed in system-config-kdump-2.0.2.2-1.el6

Comment 12 Ankit Patel 2010-08-10 16:45:19 UTC
FIXED.

TESTED and VERIFIED with system-config-kdump-2.0.2.2-1.el6.

Thanks!
Ankit

Comment 14 A S Alam 2010-08-15 18:41:44 UTC
Created attachment 438854 [details]
kdump entry in control-center

Comment 15 A S Alam 2010-08-15 18:43:54 UTC
status - FIXED
tested Package: system-config-kdump-2.0.2.2-2.el6.noarch

Detail:
1) Screenshot - Comment #14
2) Mo status: 100%/142 (as.po - check comment #9)
--------
as:
12 translated messages.
bn_IN:
142 translated messages.
de:
142 translated messages.
es:
142 translated messages.
fr:
142 translated messages.
gu:
142 translated messages.
hi:
142 translated messages.
it:
142 translated messages.
ja:
142 translated messages.
kn:
142 translated messages.
ko:
142 translated messages.
mr:
142 translated messages.
ml:
142 translated messages.
or:
142 translated messages.
pa:
142 translated messages.
pt_BR:
142 translated messages.
ru:
142 translated messages.
ta:
142 translated messages.
te:
142 translated messages.
zh_CN:
142 translated messages.
zh_TW:
142 translated messages.
--------

Comment 16 releng-rhel@redhat.com 2010-11-10 21:42:14 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.