Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610481 - [rhn-client-tools] POT File outdated
[rhn-client-tools] POT File outdated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Milan Zázrivec
Garik Khachikyan
: i18n, Translation
Depends On:
Blocks: 576455 619735
  Show dependency treegraph
 
Reported: 2010-07-02 04:19 EDT by Ankit Patel
Modified: 2015-01-04 16:57 EST (History)
8 users (show)

See Also:
Fixed In Version: rhn-client-tools-1.0.0-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:30:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
control-center gets English message for rhn_register entry (154.39 KB, image/png)
2010-07-02 04:19 EDT, Ankit Patel
no flags Details
screenshot showing english messages in main menu (861.98 KB, image/png)
2010-07-30 07:44 EDT, Ankit Patel
no flags Details
latest rhn-client-tools with Hindi RHEL6 Workstation (535.26 KB, image/png)
2010-07-30 08:34 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Ankit Patel 2010-07-02 04:19:26 EDT
Created attachment 428761 [details]
control-center gets English message for rhn_register entry

Description of problem:
rhn-client-tools POT file is outdated and the messages from rhn_register.desktop are not extracted in POT file hence PO files are not having it for translations, as a result for every localized languages these messages are appearing in English.


Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-24.el6.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. Run "LANG=gu_IN.UTF-8 gnome-control-center"
2. Observe the rhn_register entry
3. Also observe the tooltip messages
  
Actual results:
rhn_register entry and tooltips both are appearing in English.

Expected results:
rhn_register entry and tooltips both should appear in local language.

Additional info:
adding rhn_register.desktop entry in the po/Makefile should help extract messages for translation in POT and hence PO for translators
Comment 2 RHEL Product and Program Management 2010-07-02 04:43:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Ankit Patel 2010-07-26 08:27:29 EDT
Milan, is it possible for you to look into this bug as well?

Thanks!
Ankit
Comment 7 Milan Zázrivec 2010-07-27 09:09:59 EDT
This is problem has already been addresses in the upstream package and
the fix for this bug is simply a cherry-pick in between two git
repositories.

Related commit:
http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=863ca169e2f1666cd51e3535c8bebe57f1d2616e

devel_ack+
Comment 9 Ankit Patel 2010-07-28 04:12:47 EDT
(In reply to comment #7)
> This is problem has already been addresses in the upstream package and
> the fix for this bug is simply a cherry-pick in between two git
> repositories.
> 
> Related commit:
> http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=863ca169e2f1666cd51e3535c8bebe57f1d2616e
> 
> devel_ack+    

Alright, grabbing the POTs and POs from the git repo. Gimme time till 11th August (last date to submit translations for Snapshot 11), afterwards you can rebuild the package with latest translations. 

Thanks!
Ankit
Comment 10 Milan Zázrivec 2010-07-28 10:09:15 EDT
spacewalk.git master: 863ca169e2f1666cd51e3535c8bebe57f1d2616e
satellite.git CLIENT-RHEL-6: 0dcad88d0903de357a0ca54feb5d79b401fbe119
Comment 18 Ankit Patel 2010-07-30 07:44:02 EDT
Created attachment 435532 [details]
screenshot showing english messages in main menu

If you visit System => Administration => RHN Registration menu item, you will find it not localized, because it's not available for translations.

See the attached screenshot for more details.

Thanks!
Ankit
Comment 19 Garik Khachikyan 2010-07-30 08:01:45 EDT
hi Ankit,

I'll be trying now to make a KVM RHEL6 Workstation with IN locale and see if the upgraded/latest rhn-client-tools will resolve the issue.

thanks.
G.
Comment 20 Garik Khachikyan 2010-07-30 08:33:39 EDT
# REOPEN

For my installed KVM RHEL6 Workstation with latest rhn-client-tools package (rhn-client-tools-1.0.0-33.el6.noarch) there seems the text for RHN Registration is not translated still...

Please let me know if there is more info needed on this.
thanks.
P.S. Attached is the screenshot with the illustration of it.
Comment 21 Garik Khachikyan 2010-07-30 08:34:41 EDT
Created attachment 435540 [details]
latest rhn-client-tools with Hindi RHEL6 Workstation
Comment 22 Milan Zázrivec 2010-07-30 08:53:13 EDT
The intention of this bug was not really to come up with a fix so that
RHN Registration menu item would be displayed localized in non - English
language settings (although I do understand that the initial comment
might suggest so).

Fix for this bug report was simply to:
* update one of rhn-client-tools Makefiles so that we'd be able to
include strings from rhn-client-tools.desktop files into .po files
* regenerate .po files with the updated Makefile so that the localization
team can translate the updated strings.

Translations themselves will be coming with bug #619735
Comment 23 Garik Khachikyan 2010-07-30 09:02:29 EDT
Thanks a lot Milan for the clarifications.

Could you please apply the scenario that would be sufficient for verification of this bug please?

many thanks.
Garik/
Comment 24 Milan Zázrivec 2010-07-30 10:27:56 EDT
(In reply to comment #23)
> Thanks a lot Milan for the clarifications.
> 
> Could you please apply the scenario that would be sufficient for verification
> of this bug please?

Check the .po files at

http://git.rhndev.redhat.com/git/?p=satellite.git;a=tree;f=client/rhel/rhn-client-tools/po;hb=refs/heads/CLIENT-RHEL-6

whether they contain extracted strings from rhn-client-tools.desktop file.
Comment 25 Ankit Patel 2010-08-10 08:06:05 EDT
patch submitted via bug #619735 has all necessary changes required with respect to translations.

Thanks!
Ankit
Comment 26 Garik Khachikyan 2010-08-10 08:34:25 EDT
Hi Ankit,

Checking the gu.po file in "http://git.rhndev.redhat.com/git/?p=satellite.git;a=blob;f=client/rhel/rhn-client-tools/po/gu.po;h=9ade3469164593420fcd3bd60e2fc9d4d6fff57d;hb=refs/heads/CLIENT-RHEL-6" there seems for the hint of the "RHN Registration" menu item (../rhn_register.desktop.in.h:2) is not translated.

Honestly I have no idea if it's ok or not. Could you please check that?
Otherwise the bug seems fixed for me (referring to comment#24)

#: ../rhn_register.desktop.in.h:1
2280 #, fuzzy
2281 msgid "RHN Registration"
2282 msgstr "નોંધણી નંબર (_n)"
2283 
2284 #: ../rhn_register.desktop.in.h:2
2285 msgid "Register for software updates from Spacewalk/Satellite/Red Hat Network"
2286 msgstr ""
2287 
2288 #: ../rhn_register.desktop.in.h:3
2289 #, fuzzy
2290 msgid "Register to Spacewalk/Satellite/Red Hat Network."
2291 msgstr "Red Hat નેટવર્ક સાથે નોંધણી કરાવો"
Comment 27 Garik Khachikyan 2010-08-10 08:36:58 EDT
looked to another lang translation as well: seems the same. (not declared)
Comment 28 Ankit Patel 2010-08-10 09:15:10 EDT
(In reply to comment #26)
> Hi Ankit,
> 
> Checking the gu.po file in
> "http://git.rhndev.redhat.com/git/?p=satellite.git;a=blob;f=client/rhel/rhn-client-tools/po/gu.po;h=9ade3469164593420fcd3bd60e2fc9d4d6fff57d;hb=refs/heads/CLIENT-RHEL-6"
> there seems for the hint of the "RHN Registration" menu item
> (../rhn_register.desktop.in.h:2) is not translated.
> 
> Honestly I have no idea if it's ok or not. Could you please check that?
> Otherwise the bug seems fixed for me (referring to comment#24)
> 
> #: ../rhn_register.desktop.in.h:1
> 2280 #, fuzzy
> 2281 msgid "RHN Registration"
> 2282 msgstr "નોંધણી નંબર (_n)"
> 2283 
> 2284 #: ../rhn_register.desktop.in.h:2
> 2285 msgid "Register for software updates from Spacewalk/Satellite/Red Hat
> Network"
> 2286 msgstr ""
> 2287 
> 2288 #: ../rhn_register.desktop.in.h:3
> 2289 #, fuzzy
> 2290 msgid "Register to Spacewalk/Satellite/Red Hat Network."
> 2291 msgstr "Red Hat નેટવર્ક સાથે નોંધણી કરાવો"    

Well, this bug is not about getting translations completed. This bug is about getting ready (in other terms making POT file for translators) for translations.

So, it seems fixed to me. And I have provided translation patch via another bug #619735 as I mentioned.

Thanks!
Ankit
Comment 29 Garik Khachikyan 2010-08-10 09:31:55 EDT
Then I think I can do this ( put it to verified...O:-) )
Comment 30 releng-rhel@redhat.com 2010-11-10 16:30:17 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.