Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 610769 - AttributeError: 'str' object has no attribute 'get'
AttributeError: 'str' object has no attribute 'get'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
ppc64 Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
anaconda_trace_hash:0e7d1a352b3ab529e...
:
: 622558 (view as bug list)
Depends On:
Blocks: 582286 603059
  Show dependency treegraph
 
Reported: 2010-07-02 08:15 EDT by Martin Banas
Modified: 2010-11-10 14:50 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.57-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:50:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (229.88 KB, text/plain)
2010-07-02 08:15 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2010-07-02 08:15:19 EDT
The following was filed automatically by anaconda:
anaconda 13.21.56 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/kickstart.py", line 577, in execute
    if d.get("HWADDR") == device:
  File "/usr/lib/anaconda/kickstart.py", line 1148, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1102, in <module>
    ksdata.execute()
AttributeError: 'str' object has no attribute 'get'
Comment 1 Martin Banas 2010-07-02 08:15:23 EDT
Created attachment 429043 [details]
Attached traceback automatically from anaconda.
Comment 2 Martin Banas 2010-07-02 08:19:33 EDT
To reproduce this, just start RHEL6 installation with following kickstart file, where eth1 is non-existing device:

network --device eth1 --bootproto dhcp
%packages
@Base
%end

Version of components:
RHEL6.0-20100701.0
anaconda-13.21.56-1.el6
Comment 3 RHEL Product and Program Management 2010-07-02 08:23:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Chris Lumens 2010-07-02 09:16:31 EDT
Please check this and 603059 with updates=http://clumens.fedorapeople.org/610769.img.
Comment 5 Martin Banas 2010-07-02 09:27:27 EDT
working OK with updates.img

      ┌───────────────┤ Error Parsing Kickstart Config ├────────────────┐
      │                                                                 │
      │ The following error was found while parsing the kickstart       │
      │ configuration file:                                             │
      │                                                                 │
      │ The following problem occurred on line 1 of the kickstart file: │
      │                                                                 │
      │ The provided network interface eth1 does not exist              │
      │                                                                 │
      │                           ┌────────┐                            │
      │                           │ Reboot │                            │
      │                           └────────┘                            │
      │                                                                 │
      │                                                                 │
      └─────────────────────────────────────────────────────────────────┘
Comment 7 Alexander Todorov 2010-07-16 11:17:06 EDT
With snapshot #8 there's no traceback but the dialog from comment #5. Moving to VERIFIED.
Comment 8 Chris Lumens 2010-08-09 14:24:49 EDT
*** Bug 622558 has been marked as a duplicate of this bug. ***
Comment 9 releng-rhel@redhat.com 2010-11-10 14:50:16 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.