Bug 610770 - Update on 1st July has killed Keyboard
Summary: Update on 1st July has killed Keyboard
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 12:15 UTC by Stephen
Modified: 2010-07-06 20:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 18:48:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen 2010-07-02 12:15:39 UTC
Description of problem:

I carried out an update on the 1st of July and now my keyboard has ceased working after X has started running under Gnome.  I can log in via GDM entering my password but as soon as X starts the keyboard stops.  This occurs on multiple Kernels.  I can run to Init Level 3 and the keyboard works perfectly, but as soon as I type startX I lose my keyboard.  The mouse works perfectly.  When I log off I get a gnome-panel abort

This does not occur if I logon under KDE

I am using an ASPIRE 5810T-8952 laptop.

Version-Release number of selected component (if applicable):


How reproducible:

All the time

Steps to Reproduce:
1. Logon using GDM into Gnome
2.
3.
  
Actual results:

Keyboard dies after logon

Expected results:

keyboard keeps on working

Additional info:

Comment 1 Stephen 2010-07-02 23:00:49 UTC
ok after a bit of a google I have found out the problem is actually that the keyboard is slow. If i keep the key pressed down it eventually registers

Comment 2 Ray Strode [halfline] 2010-07-06 18:48:45 UTC
sounds like you have "slow keys" enabled.

if you navigate to 
    System > Preferences > Keyboard 
And then click the
    Accessibility
tab then you'll notice
    Only accept long keypresses
is enabled.  Uncheck that check box and you should be good to go.

Comment 3 Stephen 2010-07-06 19:13:24 UTC
Thanks, I did indeed have long keypresses set, however to get to the setting I had to use System -> Preferences -> Universal Access so I think something in the update set this for me as I have never set any of the Accessibility or Universal Access options, apart from leaving them at their defaults.  Still its all OK now so once again thanks.

Comment 4 Ray Strode [halfline] 2010-07-06 20:32:34 UTC
There's a hotkey to turn it on.  If you hold down the shift key for more than 8 seconds it will enable itself.  This is so users who aren't physically able to use a keyboard without long keypresses enabled are able to enable the feature.


Note You need to log in before you can comment on or make changes to this bug.