Bug 61078 - uninstall does not remove alternatives mta entries
uninstall does not remove alternatives mta entries
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 00:20 EST by Chris Ricker
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-17 14:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-03-13 00:20:11 EST
After uninstalling sendmail, I'm left with:

[kaboom@skuld alternatives]$ sudo /usr/sbin/alternatives --display mta
mta - status is manual.
 link currently points to /usr/sbin/sendmail.postfix
/usr/sbin/sendmail.sendmail - priority 90
 slave mta-mailq: /usr/bin/mailq.sendmail
 slave mta-newaliases: /usr/bin/newaliases.sendmail
 slave mta-rmail: /usr/bin/rmail.sendmail
 slave mta-mailqman: /usr/share/man/man1/mailq.sendmail.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.sendmail.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.sendmail.5.gz
/usr/sbin/sendmail.postfix - priority 30
 slave mta-mailq: /usr/bin/mailq.postfix
 slave mta-newaliases: /usr/bin/newaliases.postfix
 slave mta-rmail: /usr/bin/rmail.postfix
 slave mta-mailqman: /usr/share/man/man1/mailq.postfix.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.postfix.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.postfix.5.gz
Current `best' version is /usr/sbin/sendmail.sendmail.
[kaboom@skuld alternatives]$ rpm -qa | egrep "(sendmail|postfix|chkconfig)"
chkconfig-1.3.1-1
postfix-1.1.4-1
[kaboom@skuld alternatives]$ 


sendmail needs to be executing

/usr/sbin/alternatives --remove mta /usr/sbin/sendmail.sendmail

in its uninstall script.
Comment 1 Florian La Roche 2002-03-13 09:43:23 EST
Should be fixed within newest rawhide rpm as already pushed out to
ftp.redhat.com

Thanks,

Florian La Roche
Comment 2 Chris Ricker 2002-03-17 14:41:39 EST
Which version should fix this?  I just tried:

chkconfig-1.3.4
ntsysv-1.3.4
postfix-1.1.4-3
sendmail-8.12.2-8

I installed all 4, then ran

# alternatives --display mta
and got output like above.

I then ran
# rpm -e sendmail

and got output
/usr/sbin/sendmail has not been configured as an alternative for mta

The package otherwise uninstalled cleanly, but left a broken mail configuration,
since it didn't remove sendmail from alternatives:

# /usr/sbin/alternatives --display mta
mta - status is auto.
 link currently points to /usr/sbin/sendmail.postfix
/usr/sbin/sendmail.sendmail - priority 90
 slave mta-mailq: /usr/bin/mailq.sendmail
 slave mta-newaliases: /usr/bin/newaliases.sendmail
 slave mta-rmail: /usr/bin/rmail.sendmail
 slave mta-mailqman: /usr/share/man/man1/mailq.sendmail.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.sendmail.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.sendmail.5.gz
/usr/sbin/sendmail.postfix - priority 30
 slave mta-mailq: /usr/bin/mailq.postfix
 slave mta-newaliases: /usr/bin/newaliases.postfix
 slave mta-rmail: /usr/bin/rmail.postfix
 slave mta-mailqman: /usr/share/man/man1/mailq.postfix.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.postfix.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.postfix.5.gz
Current `best' version is /usr/sbin/sendmail.sendmail.

It looks like uninstall is still failing to clean up alternatives....
Comment 3 Florian La Roche 2002-03-25 09:59:57 EST
Ok, is now really fixed in 8.12.2-10 or newer.

Thanks for the report,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.