Bug 610820 - pdfedit - request for EL-5/6 branches
pdfedit - request for EL-5/6 branches
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pdfedit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 10:08 EDT by Mark Chappell
Modified: 2010-07-29 06:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 13:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Chappell 2010-07-02 10:08:14 EDT
I would like to see pdfedit in EPEL, as such I would request EL5 and EL-6 branches for lesstif.  I am happy to (co)maintain if you're not interested in EPEL. (I == tremble)
Comment 1 Orion Poplawski 2010-07-02 13:35:36 EDT
Sounds good.  Making the request.  I checked in change to devel to use openmotif instead of lesstif on EPEL, but I can't get it to compile on EL-5:

g++ -c  -O2   -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -fexceptions    -pipe -posix -ansi -std=c++98 -pedantic -I. -I/builddir/build/BUILD/pdfedit-0.4.5/src -I/builddir/build/BUILD/pdfedit-0.4.5/src/xpdf/  -I/usr/include -I/usr/include/freetype2  -I/usr/include -o textoutputengines.o textoutputengines.cc
cpagecontents.cc: In member function 'void pdfobjects::CPageContents::addInlineImage(const std::vector<char, std::allocator<char> >&, const libs::Point&, const libs::Point&)':
cpagecontents.cc:543: warning: passing 'const double' for argument 1 to 'pdfobjects::CObjectSimple<Tp>::CObjectSimple(const typename pdfobjects::PropertyTraitSimple<Tp>::value&) [with pdfobjects::PropertyType Tp = pInt]'
/usr/include/boost/noncopyable.hpp: In copy constructor 'pdfobjects::CObjectSimple<pInt>::CObjectSimple(const pdfobjects::CObjectSimple<pInt>&)':
/usr/include/boost/noncopyable.hpp:27: error: 'boost::noncopyable_::noncopyable::noncopyable(const boost::noncopyable_::noncopyable&)' is private
/builddir/build/BUILD/pdfedit-0.4.5/src/kernel/cobjectsimple.h:104: error: within this context
cpagecontents.cc: In member function 'void pdfobjects::CPageContents::addInlineImage(const std::vector<char, std::allocator<char> >&, const libs::Point&, const libs::Point&)':
cpagecontents.cc:543: note: synthesized method 'pdfobjects::CObjectSimple<pInt>::CObjectSimple(const pdfobjects::CObjectSimple<pInt>&)' first required here 
cpagecontents.cc:544: warning: passing 'const double' for argument 1 to 'pdfobjects::CObjectSimple<Tp>::CObjectSimple(const typename pdfobjects::PropertyTraitSimple<Tp>::value&) [with pdfobjects::PropertyType Tp = pInt]'
/usr/include/boost/noncopyable.hpp: In copy constructor 'pdfobjects::CObjectSimple<pName>::CObjectSimple(const pdfobjects::CObjectSimple<pName>&)':
/usr/include/boost/noncopyable.hpp:27: error: 'boost::noncopyable_::noncopyable::noncopyable(const boost::noncopyable_::noncopyable&)' is private
/builddir/build/BUILD/pdfedit-0.4.5/src/kernel/cobjectsimple.h:104: error: within this context
cpagecontents.cc: In member function 'void pdfobjects::CPageContents::addInlineImage(const std::vector<char, std::allocator<char> >&, const libs::Point&, const libs::Point&)':
cpagecontents.cc:545: note: synthesized method 'pdfobjects::CObjectSimple<pName>::CObjectSimple(const pdfobjects::CObjectSimple<pName>&)' first required here 

Haven't tried EL-6 yet.
Comment 2 Mark Chappell 2010-07-29 06:19:43 EDT
Switching to openmotif for EL-6 works, the EL-5 issue appears to be due to a change in the boost API (note EL-5 has an ancient version of boost)

Note You need to log in before you can comment on or make changes to this bug.