Bug 610864 - SELinux is preventing /sbin/unix_chkpwd "read" access on shadow.
SELinux is preventing /sbin/unix_chkpwd "read" access on shadow.
Status: CLOSED DUPLICATE of bug 610862
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:9fc84ebe7f7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 11:57 EDT by Benjamin Kahn
Modified: 2010-07-07 06:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 06:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2010-07-02 11:57:53 EDT
Summary:

SELinux is preventing /sbin/unix_chkpwd "read" access on shadow.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by unix_chkpwd. It is not expected that this
access is required by unix_chkpwd and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:getty_t:s0
Target Context                system_u:object_r:shadow_t:s0
Target Objects                shadow [ file ]
Source                        unix_chkpwd
Source Path                   /sbin/unix_chkpwd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pam-1.1.1-4.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.x86_64 #1 SMP Fri
                              Jun 11 09:38:12 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Fri 02 Jul 2010 11:54:00 AM EDT
Last Seen                     Fri 02 Jul 2010 11:54:00 AM EDT
Local ID                      cc11dea3-10e0-4180-8389-7b1c77f4b7a9
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278086040.590:21): avc:  denied  { read } for  pid=1340 comm="unix_chkpwd" name="shadow" dev=dm-0 ino=132316 scontext=system_u:system_r:getty_t:s0 tcontext=system_u:object_r:shadow_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1278086040.590:21): avc:  denied  { open } for  pid=1340 comm="unix_chkpwd" name="shadow" dev=dm-0 ino=132316 scontext=system_u:system_r:getty_t:s0 tcontext=system_u:object_r:shadow_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278086040.590:21): arch=c000003e syscall=2 success=yes exit=3 a0=7ff021b6a2eb a1=80000 a2=1b6 a3=0 items=0 ppid=1314 pid=1340 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=tty1 ses=4294967295 comm="unix_chkpwd" exe="/sbin/unix_chkpwd" subj=system_u:system_r:getty_t:s0 key=(null)



Hash String generated from  catchall,unix_chkpwd,getty_t,shadow_t,file,read
audit2allow suggests:

#============= getty_t ==============
allow getty_t shadow_t:file { read open };
Comment 1 Miroslav Grepl 2010-07-07 06:44:02 EDT

*** This bug has been marked as a duplicate of bug 610862 ***

Note You need to log in before you can comment on or make changes to this bug.