Bug 610892 - [abrt] firefox-3.6.4-4.el6: killed by signal 6: ###!!! ABORT: X_CloseDevice: XI_BadDevice (invalid Device parameter);
[abrt] firefox-3.6.4-4.el6: killed by signal 6: ###!!! ABORT: X_CloseDevice: ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
abrt_hash:9dbe0fe53ed2267cfb3de377b8b...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 13:00 EDT by Mike Khusid
Modified: 2013-04-02 19:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 10:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (42.43 KB, text/plain)
2010-07-02 13:00 EDT, Mike Khusid
no flags Details

  None (edit)
Description Mike Khusid 2010-07-02 13:00:04 EDT
abrt version: 1.1.4
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.6/firefox
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.6/firefox
global_uuid: 9dbe0fe53ed2267cfb3de377b8b32e80be340aee
kernel: 2.6.32-38.el6.x86_64
package: firefox-3.6.4-4.el6
rating: 4
reason: Process /usr/lib64/firefox-3.6/firefox was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)

How to reproduce
-----
1. Run a flash-intensive application on 64-bit system (with 32-bit flash)
2. Eventually npviewer and possibly flashplugin will take 100% cpu

top - 12:47:30 up 22:15,  4 users,  load average: 1.18, 1.06, 1.10
Tasks: 236 total,   2 running, 234 sleeping,   0 stopped,   0 zombie
Cpu(s): 52.8%us, 20.6%sy,  0.0%ni, 26.6%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   3717780k total,  3613680k used,   104100k free,   196536k buffers
Swap:  4194296k total,        0k used,  4194296k free,  1007904k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 2658 mkhusid   20   0 1364m 881m 4676 S 141.2 24.3  62:44.53 pulseaudio        
 8018 mkhusid   20   0  461m 250m  13m R 137.4  6.9   2:50.26 npviewer.bin      
 7603 mkhusid   20   0  938m  24m  12m S 11.5  0.7   9:35.49 totem-plugin-vi    
 2619 mkhusid   20   0  517m  39m 8604 S  5.7  1.1   0:28.80 gnome-settings-    
 2346 root      20   0  219m  53m  17m S  3.8  1.5  13:06.95 Xorg               

3. Exit firefox.
Comment 1 Mike Khusid 2010-07-02 13:00:07 EDT
Created attachment 429114 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-07-15 10:48:27 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Matěj Cepl 2010-07-16 12:09:51 EDT
#2  <signal handler called>
No symbol table info available.
#3  0x000000352b4329c5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = 3170
        selftid = 3170
#4  0x000000352b4341a5 in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, 
          sa_mask = {__val = {0, 140737385936040, 0, 0, 0, 228358908752, 
    140415833659792, 228639911168, 4294967295, 140737385936064, 5, 
    228642229392, 0, 140737385908912, 216625865122, 0}}, sa_flags = 
    717283072, sa_restorer = 0x5}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#5  0x000000353c0107f7 in PR_Abort ()
    at ../../../mozilla/nsprpub/pr/src/io/prlog.c:548
No locals.
#6  0x000000326fe3075e in Abort (aMsg=<value optimized out>)
    at nsDebugImpl.cpp:385
No locals.
#7  0x000000326fe30afd in NS_DebugBreak_P (aSeverity=<value optimized out>, 
    aStr=<value optimized out>, aExpr=<value optimized out>, aFile=
    0x326fe861a2 "nsX11ErrorHandler.cpp", aLine=182) at nsDebugImpl.cpp:356
        buf = {buffer = 
    "###!!! ABORT: X_CloseDevice: XI_BadDevice (invalid Device parameter); 9 requests ago: file nsX11ErrorHandler.cpp, line 182\000\000\000\000\000\000\060\315\344\371\377\177\000\000$\315\344\371\377\177\000\000#\315\344\371\377\177\000\000\277\314\344\371\377\177\000\000\260\314\344\371\377\177\000\000\061\315\344\371\377\177\000\000\300\372\227\t\265\177\000\000\306\024\200\060\065\000\000\000\320\230\314\033\265\177\000\000\313\066\202,5\000\000\000\377\377\377\377\000\000\000\000\300\372\227\t\265\177\000\000\320\372\227\t\265\177\000\000 \212w+5", '\000' <repeats 11 times>"\300, \372\227\t\265\177\000\000\360"..., 
          curlen = 122}
        ll = PR_LOG_ALWAYS
        sevString = <value optimized out>
#8  0x000000326f4d2b81 in X11Error (display=0x7fb51bc87000, 
    event=<value optimized out>) at nsX11ErrorHandler.cpp:182
        notes = {<nsFixedCString> = {<nsCString> = {<nsACString_internal> = {
                mData = 
    0x7fb4e50ef088 "X_CloseDevice: XI_BadDevice (invalid Device parameter); 9 requests ago", mLength = 70, mFlags = 65541}, <No data fields>}, 
            mFixedCapacity = 63, mFixedBuf = 
    0x7ffff9e4d7a0 "X_CloseDevice: XI_BadDevice (invalid Device parameter); 9"}, mStorage = 
    "X_CloseDevice: XI_BadDevice (invalid Device parameter); 9\000\322\033\265\177\000"}
        buffer = 
    "XI_BadDevice (invalid Device parameter)", '\000' <repeats 2008 times>
        age = 9
        message = {<nsFixedCString> = {<nsCString> = {<nsACString_internal> = 
    {mData = 0x7ffff9e4d740 "XInputExtension.4", mLength = 17, mFlags = 
    65553}, <No data fields>}, mFixedCapacity = 63, mFixedBuf = 
    0x7ffff9e4d740 "XInputExtension.4"}, mStorage = 
    "XInputExtension.4\000\304\033\265\177\000\000\357\034x\000\000\000\000\000\067\000\000\000\000\000\000\000$#\200.5", '\000' <repeats 11 times>"\362, (H+5\000\000"}
#9  0x000000352e846b04 in _XError (dpy=0x7fb51bc87000, rep=0x7fb4e5075df0)
Comment 5 Matěj Cepl 2010-07-19 15:58:50 EDT
Also, this (from the same thread but way below the show top of the backtrace):

warning:   found `(anonymous namespace)::WorkSourceFuncs' instead
{mSections = warning: can't find linker symbol for virtual table for `nsClassHashtable<nsDepCharHashKey, nsINIParser_internal::INIValue>' value
warning:   found `(anonymous namespace)::WorkSourceFuncs' instead

{<nsBaseHashtable<nsDepCharHashKey, nsAutoPtr<nsINIParser_internal::INIValue>, nsINIParser_internal::INIValue*>> = 
    {<nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser_internal::INIValue> > >> = {mTable = warning: can't find linker symbol for virtual table for `PLDHashTable' value
warning:   found `(anonymous namespace)::WorkSourceFuncs' instead
Comment 6 RHEL Product and Program Management 2011-01-07 10:40:25 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 RHEL Product and Program Management 2011-02-01 00:46:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 RHEL Product and Program Management 2011-02-01 13:26:48 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 RHEL Product and Program Management 2011-04-03 22:23:58 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 10 Suzanne Yeghiayan 2011-10-06 14:39:24 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.
               
Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.