Bug 610990 - Kernel paging error trying to install FC13
Kernel paging error trying to install FC13
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 20:23 EDT by Vince Radice
Modified: 2013-01-10 01:03 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-29 10:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen with error message and some following screens (107.21 KB, image/jpeg)
2010-07-02 20:23 EDT, Vince Radice
no flags Details
JPG with error message and initcall_debug output test # 1 (1.71 MB, image/jpeg)
2010-08-15 22:06 EDT, Vince Radice
no flags Details
Initcall test# 2 (20.68 KB, image/jpeg)
2010-08-15 22:14 EDT, Vince Radice
no flags Details
Failure captured (17.61 KB, text/plain)
2010-11-29 14:47 EST, Vince Radice
no flags Details
Faliure listing with noapic option (23.10 KB, text/plain)
2010-12-02 10:30 EST, Vince Radice
no flags Details
apic=verbose (21.18 KB, text/plain)
2010-12-02 10:31 EST, Vince Radice
no flags Details
apic=debug (21.35 KB, text/plain)
2010-12-02 10:34 EST, Vince Radice
no flags Details
Failure with a bunch of options. (93.91 KB, text/plain)
2010-12-02 10:40 EST, Vince Radice
no flags Details
Failure with noapic acip=off (21.73 KB, text/plain)
2010-12-04 09:05 EST, Vince Radice
no flags Details
Failure with noapic acip=off nosmp (66.49 KB, text/plain)
2010-12-04 09:10 EST, Vince Radice
no flags Details
Failure with just nosmp (63.87 KB, text/plain)
2010-12-04 09:12 EST, Vince Radice
no flags Details

  None (edit)
Description Vince Radice 2010-07-02 20:23:49 EDT
Created attachment 429200 [details]
Screen with error message and some following screens

Description of problem:
While trying to install FC13, I encounter an error during the initialization process.  I boot the install dvd and get to the screen where it asks what kind if install.  I select install a new system.  It starts processing and within 1 minute some sort of error occurs.  I never get any more choices and the system hangs.  By using the boot_delay option, I was able to slow the messages down long enough to capture the error with my digital camera in video mode.  In the attachments are screen captures of the error.  I am getting the following error:
BUG: unable to handle kernel paging request at ffffa000

I have merged 4 screens into 1 file that shows the error and what follows.  I have the entire video (300k+) available if needed


Version-Release number of selected component (if applicable):

Release 13
How reproducible:
Very

Steps to Reproduce:
1. Boot the install dvd
2. Select new install
3.
  
Actual results:
System hangs.  Power off is the only way to clear it


Expected results:
Install of release 13


Additional info:
Comment 1 Vince Radice 2010-07-04 11:45:43 EDT
Correction - the video is 300+ mb, not kb.  Vince Radice
Comment 2 Chuck Ebbert 2010-07-09 04:18:10 EDT
Did older releases work on that hardware?
Comment 3 Vince Radice 2010-07-09 18:22:05 EDT
I am trying to convert from windows to Linux.  I have tried several different distros - Knoppix, Ubuntu, Debian.  None of them worked.  This is the first distribution where I was able to capture some doc on the error.  However, here is an interesting item.  The Ultimate Boot CD which does boot a linux kernel boots fine and I can run the programs there.  Windows XP home runs fine.  I read that this error is sometimes caused by memory problems.  I downloaded the latest Memtest and let it run for 3 hours - no problems found.  Do you want/need screenshots from before the error?  Thank you, Vince Radice
Comment 4 Chuck Ebbert 2010-07-21 06:23:08 EDT
What kind of machine is it (vendor and model)? Is there any possibility of connecting a serial port and capturing the boot messages that way? The screen shots are almost impossible to read.
Comment 5 Vince Radice 2010-07-21 08:43:52 EDT
The machine is an HP Pavillion a705w. It does have serial/parallel ports.  What would I connect to capture the messages?  The screen shots are a little hard to read.  The video is a little better.  I can again to capture the messages with the camera positioned different to see if I can get a better image.  Would you want me to send/post the entire video so you can try to understand the error better?
Comment 6 Chuck Ebbert 2010-07-21 22:54:45 EDT
(In reply to comment #5)
> The machine is an HP Pavillion a705w. It does have serial/parallel ports.  What
> would I connect to capture the messages?

You would need to connect, using a null-modem cable, another computer with a serial port running a terminal emulator program. (It could even be a windows machine.)
Comment 7 Vince Radice 2010-07-27 17:31:57 EDT
3 things
(1) I am having a problem locating a null modem cable.  I don't have one and I have asked several friends who are looking.

(2) I found a document that describes another possibility - remote syslog.  By specifying an ip address during initialization, all messages would be forwarded to that machine and be recorded in the log there.  At least that's what the documentation indicates.
http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/sn-remote-logging.html

I tried this but it doesn't look like the messages made it.  I can't guarantee this as I am not sure where the messages would have been logged.  Still looking.

(3) As the install fails within about 30 seconds after entering the 
linux boot_delay=50 
command, I am wondering if it is up far enough to allow the remote telnet in (I believe that this what you want the null modem cable for).

I think you want me to do this because you can't read the messages from the screen prints that I have posted.  If this is the case, then I need to come up with a way to get the info from them.  How about hooking up a printer and doing screen prints with the Print Screen button?
Comment 8 Vince Radice 2010-07-28 01:05:42 EDT
Printer idea doesn't work.  I tried it.
Comment 9 Bug Zapper 2010-07-30 08:24:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Vince Radice 2010-08-04 12:45:35 EDT
I have downloaded Fedora 13 and this is what I am trying to install.  

Is that the same as rawhide?  

Does it matter which release it is reported against?

Seeing as how I cannot capture the error in a machine-readable form, I will be transcribing the screen print by hand.  Do I start from the beginning all the way to the end?  I presume that all of the lines after the error will be needed.  Any guidelines would be appreciated.  Thanks, Vince Radice
Comment 11 Vince Radice 2010-08-10 13:09:33 EDT
I have transcribed some of the messages captured by the video I took.  There are more lines before and more lines after what I have posted here.  I have isolated the line with the error (I believe)  with a line of dashes before and after it.  The dashes are not in the captured video - I added them.  If you want/need more lines before/after these, I will make an attempt to transcribe those also.

Here is the part that I wrote:

PID hash table entries: 4096 (order: 2, 16384 bytes)
Dcatry cache hash tables enties:131072 (order:7, 524280 bytes)
Imode-cache hash table entries: 65536 (order: 6,262144 bytes)
TCP bind hash table entries 65536 (order:7,524200 bytes)
TCP: hash tables configured (established 131072 bind 65536)
TCP ream registered
UDP hash table entries: 512 (order: 2, 16384 bytes)
UDP-Lite hash table entries: 512 (order: 2,16384 bytes)
NET: Registered protocal family 1
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 28463k freed
platform rtc_cmos: registered platform RTC device (no PNP device found)
apm: BIOS version 1.2 Flags 0x07 (driver version 1.16ac)
audit: initializing netlink socket (disabled)
type=2000 audit(1277610039.964:1): initialized
highmem bounce pool size: 64 pages
HugeTLB registered 4 MB page size, pre-allocated 0 pages
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
msgmni has been set to 1725
alg:No test for stdrmg (krng)
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfg registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pcichp: PCI Express Hot Plug Controller Driver version: 0.4
acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
pci-stub: invalid id string
isapnp Scanning for PnP cards
isapnp: No Plug & Play device found
Non-volitile memory driver v1.3
Linux agpqart interface v0.103
agpgart-intel 0000:00:00:0: Intel 830M Chipset
agpgart-intel 0000:00:00:0: detected 380K stolen memory
agpgart-intel 0000:00:00:0: AGP aperture is 128M @ 0xd0000000
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
----------------------------------------------------------
BUG: unable to handle kernel paging request at ffffa800
----------------------------------------------------------
IP: [<c0418ba6>] __io_apic_modify_irq+0x2d/0x74
*pde = 00009067  *pte = 0202r001
Oops:0003 [all]SMP
last sysfs file:
Modules linked in:

Pid: 1, comm:swapper Not tainted 2.6.33.3-95.fc13.i686 #1 Gamila/Giovaml/Mco
eries/PJ562AA a705w
KIP: 0060:[<c0418ba6?] EFLAGS: 00010006 CPU:0
EIP is ar __io_apic_modify_irq+0x2d/0x74
EAX: f6c002b0 EBX:ffffa000 ECX 00000000 EBX:fffeffff
ESI: 00005000 EDI: 0000003e EBP: f6c3bcdc ESP: f6c3bccc
 BS: 007b ES: 007b FS: 00d0 GS: 00e0 SS: 0068
Process swapper (pid:1, ti=f6c3a000 task=f6c40000 task.ti=f6c3a000)
Stack:
 0000000286 f6c002b0 00000000 00000046 f6c3bef4 c041a14f 00000000 c0938700
(0) 00000017 00000000 f6c3bf00 c047ae7f c0af44ac c062782e 00000000 f6c3bf34
(0) c0628b17 00000202 00000000 fffffffe 00000083 f6dd8000 00000000 c0af44ac
Call trace:
[<c041a14f>] ? startup_ioapic_lrq+0x5c/0x7a
[<c047ac7f>] ? probe_irq_oo+0x57/0x144
[<c062782e>] ? io_serial_mnt+0x0/0x15
[<c0628b17>] ? serial8250_config_port+0x6c8/0x8bd
[<c0625329>] ? uart_add_one_port+0xef/0x2a9
[<c0597b2e>] ? kobject_put+0x37/0x3c
[<c062b267>] ? put_device+0x??/0x11
[<c062c3e8>] ? device_add+0x396/0x49c
[<c0597fed>] ? kobject_set_name_uargs+0x46/0xfc
[<c062f749>] ? platform_device_add+0xf0/0x14f
[<c09e0de5>] ? serial8250_init+0xcd/0x114
[<c09e0d18>] ? serial8250_init+0x0/0x114
[<c0401139>] ? do_one_initcall+0x4c/0x13a
[<c09b7396>] ? kernel_init+0x197/0x1e8
[<c09b71ff>] ? kernel_init+0x0/0x1e8
[<c048383e>] ? kernel_thread_helper+0x6/0x10
Code: e5 57 57 53 03 cc 04 6b 58 94 9b 39 9d 7c 1b 10 8b 1c f5 4c db a3 c8 83 ??
 05 c1 e6 81 e3 ff 0f 00 00 03 1d ec 24 96 c0 29 f3 {09} 3b 8b 73 10 09 75 ??
8b 30 0b 1c f5 4c db a3 c0 83 c6 05 c1
EIP: [<c0418ba6>] __io_apic_modify_irq+0x7d/0x74 SS:ESP 0060:f6c3bccc
CBZ: 00000000fffa0000
---[ end trace 7c4ac46b6fb7fe5 ]---
BUG: unable to handle kernel paging request at ffffb000
IP: [<c04181e8>] native_apic_mem_write+0x18/0x14
*pde * 00009067 *pte = 0262f001
Oops:0003 [02] SMP
last sysfs file:
Modules linked in:

Pid: 1,comm:swapper Tainted : G     D   2.6.33.3-05.fc13.1686 s1 Gamila/G???
mi/Mcon series/PJ562AA-ABA a705w


I believe that I got all of the letters/numbers correct.  If a name appears to be incorrect or you need some numbers verified, please let me  know.  I hope this helps determine what is wrong.  Thanks, Vince Radice
Comment 12 Chuck Ebbert 2010-08-11 08:28:13 EDT
It looks like the IOAPIC is not mapped or has an invalid address. Can you try adding "noacpi" to the boot options?

See also:

http://fedoraproject.org/wiki/KernelCommonProblems
Comment 13 Vince Radice 2010-08-11 09:15:17 EDT
I tried noacpi but it still failed in the same manner.  Three dumb questions
(1) Is that the proper spelling?  I have seen several posts while researching this problem and some (didn't write down where) had it as acpi=off or acpi=no.

(2) When entering boot options, are they separated by spaces or commas or doesn't it matter?  i.e.  linux option1 option2 option3
or  linux option1,option2,option3

(3) Are all of the boot options documented someplace with all of the parameters?

Thank you.
Comment 14 Chuck Ebbert 2010-08-13 06:07:10 EDT
The kernel options are described in the kernel-parameters.txt file in the kernel-doc package.
Comment 15 Vince Radice 2010-08-15 22:06:50 EDT
Created attachment 438877 [details]
JPG with error message and initcall_debug output test # 1
Comment 16 Vince Radice 2010-08-15 22:14:14 EDT
Created attachment 438878 [details]
Initcall test# 2

This is a second run that was made to capture the messages.  The last calls before the error are different from my first attempt.
Comment 17 Vince Radice 2010-08-15 22:25:49 EDT
I was perusing the kernel parameter documentation (Thanks Chuck for telling me where the doc is) and came across the proper format for "noacpi".  The documented way is "acpi=off".  I tried this and got the same results.  Further reading yielded the options loglevel and initcall_debug.  The attachments above are from running the install with these options.  The first was to see what would come out.  I happened to have my camera set up and took a picture of the error.  I then reran the install to capture the output on video so I could trace back further if needed.  When looking at the output, I noticed that the last calls before the error are different. 

This begs the question - Is it the same error?
Comment 18 Vince Radice 2010-09-04 15:27:40 EDT
Is anyone looking into this?  I tried downloading a live cd to see if that makes any difference.  It doesn't.  It still fails so fast I can't see if it the same error.
Comment 19 Chuck Ebbert 2010-09-06 20:07:01 EDT
Could you try the Fedora 14 Alpha live DVD?

Also, try the boot option "noapic", which was what I meant to type in comment #12
Comment 20 Vince Radice 2010-09-06 22:53:17 EDT
It'll take me a few days to try Fedora 14.  

I tried the noapic and got the same error - unable to handle  kernel paging request.

Please help me understand this - there is 1 gb of memory on the system, it is trying to setup for installation (there is no paging file at this time), what is trying to be paged?  My impression is that the installation program is loading and trying to figure out what hardware is on the system.  Is that what is happening?  If so, then back to my question - what is trying to be paged?

I have found several posts about this hardware and some said they got it to work, but never told how.  Is there any way to track back to those people and find out how?  The posts are old - typically 3 or more years old.

Thanks for the help.  I'll post back after I try Fedora 14.
Comment 21 Chuck Ebbert 2010-09-07 00:36:31 EDT
The IOAPIC(s) need(s) to be mapped somewhere in the address range so it/they can be accessed. Either the mapping isn't happening, or the kernel is confused about the addresses to use. If you could boot with the option "ioapic=debug" and capture all of the output to a file there would be more information. The current method of trying to decipher blurry video isn't working very well.
Comment 22 Vince Radice 2010-09-07 08:15:12 EDT
I would LOVE to capture the output to a file, but how?  I don't have a null modem cable.  I asked a few friends - still no luck.  I tried using Net Console - still no luck.  The question appears to me - is the system up far enough to support these things?  If I don't use boot_delay, from the time I hit Enter after the short What do you want to do menu until the error messages are done is about 10 seconds.  My daughter has a High Def digital video recorder.  I was thinking to borrow it and see if the video is any better.  I tried hooking up an ink jet printer and capture the output that way - no luck.  Any and all suggestions on how to capture the error will be much appreciated.  

Thanks
Comment 23 Chuck Ebbert 2010-09-08 13:36:18 EDT
A null modem cable is about $8, I'd just try to buy one somewhere on the internet, or even find one in a store. Just google for "null modem cable".
Comment 24 Vince Radice 2010-09-09 16:47:07 EDT
I tried Fedora FC14 Alpha and it was worse.  I got the loading vmlinuz, loading initrd.img, and the probing EDD (edd=off to disable).  At this point it hung with no further messages.  I waited 10 minutes just to see if anything showed up.

I will pursue the null modem cable.  I didn't realize how cheap they were.  I looked at Compusa's web site.  They had several with different connection available.	DB25 Male and DB9 Female, 2 DB9 Female, and 2 DB25 Male.  I would presume that DB9 is Serial port and DB25 is parallel port.  I remember from too many years ago that serial ports were usually modems.  I believe I want one with 2 DB9 plugs.  With that being the case,  I will pursue getting that cable.  Now about the software.  I remember that there is an option that can be put on the linux command on A705w box.  What about on the other box?  What should I run to capture the data?  I will be on vacation for a while and won't be able to try anything until after Sept. 27.  Thanks for all help.
Comment 25 Chuck Ebbert 2010-09-10 12:23:27 EDT
You can run anything on the other box, even windows. You just neeed a program that can capture serial output. MS terminal was included with windows at one point and even that worked.
Comment 26 Vince Radice 2010-11-06 21:08:57 EDT
I finally got a null modem cable.  I waited until FC14 was ready as I figure the first thing someone will say is try the new version.  Well, I tried it and it failed too.  I presume that the same kernel options for FC13 apply to 14.  Two questions 
Q1 - What linux program will capture the serial output?  I looked for a program that would use a serial modem, but couldn't find anything.  The pc I hope to use to capture the serial output is an FC13 system.

Q2 - Off hand, what would be the kernel option to send the output to the serial port?  I have read through the options and some sound right, but I am not sure the exact option to use.

Thanks for your help,
Vince

p.s. All of the other boxes I have run  Fedora.  I only use windows on the one I am trying to convert because I can't get linux to load.
Comment 27 Vince Radice 2010-11-29 14:47:28 EST
Created attachment 463560 [details]
Failure captured

Here is the output from the failing system as captured on a different PC with the PCs connected with a null modem cable.
Comment 28 Vince Radice 2010-11-29 14:48:48 EST
This also fails with FC14.  Do I change that or does an administrator have to do that?
Comment 29 Kyle McMartin 2010-11-29 19:16:26 EST
Sorry Vince, what do you mean 'administrator' have to do that? If you hook up the null modem cable between this box (the remote) and another linux box (the host) and on the host box run minicom or some other terminal program.

In minicom, set the terminal settings to 9600 no parity 8 bit one stop bit (otherwise known as 9600,8n1) (there's tonnes of docs on this if you need help.)
The terminal device will be ttyS0 or something similar. (Unless you're using a USB serial cable, where it'll be ttyUSB0 or so.)

Then, put the livecd into the 'remote' box, interrupt the boot at the splash screen, and edit the 'command line' for the kernel.

You'll need to append something like

console=ttyS0,8n1 

and remove the 'quiet' and 'rhgb' options. Which will log the kernel buffers out the serial port onto minicom, where you can record it.

regards, Kyle
Comment 30 Kyle McMartin 2010-11-29 19:20:14 EST
If you get that working, it would be useful to boot with the option
"apic=debug"
in order to generate verbose amounts of apic debugging info, which could help us root cause the issue.

It's an extremely bizarre error though, I've not before seen a machine which fails in such a way.

regards, Kyle
Comment 31 Vince Radice 2010-11-29 19:45:44 EST
Kyle, I have the log from the install attempt.  See comment #27.  My question about the administrator is changing this bug report to apply to FC14 also.

Please look at the listing .  There are a lot of messages there.    Please let me know what other options would be helpful.  I was looking at the kernel parameters and saw several that might yield more data.
Thanks for the quick response.
Comment 32 Kyle McMartin 2010-11-29 21:28:54 EST
Ugh, this is really bizarre. The failure is in the low level APIC code as it tries to set up the interrupt table for the serial port. As Chuck said above, it's not mapped so it's causing the paging error.

If you go into the BIOS, do you have the option to turn on/off various on board devices? Try turning the serial port off (obviously you can't log to serial when you try that) and booting up and see if it still falls over in the same place.

It's most curious that "noapic" fails, since it should be avoiding any of those code paths. If you could capture a log with "noapic" and also with "apic=verbose" I would appreciate it.

--Kyle
Comment 33 Vince Radice 2010-12-02 10:30:20 EST
Created attachment 464277 [details]
Faliure listing with noapic option

This is the failure with the noapic option
Comment 34 Vince Radice 2010-12-02 10:31:55 EST
Created attachment 464278 [details]
apic=verbose

Here is the failure with apic=verbose.
Comment 35 Vince Radice 2010-12-02 10:34:08 EST
Created attachment 464279 [details]
apic=debug

I saw that there was another option for apic - debug.  I ran with it and it produced a few more line that with verbose.  It may help.  It can't hurt having this.
Comment 36 Vince Radice 2010-12-02 10:40:33 EST
Created attachment 464282 [details]
Failure with a bunch of options.

As I was going through the kernel options, I came across some which indicated they wee used for debugging purposes.  I ran with them.  The command line I entered is in the file.  I put it there.  Again it can't hurt.  Having made my living as a programmer,  anything may help when debugging a problem.  Thanks for the help.

I will be on vacation for two weeks starting Monday and will not be able to do anything until after that.  Then there is Christmas and New Years.  I don't want to interrupt your holidays.  I do not expect to be able nor want to do anything until next year.

Merry Christmas,
Vince Radice
Comment 37 Vince Radice 2010-12-02 10:55:42 EST
I also tried with the serial port disabled. Same problem.  I tried to change it from 374/IRQ4 to 278/IRQ3.  Still no luck.
Comment 38 Kyle McMartin 2010-12-02 12:09:22 EST
Yowzers, that's really bizarre dude. "noapic" should really be disabling the APIC (but it's still trying for some reason.)

Can you try "noapic acpi=off nosmp"?

(Whenever you get a chance, I don't really take Christmas or anything, so I'll be around.)

I think F-14 will be a lost cause, unless we can find some kernel args to make it go, but we'll probably be able to gin up something to make this work for F-15.

One last thing, is there anything about interrupt controllers in the bios? It might have a toggle for "Advanced Programmable Interrupt Controller" or something for a "Legacy Interrupt Controller" or something. It's entirely possible the machine is just entirely unhappy. :<
Comment 39 Vince Radice 2010-12-04 09:05:38 EST
Created attachment 464746 [details]
Failure with noapic acip=off

I tried it with noapic acip=off.

I also discovered that the command that I issue is listed around line 75 is all of the listings.
Comment 40 Vince Radice 2010-12-04 09:10:15 EST
Created attachment 464747 [details]
Failure with noapic acip=off nosmp

Here is the failure with noapic acip=off nosmp.

This one acted differently after the error.  The last line was not the same as the others and so, I tried hitting keys to see what happens.  I found that if I press ctrl+scroll lock,  more lines come out.  Also shift+scroll lock caused another different set of messages.  I have included those along with a comment before the lines as to what I did.  It looks like nosmp causes a different path through the code.
Comment 41 Vince Radice 2010-12-04 09:12:46 EST
Created attachment 464748 [details]
Failure with just nosmp

Just for grins, I tried just nosmp.  Still failed. Similar results with hittig ctrl+scroll lock and shift+scroll lock.
Comment 42 Vince Radice 2010-12-04 12:56:19 EST
Kyle, in comment 38 you said that noapic should be disabling apic but is not.  Is that a bug in the code for that?  Also, some of the options are case sensitive.  Could this one be and that is why it did not process it correctly?
Comment 43 Kyle McMartin 2010-12-09 11:43:20 EST
To be honest, I just think your hardware is broken. It /should/ be disabling the APIC, but isn't, but the code will correctly disable the APIC on other systems, so it's possible a combination of mis-wired hardware or broken BIOS or something that prevents it from falling back to 8259A irqs. (Legacy fallback *should* work on hardware that old...)

regards, Kyle
Comment 44 Vince Radice 2011-02-19 21:41:51 EST
I got part way there.  While looking for anything for A705W (Pc model) I came across a post that said a guy was able to boot only if the onboard video was 1 mb.  I went into the bios setup and started playing around with several of the options - serial port disabled, parallel port disabled, 1394 disabled - and changed the bios to onboard video with 1 mb and booted.  I esc'ed out of the initial menu and entered
 linux acpi=off apic=off apic=no

in case the spelling was off.  Low and behold, it worked.  I got to the test media screen - never got there before.  To figure out what was the option that worked, I went back and tried each by itself.  All worked!  Still trying to figure out why it now worked,  I started playing around with with all sorts of options - enable/disable serial port, enable/disable parallel port, enable/disable 1394.  All worked.
When I changed back to PCI video, failure was back.  Bottom line - something about PCI video causes the failure.  
Now that I could the installer to run, I hooked up the drive I wanted Fedora on, rebooted using onboard video with 8 mb shared memory and installed FC14.  During the install, I got a message about X (I think) not working.  Only 198 packages were installed.  Something was wrong.  Other installs have somewhere about 1000 or more installed.  Install finished and rebooted to text mode.
I tried switching back to PCI video and got my error again.
Now what?
Is 8mb enough video memory to run the gui interface?  8 mb is as large as the bios will allow.
Now that I know it is the PCI video that is causing my problem, are there any boot options related to video that might help?  Video card is NViDIA GeForce 6200 with 256 mb memory.
Thanks in advance, Vince Radice
Comment 45 Vince Radice 2011-03-01 15:02:21 EST
I found the answer.
  agp=off
I was looking at the captured error and noticed that there were some references to agp things.  My video card is PCI.  Looking through the kernel parameters, I found agp=off and I tried it.  It worked like a charm.
That leads to the question -  does the kernel know what type of interface to the video is being used?  I can't believe that I am the only user of a pc with onboard video on the motherboard and a PCI video card.

Anyway, my problem is solved.  

Who can close this as solved?  Me?  An administrator?

Thank you Kyle and Chuck for your help.
Comment 46 Chuck Ebbert 2011-03-03 20:29:24 EST
Is there any way you can try the F15 Alpha LiveCD, which should be available in a few days? It looks like the AGP driver should not be loading at all if the video type is PCI, but it does seem to be loading... or at least it shouldn't be trashing the pagetables that map the IOAPIC when it does load like that.
Comment 47 Vince Radice 2011-04-29 10:58:33 EDT
Things finally slowed down enough.  I tried the FC15 Alpha and it work without needing agp=off.  I let it get to the part where the menu asked what I wanted to do.  I did not install it at this time.  Now I need to wait until FC15 is officially released and try to load it for real.

Thanks for all the help.
Vince

Note You need to log in before you can comment on or make changes to this bug.