Bug 611210 - Cannot attach console to RHEL 6 PV guest
Cannot attach console to RHEL 6 PV guest
Status: CLOSED DUPLICATE of bug 523623
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-04 05:34 EDT by Yufang Zhang
Modified: 2012-01-31 13:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 06:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config file used to create the RHEL PV guest (488 bytes, application/octet-stream)
2010-07-04 05:34 EDT, Yufang Zhang
no flags Details
xend.log (9.34 KB, text/plain)
2010-07-04 05:37 EDT, Yufang Zhang
no flags Details
config file used in comment #2 (489 bytes, text/plain)
2010-07-06 08:15 EDT, Yufang Zhang
no flags Details

  None (edit)
Description Yufang Zhang 2010-07-04 05:34:52 EDT
Created attachment 429341 [details]
config file used to create the RHEL PV guest

Description of problem:
After create a RHEL 6 PV guest, we cannot attach console to the guest.

Version-Release number of selected component (if applicable):
xen-libs-3.0.3-113.el5
xen-debuginfo-3.0.3-113.el5
kernel-xen-2.6.18-203.el5
xen-devel-3.0.3-113.el5
kernel-xen-devel-2.6.18-203.el5
xen-3.0.3-113.el5

RHEL 6 PV guest OS is RHEL 6 beta2.

How reproducible:
Always

Steps to Reproduce:
1. Create a PV RHEL 6 PV guest with '-c' option
2. 
3.
  
Actual results:
# xm cr /tmp/xm-test.conf -c
Using config file "/tmp/xm-test.conf".
Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst
Started domain vm1
PCI: Fatal: No config space access function found

No other output is printed on the screen.


Expected results:
We could get console of this PV guest.


Additional info:
1. xm console doesn't work for this PV guest either.
2. We could get console of this PV guest via virt-viewer or virt-manager if VFB device is enabled.
Comment 1 Yufang Zhang 2010-07-04 05:37:41 EDT
Created attachment 429343 [details]
xend.log
Comment 2 Yufang Zhang 2010-07-06 08:13:49 EDT
Retest this bug with a new clean image, bellow is the results:

# xm cr /tmp/xm-test.conf -c
Using config file "/tmp/xm-test.conf".
Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst
Started domain vm1
PCI: Fatal: No config space access function found

Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)
Kernel 2.6.32-37.el6.x86_64 on an x86_64

dhcp-66-70-159.nay.redhat.com login: root
Password: 
Last login: Tue Jul  6 20:15:47 on hvc0
[root@dhcp-66-70-159 ~]# uname -a
Linux dhcp-66-70-159.nay.redhat.com 2.6.32-37.el6.x86_64 #1 SMP Sun Jun 20 19:29:35 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@dhcp-66-70-159 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)
[root@dhcp-66-70-159 ~]# halt
Shutting down Avahi daemon: [  OK  ]
Stopping atd: [  OK  ]
Stopping abrt daemon: [  OK  ]
Stopping sshd: [  OK  ]
Shutting down postfix: [  OK  ]
Stopping crond: [  OK  ]
Stopping HAL daemon: [  OK  ]
Stopping NetworkManager daemon: [  OK  ]
Killing mdmonitor: [  OK  ]
Stopping system message bus: [  OK  ]
Shutting down interface eth0:  [  OK  ]
Shutting down loopback interface:  [  OK  ]
Stopping monitoring for VG vg_dhcp6670159:   2 logical volume(s) in volume group "vg_dhcp6670159" unmonitored
[  OK  ]
Sending all processes the TERM signal... [  OK  ]
Sending all processes the KILL signal... [  OK  ]
Saving random seed:  [  OK  ]
Syncing hardware clock to system time Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
[FAILED]
Turning off swap:  [  OK  ]
Turning off quotas:  [  OK  ]
Unmounting file systems:  [  OK  ]
init: Re-executing /sbin/init
Halting system...
System halted.


We could get console of RHEL6 PV guest as along as we disable VFB device of this guest. But only when we shutdown the guest, we can see kernel messages from the console. No kernel messages were printed on the console when booting the guest. So we could only get these information via dmesg from within the guest.
Comment 3 Yufang Zhang 2010-07-06 08:15:46 EDT
Created attachment 429758 [details]
config file used in comment #2
Comment 4 Yufang Zhang 2010-07-06 08:19:41 EDT
(In reply to comment #3)
> Created an attachment (id=429758) [details]
> config file used in comment #2    

Got the same results with or without the 'serial' option enabled using this config file.
Comment 5 Miroslav Rezanina 2010-07-07 02:35:36 EDT
Can you please provide me with grub config files for these pv guests. It looks like the console is working, but is not used by guest.
Comment 6 Yufang Zhang 2010-07-07 05:24:22 EDT
(In reply to comment #5)
> Can you please provide me with grub config files for these pv guests. It looks
> like the console is working, but is not used by guest.    

# cat /etc/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_dhcp6670159-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/xvda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux (2.6.32-37.el6.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.32-37.el6.x86_64 ro root=/dev/mapper/vg_dhcp6670159-lv_root rd_LVM_LV=vg_dhcp6670159/lv_root rd_LVM_LV=vg_dhcp6670159/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=auto rhgb quiet
	initrd /initramfs-2.6.32-37.el6.x86_64.img
Comment 7 Miroslav Rezanina 2010-07-07 07:28:46 EDT
Ok, I see no console redirection in config. If you append console=ttyS0 to kernel line, does console work?
Comment 8 Miroslav Rezanina 2010-07-08 02:46:58 EDT
In rhel6 console should be accessible as hvc0 device...so it should work with setting console=hvc0. Can you test it?
Comment 9 Yufang Zhang 2010-07-11 22:22:14 EDT
(In reply to comment #8)
> In rhel6 console should be accessible as hvc0 device...so it should work with
> setting console=hvc0. Can you test it?    

Testing with setting console=hvc0, console could work for RHEL 6 PV guest.
Comment 10 Miroslav Rezanina 2010-07-12 06:03:00 EDT
As discussed with Andrew Jones this is probably due to different anaconda behavior and is tracked by BZ #523623. Closing this one as duplicate.

*** This bug has been marked as a duplicate of bug 523623 ***

Note You need to log in before you can comment on or make changes to this bug.