Bug 61132 - hampton b2: qlogic drivers only detect one volume
hampton b2: qlogic drivers only detect one volume
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 18:46 EST by Wendy Hung
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 14:54:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/scsi/scsi from machine with qla2300 and attached storage (host scsi2) (493 bytes, text/plain)
2002-03-22 16:29 EST, Don Smith
no flags Details

  None (edit)
Description Wendy Hung 2002-03-13 18:46:44 EST
The qla2200 and qla2300 drivers included in the Hampton Beta2 are only 
detecting one volume when loaded, but the enclosures 
we are using are set up with multiple volumes (one has two volumes 
and the other has three).
Comment 1 Wendy Hung 2002-03-22 12:46:52 EST
Also seen in Pensacola Beta2.

Fix is to enable the "probe all LUNs on each SCSI device" option 
(CONFIG_SCSI_MULTI_LUN) and recompile the kernel. This option is not enabled by 
default in Red Hat (apparently it can cause problems in some cases).
However, this may be an issue for support since the user must
perform a kernel compilation.


Comment 2 Arjan van de Ven 2002-03-22 13:04:52 EST
I think you have been slightly misinformed. That option is ALSO a runtime
option. In addition the scsi layer has a whitelist of good devices where it
ALWAYS will scan all luns. If you can get me the output of "cat /proc/scsi/scsi"
on a machine with the "offending" device I can add the scsi device to this
whitelist.
Comment 3 Don Smith 2002-03-22 16:29:26 EST
Created attachment 49766 [details]
/proc/scsi/scsi from machine with qla2300 and attached storage (host scsi2)
Comment 4 Don Smith 2002-03-22 16:31:25 EST
How do you enable the runtime option for multiple LUNs?
Comment 5 Arjan van de Ven 2002-03-22 17:21:52 EST
Thanks for the ident; I've added it to my trees.
How to do it at runtime:
add

options scsi_mod max_scsi_luns=128

to the /etc/modules.conf file and then recreate the initrd (or remove and
install the kernel). see "man initrd" for info on how to recreate an initrd
simple.
Comment 6 Wendy Hung 2002-03-25 14:51:15 EST
Will this ident be included in the whitelist for Hampton Beta4?
Pensacola?  or will the runtime option have to be used?
Comment 7 Arjan van de Ven 2002-03-25 14:54:20 EST
It's in pensacola already and on my list of id's to add for hampton.
(there's a few more and I rather do them in one go; saves time ;)
Comment 8 Arjan van de Ven 2002-03-28 05:30:56 EST
Ok should be fixed.
Comment 9 Wendy Hung 2002-04-09 14:41:50 EDT
Not fixed in beta 4 - still had to add the scsi_mod options to see all LUNs.  
Will there be another beta drop available before the Gold Masters cut?
Comment 10 Arjan van de Ven 2002-04-09 14:47:35 EDT
Ah bah. typo.
Will be fixed in the 2.4.18-0.19 kernel which will be in rawhide tomorrow
Comment 11 Wendy Hung 2002-04-11 11:56:41 EDT
Can you confirm that the device is in the whitelist in Pensacola-re0328 (2.4.9-
26.53beta kernel)?  I've gotten reports that the user still must add the 
scsi_mod options to see all LUNs.
Comment 12 Arjan van de Ven 2002-04-11 11:59:05 EDT
pensacola is a whole different beast; will look into

Note You need to log in before you can comment on or make changes to this bug.