Bug 61143 - rpc.rstatd crashed - oops
rpc.rstatd crashed - oops
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rusers (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 04:59 EST by Christian Jacobsen
Modified: 2015-03-04 20:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-14 06:50:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Jacobsen 2002-03-14 04:59:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; Q312461; T312461)

Description of problem:
The rpc.rstatd demon crashes every 18 Hours. It is queried quite ofen by 
piranha with rup.
I first tried the rusers-server-0.17-14 from rawhide (now dissappeard), that 
did not help.
Then i installed  portmap-4.0-41 from rawhide - it did not help either.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Piranha queries with rup the rpc.rstatd on another server (Real Server)
2. After 18 Hours it crashed with an oops in /var/log/messages

	

Actual Results:  First crash with standard Portmap and standard rusers-server :

Mar 12 10:27:03 Test kernel: Unable to handle kernel NULL pointer dereference 
at virtual address 000002de
Mar 12 10:27:03 Test kernel:  printing eip:
Mar 12 10:27:03 Test kernel: c01cd466
Mar 12 10:27:03 Test kernel: *pde = 00000000
Mar 12 10:27:03 Test kernel: Oops: 0000
Mar 12 10:27:03 Test kernel: CPU:    0
Mar 12 10:27:03 Test kernel: EIP:    0010:[sprintf_stats+38/192]
Mar 12 10:27:03 Test kernel: EIP:    0010:[<c01cd466>]
Mar 12 10:27:03 Test kernel: EFLAGS: 00010202
Mar 12 10:27:03 Test kernel: eax: 00000286   ebx: df1e2c00   ecx: 00000000   
edx: 00000286
Mar 12 10:27:03 Test kernel: esi: d0ce4145   edi: 00000000   ebp: 00000000   
esp: de42df24
Mar 12 10:27:03 Test kernel: ds: 0018   es: 0018   ss: 0018
Mar 12 10:27:03 Test kernel: Process rpc.rstatd (pid: 720, stackpage=de42d000)
Mar 12 10:27:03 Test kernel: Stack: 00000145 df1e2c00 c01cd554 d0ce4145 
df1e2c00 00000000 00000c00 00001000
Mar 12 10:27:03 Test kernel:        d0ce4000 c015be24 d0ce4000 de42df68 
00000000 00000c00 c1b6e4e0 00000000
Mar 12 10:27:03 Test kernel:        00000000 00000000 d4efa720 ffffffea 
00000000 00001000 c013c5c6 d4efa720
Mar 12 10:27:03 Test kernel: Call Trace: [dev_get_info+84/160] 
[proc_file_read+148/400] [sys_read+150/208] [system_call+51/56]
Mar 12 10:27:03 Test kernel: Call Trace: [<c01cd554>] [<c015be24>] [<c013c5c6>] 
[<c010716b>]
Mar 12 10:27:03 Test kernel:
Mar 12 10:27:03 Test kernel: Code: 8b 42 58 50 8b 4a 44 8b 42 40 01 c8 8b 4a 50 
01 c8 8b 4a 4c


Second crash with rusers-server-0.17-14 :
Mar 12 11:18:23 Test rstatd: rpc.rstatd startup succeeded
Mar 13 04:02:01 Test syslogd 1.4.1: restart.
Mar 13 05:31:15 Test kernel:  <1>Unable to handle kernel NULL pointer 
dereference at virtual address 000002de
Mar 13 05:31:15 Test kernel:  printing eip:
Mar 13 05:31:15 Test kernel: c01cd466
Mar 13 05:31:15 Test kernel: *pde = 00000000
Mar 13 05:31:15 Test kernel: Oops: 0000
Mar 13 05:31:15 Test kernel: CPU:    1
Mar 13 05:31:15 Test kernel: EIP:    0010:[sprintf_stats+38/192]
Mar 13 05:31:15 Test kernel: EIP:    0010:[<c01cd466>]
Mar 13 05:31:15 Test kernel: EFLAGS: 00010202
Mar 13 05:31:15 Test kernel: eax: 00000286   ebx: df1e2c00   ecx: 00000000   
edx: 00000286
Mar 13 05:31:15 Test kernel: esi: cf048145   edi: 00000000   ebp: 00000000   
esp: d00a5f24
Mar 13 05:31:15 Test kernel: ds: 0018   es: 0018   ss: 0018
Mar 13 05:31:15 Test kernel: Process rpc.rstatd (pid: 19204, stackpage=d00a5000)
Mar 13 05:31:15 Test kernel: Stack: 00000145 df1e2c00 c01cd554 cf048145 
df1e2c00 00000000 00000c00 00001000
Mar 13 05:31:15 Test kernel:        cf048000 c015be24 cf048000 d00a5f68 
00000000 00000c00 c1b6e4e0 00000000
Mar 13 05:31:15 Test kernel:        00000000 00000000 ded95200 ffffffea 
00000000 00001000 c013c5c6 ded95200
Mar 13 05:31:15 Test kernel: Call Trace: [dev_get_info+84/160] 
[proc_file_read+148/400] [sys_read+150/208] [system_call+51/56]
Mar 13 05:31:15 Test kernel: Call Trace: [<c01cd554>] [<c015be24>] [<c013c5c6>] 
[<c010716b>]
Mar 13 05:31:15 Test kernel:
Mar 13 05:31:15 Test kernel: Code: 8b 42 58 50 8b 4a 44 8b 42 40 01 c8 8b 4a 50 
01 c8 8b 4a 4c


Third crash with portmap 4.0-41 and rusers-server-0.17-14 :
Mar 13 09:19:42 Test rstatd: rpc.rstatd startup succeeded
Mar 14 03:23:32 Test kernel:  <1>Unable to handle kernel NULL pointer 
dereference at virtual address 000002de
Mar 14 03:23:32 Test kernel:  printing eip:
Mar 14 03:23:32 Test kernel: c01cd466
Mar 14 03:23:32 Test kernel: *pde = 00000000
Mar 14 03:23:32 Test kernel: Oops: 0000
Mar 14 03:23:32 Test kernel: CPU:    1
Mar 14 03:23:32 Test kernel: EIP:    0010:[sprintf_stats+38/192]
Mar 14 03:23:32 Test kernel: EIP:    0010:[<c01cd466>]
Mar 14 03:23:32 Test kernel: EFLAGS: 00010202
Mar 14 03:23:32 Test kernel: eax: 00000286   ebx: df1e2c00   ecx: 00000000   
edx: 00000286
Mar 14 03:23:32 Test kernel: esi: db266000   edi: 00000145   ebp: 000001c2   
esp: dcf59f24
Mar 14 03:23:32 Test kernel: ds: 0018   es: 0018   ss: 0018
Mar 14 03:23:32 Test kernel: Process rpc.rstatd (pid: 28581, stackpage=dcf59000)
Mar 14 03:23:32 Test kernel: Stack: 00000000 df1e2c00 c01cd554 db266000 
df1e2c00 000001c2 00000c00 00001000
Mar 14 03:23:32 Test kernel:        db266000 c015be24 db266000 dcf59f68 
000001c2 00000c00 c1b6e4e0 00000000
Mar 14 03:23:32 Test kernel:        00000000 00000000 dc983f60 ffffffea 
00000000 00001000 c013c5c6 dc983f60
Mar 14 03:23:32 Test kernel: Call Trace: [dev_get_info+84/160] 
[proc_file_read+148/400] [sys_read+150/208] [system_call+51/56]
Mar 14 03:23:32 Test kernel: Call Trace: [<c01cd554>] [<c015be24>] [<c013c5c6>] 
[<c010716b>]
Mar 14 03:23:32 Test kernel:
Mar 14 03:23:32 Test kernel: Code: 8b 42 58 50 8b 4a 44 8b 42 40 01 c8 8b 4a 50 
01 c8 8b 4a 4c


Expected Results:

Additional info:


I first tried the rusers-server-0.17-14 from rawhide (now dissappeard from 
there), that did not help.
Then i installed  portmap-4.0-41 from rawhide - it did not help either.
Comment 1 Phil Knirsch 2002-03-14 06:07:32 EST
Which kernel/glibc? As i am seeing a null pointer dereference in the kernel as
well (a real kernel oops), which might mean it could be a kernel problem as well.

Read ya, Phil
Comment 2 Christian Jacobsen 2002-03-14 06:46:04 EST
Hallo Phil,

thank you for the fast reaktion :)

# rpm -qa |grep kernel
kernel-smp-2.4.7-10
kernel-2.4.7-10
kernel-headers-2.4.7-10
kernel-source-2.4.7-10

# rpm -qa |grep glibc
glibc-2.2.4-19.3
compat-glibc-6.2-2.1.3.2
glibc-common-2.2.4-19.3
glibc-devel-2.2.4-19.3

Greetings Christian
Comment 3 Phil Knirsch 2002-03-14 06:50:53 EST
I'd advise to update to the latest errata kernel (2.4.9-31). glibc looks ok and
seems to be the latest one.

If that doesn't help i'm going to have a hard time reproducing this bug (if it
takes 18 hours... :).

Read ya, Phil
Comment 4 Christian Jacobsen 2002-04-02 10:07:35 EST
The Kernel Update did solve the Problem.
Thanks :)

Christian Jacobsen

Note You need to log in before you can comment on or make changes to this bug.