Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 611475 - SELinux is preventing /bin/bash "getattr" access on /usr/bin/cvs.
SELinux is preventing /bin/bash "getattr" access on /usr/bin/cvs.
Status: CLOSED DUPLICATE of bug 611474
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:28bc9416de4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 08:06 EDT by mathepic
Modified: 2010-07-07 04:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 04:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mathepic 2010-07-05 08:06:01 EDT
Summary:

SELinux is preventing /bin/bash "getattr" access on /usr/bin/cvs.

Detailed Description:

SELinux denied access requested by gdm. It is not expected that this access is
required by gdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cvs_exec_t:s0
Target Objects                /usr/bin/cvs [ file ]
Source                        gdm
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.1.7-1.fc13
Target RPM Packages           cvs-1.11.23-8.fc13
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11
                              09:38:12 UTC 2010 x86_64 x86_64
Alert Count                   3
First Seen                    Sun 04 Jul 2010 10:00:51 PM EDT
Last Seen                     Mon 05 Jul 2010 07:52:54 AM EDT
Local ID                      4df1b4d1-d6c1-49fa-89d2-269a82f3e0bf
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278330774.172:15): avc:  denied  { getattr } for  pid=1377 comm="gdm" path="/usr/bin/cvs" dev=sda3 ino=23571 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cvs_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278330774.172:15): arch=c000003e syscall=4 success=no exit=-13 a0=1aab7c0 a1=7fff447b6010 a2=7fff447b6010 a3=d items=0 ppid=1 pid=1377 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gdm" exe="/bin/bash" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm,xdm_t,cvs_exec_t,file,getattr
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t cvs_exec_t:file getattr;
Comment 1 Miroslav Grepl 2010-07-07 04:08:07 EDT

*** This bug has been marked as a duplicate of bug 611474 ***

Note You need to log in before you can comment on or make changes to this bug.