Bug 611585 - Working Wireless Fails When Managed by NM
Working Wireless Fails When Managed by NM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 611905 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 15:20 EDT by fedoradch
Modified: 2010-07-09 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 12:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested Information (78.23 KB, application/octet-stream)
2010-07-08 11:42 EDT, fedoradch
no flags Details

  None (edit)
Description fedoradch 2010-07-05 15:20:04 EDT
This device works perfectly when not managed by NM. I entered the same information into the NM connection manager and checked "managed by NetworkManager in the standard network configuration application.

Wireless mod = wl (Broadcom)

Error message:

Bringing up interface eth1:  
** (process:3083): WARNING **: replace_settings: error updating user connection /org/freedesktop/NetworkManagerSettings/1 settings: (1) mac-address
Error: Connection activation failed: Device not managed by NetworkManager
                                                           [FAILED]
"Enable Wireless" is grayed out in tray applet.

iwlist scanning works. I have tried DHCP and fixed IP with the similar results. DHCP fails with a Set error.

DEVICE=eth1
BOOTPROTO=none
TYPE=Wireless
NM_CONTROLLED=yes
ONBOOT=yes
USERCTL=yes
IPV6INIT=no
ESSID="linksys_SES_27284"
MODE=Managed
RATE=auto
DNS1=4.2.2.2
DNS2=4.2.2.1
IPADDR=192.168.0.2
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
HWADDR=00:23:4D:CB:81:12
DEFAULTKEY=1
PREFIX=24
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
NAME="System linksys_SES_27284 (eth1)"
UUID=9c92fad9-6ecb-3e6c-eb4d-8a47c6f50c04
Comment 1 fedoradch 2010-07-07 10:42:35 EDT
*** Bug 611905 has been marked as a duplicate of this bug. ***
Comment 2 Jirka Klimes 2010-07-08 04:04:23 EDT
Could you provide the following info?

1) output of 'nm-tool'
2) /var/log/messages log
3) rpm -qv NetworkManager
   rpm -qv NetworkManager-gnome
4) output of
dbus-send  --system --print-reply --dest='org.freedesktop.NetworkManagerUserSettings' '/org/freedesktop/NetworkManagerSettings/1' org.freedesktop.NetworkManagerSettings.Connection.GetSettings
5) How do you try to activate your connection?
Comment 3 fedoradch 2010-07-08 11:42:50 EDT
Created attachment 430403 [details]
Requested Information
Comment 4 fedoradch 2010-07-08 11:44:38 EDT
Requested information in attachment.

"5) How do you try to activate your connection?"

Unplugging eth0 cable worked in the past. Did I misunderstand the q?
Comment 5 Jirka Klimes 2010-07-09 05:58:23 EDT
(In reply to comment #3)
Jul  8 10:49:41 dch NetworkManager[1383]: <info> found WiFi radio killswitch rfkill0 (at /sys/devices/platform/dell-laptop/rfkill/rfkill0) (driver dell-laptop)
Jul  8 10:49:41 dch NetworkManager[1383]: <info> WiFi disabled by radio killswitch; disabled by state file

WiFi is disabled by killswitch. Please check, that you didn't switch it off.
What killswitch type do you have? (what Dell notebook model is that).

Check killswitch state with:
$ rfkill list

Most probably, it's an issue with platform driver for the killswitch.
Try remove the driver:
# rmmod dell_laptop

Some references:
http://linuxtrap.wordpress.com/2009/11/25/hard-blocked-wireless-kill-switch-on-dell-laptop/
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/523143



** (process:8559): WARNING **: <WARN>  get_one_connection(): error: invalid connection: 'NMSettingWireless' / 'mac-address' invalid: 1

Second issue (not causing the problem) is that in your user connection, the MAC address is not valid. I don't know how that could have become malformed. Did you edit it manually in gconf files?
Anyway, you should be able to correct the address via nm-connection-editor in "Wireless" tab.

(In reply to comment #4)
> Requested information in attachment.
> 
> "5) How do you try to activate your connection?"
> 
> Unplugging eth0 cable worked in the past. Did I misunderstand the q?    
Never mind. Just wanted to know whether you activate the wireless connection by clicking an entry in nm-applet or some other way.
But now it is clear that the problem is related to the killswitch.
Comment 6 fedoradch 2010-07-09 12:09:48 EDT
I blacklisted dell_laptop and everything works perfectly. Why this worked as a stand-alone and not with NM will remain one of life's mysteries along with where those odd socks disappear to.

THANKS FOR YOUR HELP!

Note You need to log in before you can comment on or make changes to this bug.