Bug 61161 - evolution.desktop is broken for most languages
evolution.desktop is broken for most languages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 61800 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 11:52 EST by Leonid Kanter
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-24 14:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2002-03-14 11:52:08 EST
Description of Problem:

Script thet build .desktop from po-files (xml-i18n-merge) is broken because it
doesn't ignore "fuzzy" pairs. As a result, most Name[LANG] lines in .desktop
file are broken. Just a few lines from evolution.desktop:

Name=Ximian Evolution
Name[da]=Ximian Evolution _OSS
Name[en_AU]=Can not initialise the Ximian Evolution shell
Name[en_GB]=Cannot initialise the Evolution shell.
Name[lt]=Ximian Evolution _FAQ
Name[pt_BR]=_FAQ do Ximian Evolution

The same for Russian, Ukrainian, Slovak and other maybe other languages.

How it looks in .po file:
#: data/evolution.desktop.in.h:2
#, fuzzy
msgid "Ximian Evolution"
msgstr "_FAQ do Ximian Evolution"

So, evolution.desktop file is broken for most languages.
Comment 1 Leonid Kanter 2002-03-14 11:55:00 EST
This problem can also affect all other gnome programs that use xml-i18n-merge
Comment 2 Jeremy Katz 2002-03-14 12:02:02 EST
Cc'ing Havoc...  this might be fixed by moving to a newer intltool; I'll try to
do a build on my workstation this afternoon to see if that fixes it
Comment 3 Leonid Kanter 2002-03-14 12:34:46 EST
Russian translation that came with evolution-1.0.2 is broken and incomplete. I
have much better translation and I can commit it to cvs at sources.redhat.com if
evolution directory appear there.
Comment 4 Jeremy Katz 2002-03-14 12:41:51 EST
It'd really be a lot better if it were committed upstream rather than having a
translation fork in Red Hat Linux.  I have no problem pulling diffs from the
evolution-1-0-branch for updated translations if the branch translations are
better (note that we'll probably be shipping evolution 1.0.3 anyway, so I'd hold
off on doing any updated pulls for translations until after that's released, but
if the better translations were already in evolution 1.0.3, everyone would be
better off)
Comment 5 Leonid Kanter 2002-03-14 12:55:08 EST
Yes, updated translation was committed and it's available from
anoncvs.gnome.org, but it may be for 1.1 branch. I'm not shure that it will
appear in 1.0.3.
Comment 6 Jeremy Katz 2002-03-14 15:14:19 EST
Since the strings on evolution HEAD and the 1.0 branch are somewhat divergent,
it's really a lot better if the translations are actually updated on the branch
(evolution-1-0-branch in this case) also;  it completely loses the effort for
the upstream releases as well without it being on the branch.  If after 1.0.3 is
released, I have to, I can try to find the time to munge the updated po file in
and cross my fingers to hope things work.
Comment 7 Leonid Kanter 2002-03-15 06:53:27 EST
Can you please tell me how to checkout ru.po from evolution-1-0-branch?
Comment 8 Peter Bowen 2002-03-15 07:51:10 EST
To checkout just the po files for evolution 1.0.x from gnomecvs use:

cvs -z3 checkout -P -r evolution-1-0-branch evolution/po
Comment 9 Jeremy Katz 2002-03-24 14:48:26 EST
Current 1.0.3 pre-release tarballs are being built with intltool 0.17 which
fixes the problem with the desktop file.  I'll continue to double-check up until
the final release of 1.0.3, though
Comment 10 Jeremy Katz 2002-03-24 14:54:16 EST
*** Bug 61800 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2002-03-25 17:16:24 EST
Fixed in 1.0.3-1 which should show up in rawhide tomorrow

Note You need to log in before you can comment on or make changes to this bug.