Bug 61164 - new openssh can not connect by SSH1 protocol on RH 6.2
new openssh can not connect by SSH1 protocol on RH 6.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
: 61476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 12:07 EST by Andy Shevchenko
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 07:25:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2002-03-14 12:07:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020207

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. recompile openssh-3.1 under openssl-0.9.5a (or 0.9.6b) under RH linux version 6.2
(compiler egcs-1.1.2-30)

Something was changed in spec-file:
# Do we want to disable building of x11-askpass? (1=yes 0=no)
%define no_x11_askpass 1

# Do we want to disable building of gnome-askpass? (1=yes 0=no)
%define no_gnome_askpass 1

# Is this build for RHL 6.x?
%define build6x 1


2. ssh -C -v this.host.from.remote.host 

(the options -C and -v not affected for reproduction of the bug)



Actual Results:  see the following error:

debug1: Remote protocol version 1.5, remote software version OpenSSH_3.1p1
debug1: match: OpenSSH_3.1p1 pat OpenSSH*
debug1: Local version string SSH-1.5-OpenSSH_3.1p1
debug1: Waiting for server public key.
debug1: Received server public key (768 bits) and host key (1024 bits).
debug1: Host 'serv.smile.org.ua' is known and matches the RSA1 host key.
debug1: Found key in /home/andy/.ssh/known_hosts:12
debug1: Encryption type: 3des
debug1: Sent encrypted session key.
debug1: cipher_init: set keylen (16 -> 32)
debug1: cipher_init: set keylen (16 -> 32)
debug1: Installing crc compensation attack detector.
Disconnecting: Corrupted check bytes on input.
debug1: Calling cleanup 0x8063550(0x0)


Expected Results:  Would be the password promt instead of error.

Additional info:
Comment 1 Alec Voropay 2002-03-15 03:03:00 EST
See bug 60924 and comments.
Comment 2 Matthew Galgoci 2002-03-18 09:21:22 EST
The same happens on 7.2 machines with current official errata. Note though
that you need to ssh from one machine to another forcing protocol 1 to reproduce
this bug; ssh -v -1 localhost works fine.
Comment 3 Matthew Galgoci 2002-03-18 09:39:16 EST
nevermind, I'm on crack. Please refer to bug #60924
Comment 4 Tomas Mraz 2005-02-03 07:25:48 EST
This is not supported.
Comment 5 Tomas Mraz 2005-02-04 10:54:17 EST
*** Bug 61476 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.