Bug 611642 - gnome-keyring isn't staying unlocked
Summary: gnome-keyring isn't staying unlocked
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-06 02:12 UTC by Dave Jones
Modified: 2015-03-03 22:50 UTC (History)
7 users (show)

Fixed In Version: gnome-keyring-2.31.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 16:45:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream commit 629fecbd61c8585a2bc95e2fcb059de260c34fb8 (2.43 KB, patch)
2010-07-12 07:47 UTC, Yanko Kaneti
no flags Details | Diff

Description Dave Jones 2010-07-06 02:12:53 UTC
usually, I get asked my keyring password once, the first time I use ssh, and then it remains unlocked for the session. subsequent invocations of ssh don't pop up the keyring dialog.

In rawhide right now, every time I invoke ssh, I get the keyring dialog pop up asking me to reenter the password.  It makes using cvs from a remote machine really annoying.

Comment 1 Adam Williamson 2010-07-10 17:19:56 UTC
It's not working for me either in current Rawhide, in GNOME or XFCE.

In GNOME it behaves as Dave describes, IIRC. In XFCE, even though there's a /usr/bin/gnome-keyring-daemon --daemonize --login process running, I never see anything that looks like a g-k dialog; when I try to ssh anywhere I just get the "Enter passphrase for key" prompt at the console.

Comment 2 Yanko Kaneti 2010-07-12 07:47:30 UTC
Created attachment 431100 [details]
upstream commit 629fecbd61c8585a2bc95e2fcb059de260c34fb8

Patch from upstream. Fixed it for me.

Comment 3 Adam Williamson 2010-07-13 23:55:27 UTC
That patch also fixes for me (in GNOME, haven't tested Xfce).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Tomáš Bžatek 2010-07-20 16:45:33 UTC
Packaged in gnome-keyring-2.31.4-2.fc14. Thanks for testing!


Note You need to log in before you can comment on or make changes to this bug.