Bug 611677 - VMWare Workstation 7.x keyboard problem when using tigervnc-server >= 1.0.1
VMWare Workstation 7.x keyboard problem when using tigervnc-server >= 1.0.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 02:24 EDT by shr
Modified: 2013-04-30 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: tigervnc-1.0.90-0.13.20100420svn4030.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 16:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error output for debug tigervnc-server RPM (15.98 KB, application/octet-stream)
2010-08-13 12:59 EDT, rwhalb
no flags Details
Error log for debug tigervnc-server RPM (VMware Workstation 7.1.1) (19.42 KB, text/plain)
2010-08-16 04:46 EDT, shr
no flags Details
Log File for tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.2.x86_64.rpm (13.88 KB, application/octet-stream)
2010-08-19 08:29 EDT, rwhalb
no flags Details

  None (edit)
Description shr 2010-07-06 02:24:36 EDT
Description of problem:
VMWare Workstation 7.x keyboard problem when using tigervnc-server >= 1.0.1.
We can't send any key to Guest OS.

Version-Release number of selected component (if applicable):
all tigervnc-server >= 1.0.1 will not work
tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.x86_64
tigervnc-server-1.0.90-0.11.20100420svn4030.fc13.x86_64
tigervnc-server-1.0.90-0.8.20100219svn3993.fc13.x86_64
tigervnc-server-1.0.1-1.fc12.x86_64
...

all tigervnc-server <= 1.0.0 will work
tigervnc-server-1.0.0-1.fc12.x86_64
tigervnc-server-1.0.0-2.fc11.x86_64
tigervnc-server-0.0.90-0.10.fc11.x86_64
...

How reproducible:
Upgrade tigervnc-server to >= 1.0.1

Steps to Reproduce:
1.Upgrade tigervnc-server to >= 1.0.1
2.Connect to Fedora via vnc client.(tigervnc client On Win32)
3.Start any VMWare Guest OS via vnc, Press any key in Guest OS.
  
Actual results:
Not work, we also can't press Ctrl+Alt to escape VMWare.

Expected results:
Any key we press would be accepted in Guest OS

Additional info:
Every time we press any key in VMWare guest OS, the following message will append to vnc.log (~/.vnc/hostname:1.log)
Tue Jul  6 09:13:54 2010
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed


Workaround:
Install tigervnc-server <= 1.0.0 in Fedora13, or don't update tigervnc-server in Fedora12 (for example, use tigervnc-server-1.0.0-1.fc12.x86_64)
Comment 1 rwhalb 2010-07-09 14:35:40 EDT
I also have this issue. Another work around is to use the Gnome Vino Server. I have also downgraded to version: tigervnc-server-1.0.0-1.fc12.x86_64 and seems to work on F12.
Comment 2 Adam Tkac 2010-07-14 03:47:15 EDT
I'm not able to reproduce this issue. Would it be possible to attach full .vnc/hostname:1.log, please? Thank you in advance.
Comment 3 rwhalb 2010-07-14 08:23:57 EDT
Adam:

Xvnc:
=====

/usr/bin/Xvnc :6 -geometry 1280x1024 -depth 24 -dpi 96 -httpd /usr/share/vnc/classes -auth /root/.Xauthority -rfbauth /root/.vnc/passwd -log *:stderr:30 -ClientWaitTimeMillis 20000 -IdleTimeout 0 -rfbport 5906 -desktop=root@vortex


Since my "/root/.vnc/vortex:6.log" file is short I will just paste it in:

----------------------------------------------------------
Xvnc TigerVNC 1.0.90 - built Jun 24 2010 10:00:40
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 Constantin Kaplinsky
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 10800000, The X.Org Foundation


Thu Jul  8 20:52:40 2010
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5906
 vncext:      Listening for HTTP connections on all interface(s), port 5806
 vncext:      created VNC server for screen 0

Thu Jul  8 20:53:03 2010
 Connections: accepted: 10.222.222.18::61504
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
 SConnection: AuthFailureException: Authentication failure
 Connections: closed: 10.222.222.18::61504 (Authentication failure)

Thu Jul  8 20:53:12 2010
 Connections: accepted: 10.222.222.18::61505
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888

Thu Jul  8 20:53:56 2010
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed

Thu Jul  8 20:54:24 2010
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed

Thu Jul  8 23:03:06 2010
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed
 Input:       generate_modkeymap failed

Thu Jul  8 23:03:07 2010
 Input:       generate_modkeymap failed

Fri Jul  9 11:59:03 2010
 Input:       generate_modkeymap failed

Fri Jul  9 11:59:04 2010
 Input:       generate_modkeymap failed
Comment 4 Adam Tkac 2010-07-14 10:06:15 EDT
Thanks for your logs. However I'm still not able to reproduce this issue even when I start Xvnc with same parameters.

Would it be possible tell me how exactly do you start your desktop in the virtual machine? Do you start Xvnc via /usr/bin/vncserver command? If yes, please attach your .vnc/xstartup. Also please tell me which window manager do you use. Thank you in advance.
Comment 5 rwhalb 2010-07-14 10:38:51 EDT
This error only occurs with the VMWare WorkStation application. If I run another X-application (e.g., firefox) within the VNC session, keyboard input/output behaves normally and no "generate_modkeymap failed" messages occur.

I can also control the VMware workstation manager and setting with no keyboard input/output issues. This problem only occurs with typing within a guest virtual machine (examples terminal, login dialog, etc...).

This xstartup is run to start the GNOME desktop. This for the vnc session. The VMware WorkStation is run within this VNC session. No Xvnc sessions are run within the virtual machines themselves.

So I believe there is an interaction between the tigervnc server v1.0.1 and VM WorkStation 7 Guest VMs. Remember if I revert back to tigervnc server 1.0.0 keyboard I/O behaves normally which is the current workaround.

xstartup:
=========
#!/bin/bash
# Copyright (C) 1999 - 2004 Red Hat, Inc. All rights reserved. This
# copyrighted material is made available to anyone wishing to use, modify,
# copy, or redistribute it subject to the terms and conditions of the
# GNU General Public License version 2.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.

#
# Redirect errors to a file in user's home directory if we can...
if [ -z "$GDMSESSION" ]; then
  #
  # Non-GDM redirect output:
  errfile="$HOME/.xsession-errors${DISPLAY}.log";
  if /bin/cp /dev/null "$errfile" 2> /dev/null ; then
    /bin/chmod 600 "$errfile";
    exec > "$errfile" 2>&1;
  else
    errfile=$(/bin/mktemp -q /tmp/xses-$USER.XXXXXX;)
    if [ $? -eq 0 ]; then
      exec > "$errfile" 2>&1;
    fi
  fi
fi

#
# NST Default X start init script (attempts to launch the
# X Window Desktop Manager below from ssh-agent parent process)
SSH_LAUNCH="";
if [ \( -z "${SSH_AGENT_PID}" \) -a      \( -x "/usr/bin/ssh-agent" \) ]; then
  SSH_LAUNCH="/usr/bin/ssh-agent";
fi

#
# Source in Startup X Window Applications:
if [ -f "${HOME}/.vnc/xstartupapps" ]; then
 source "${HOME}/.vnc/xstartupapps";
fi

#
# Startup the currently configured X Window Desktop Manager:
exec gnome-session;
Comment 6 Adam Tkac 2010-07-14 11:08:17 EDT
(In reply to comment #5)

Thanks for your information, I will try to reproduce this issue with the VM Workstation.

> So I believe there is an interaction between the tigervnc server v1.0.1 and VM
> WorkStation 7 Guest VMs. Remember if I revert back to tigervnc server 1.0.0
> keyboard I/O behaves normally which is the current workaround.

Although this is usually useful information, there is a huge difference between 1.0.0 and 1.0.1 server in keyboard handling in Fedora because those servers are built against different major versions of X.Org.
Comment 7 shr 2010-07-14 23:54:48 EDT
Thanks rwhalb for log and xstartup.

The issue i have encountered is the same as rwhalb. Only in VMware Guest OS.

The following is .vnc/xstartup.
$cat ~/.vnc/xstartup

#!/bin/sh

#vncconfig -iconic &
# Uncomment the following two lines for normal desktop:
 unset SESSION_MANAGER
 exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &


I start Xvnc via "service vncserver start"(Automatic when boot).

The following is /etc/sysconfig/vncservers ( +extension XKEYBOARD doesn't matter, I have tried with/without this option)

#/etc/sysconfig/vncservers
 VNCSERVERS="1:shr"
 VNCSERVERARGS[1]="-geometry 1200x900 -localhost -nolisten tcp +extension XKEYBOARD"
Comment 8 Adam Tkac 2010-08-13 10:28:24 EDT
I would like to ask you to reproduce the problem with rpm on http://atkac.fedorapeople.org/tigervnc/tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.1.x86_64.rpm, please. Although this rpm won't solve this issue, it will write more details which will help in further debugging. Make sure you pass "-log *:stderr:100" parameter to Xvnc and attach vncserver log here, please. Thank you in advance.
Comment 9 rwhalb 2010-08-13 12:59:56 EDT
Created attachment 438725 [details]
Error output for debug tigervnc-server RPM
Comment 10 rwhalb 2010-08-13 13:02:28 EDT
I have attached an Xvnc log file above using RPM:

tigervnc-server-.0.90-0.12.20100420svn4030.fc13.1.x86_64.rpm

- Most of the error info is at the bottom.

I ran Xvnc using the following:

/usr/bin/Xvnc :6 -geometry 1280x1024 -depth 24 -dpi 96 -httpd /usr/share/vnc/classes -auth /root/.Xauthority -rfbauth /root/.vnc/passwd -log *:stderr:100 -log *:stderr:100 -ClientWaitTimeMillis 20000 -IdleTimeout 0 -rfbport 5906 -desktop=root@vortex

---RWH
Comment 11 shr 2010-08-16 04:46:29 EDT
Created attachment 438910 [details]
Error log for debug tigervnc-server RPM (VMware Workstation 7.1.1)
Comment 12 shr 2010-08-16 04:54:24 EDT
The log I attached is very similar to rwhalb's.

Every time I press any key in VMware Workstation, it will generate the error:

 Input:       generate_modkeymap failed, detail: 11
 Input:       generate_modkeymap failed, detail: 11

I use VMware Workstation 7.1.1.
Comment 13 Adam Tkac 2010-08-18 10:22:43 EDT
This is odd, "detail 11" indicates generate_modkeymap should have failed due lack of memory. This doesn't sound believably for me.

May I ask you test another debug tigervnc-server from https://kojiweb.fedoraproject.org/koji/taskinfo?taskID=2409072, please? (download it from bottom of the page) This build should give me enough information to figure what exactly VMware Workstation does. Then attach log file as before, please.
Comment 14 rwhalb 2010-08-18 19:34:31 EDT
Adam:

Your link:

https://kojiweb.fedoraproject.org/koji/taskinfo?taskID=2409072

appears broken????

---Ron Henderson
Comment 15 Adam Tkac 2010-08-19 04:58:15 EDT
(In reply to comment #14)
> Adam:
> 
> Your link:
> 
> https://kojiweb.fedoraproject.org/koji/taskinfo?taskID=2409072
> 
> appears broken????

Hm, the link works fine for me. However I put tigervnc-server also on http://atkac.fedorapeople.org/tigervnc/tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.2.x86_64.rpm so you can try this link.
Comment 16 rwhalb 2010-08-19 08:29:08 EDT
Created attachment 439665 [details]
Log File for tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.2.x86_64.rpm
Comment 17 rwhalb 2010-08-19 08:31:04 EDT
I have attached another Xvnc log file above using RPM:

tigervnc-server-.0.90-0.12.20100420svn4030.fc13.2.x86_64.rpm

- Most of the error info is at the bottom.

I ran Xvnc using the following:

/usr/bin/Xvnc :6 -geometry 1280x1024 -depth 24 -dpi 96 -httpd
/usr/share/vnc/classes -auth /root/.Xauthority -rfbauth /root/.vnc/passwd -log
*:stderr:100 -log *:stderr:100 -ClientWaitTimeMillis 20000 -IdleTimeout 0
-rfbport 5906 -desktop=root@vortex

---RWH
Comment 18 Hubert Bahr 2010-08-23 21:08:37 EDT
I ran into a similar problem.  It started out in Vino not transferring "(" or ")" the parentheses keys.  So I to tried tigervnc-server-1.0.90- 0.12.20100420svn4030.fc13.x86_64  This was worse as no keys were seen anywhere on the desktop or in the VMware window and once I clicked the mouse in the window it wouldn't release since keyboard presses were not recognized.  I backed off to  tigervnc-server-1.0.0-1.fc12.x86_64.rpm and all is well.  If you want additional info let me know.

Hubert
Comment 19 Adam Tkac 2010-08-24 12:04:22 EDT
May I ask you to retest this issue with http://atkac.fedorapeople.org/tigervnc/tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.4.x86_64.rpm, please? This package should finally solve this issue, I hope. In case it is still broken please attach log as before. Thank you in advance.
Comment 20 rwhalb 2010-08-24 21:22:24 EDT
Adam:

Greate job! Just tried RPM:

tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.4.x86_64.rpm

Now works as expected: running VMware Workstation 7.1 under tiger-vnc and typing within Linux VM guest in a terminal window. Hopefully others will concur with my results so that this fix can be released in the F13 update repo...

Thanks for your support...

Ron Henderson
Comment 21 shr 2010-08-25 02:59:40 EDT
Thanks Adam~~

I have tried tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.4.x86_64.rpm
 and It works fine to me.

shr
Comment 22 Fedora Update System 2010-08-25 11:06:00 EDT
tigervnc-1.0.90-0.13.20100420svn4030.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.13.20100420svn4030.fc13
Comment 23 Fedora Update System 2010-08-25 21:00:05 EDT
tigervnc-1.0.90-0.13.20100420svn4030.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.13.20100420svn4030.fc13
Comment 24 Hubert Bahr 2010-08-27 13:45:44 EDT
tigervnc-1.0.90-0.13.20100420svn4030.fc13 solved this issue for me on Fedora 13 and RHEL 6.0 Beta Release 2
Thanks
Hubert
Comment 25 Fedora Update System 2010-09-02 16:37:25 EDT
tigervnc-1.0.90-0.13.20100420svn4030.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.