Bug 611816 - WARNING: at net/mac80211/util.c:536 ieee80211_can_queue_work+0x35/0x50 [mac80211]() (Not tainted)
WARNING: at net/mac80211/util.c:536 ieee80211_can_queue_work+0x35/0x50 [mac80...
Status: CLOSED DUPLICATE of bug 614275
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: John W. Linville
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 10:57 EDT by Scott Dodson
Modified: 2010-07-16 10:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 10:47:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2010-07-06 10:57:42 EDT
Description of problem:
When resuming my suspended system I got the following traceback

Jul  6 07:55:01 dhcp242-213 kernel: PM: Syncing filesystems ... done.
Jul  6 07:59:17 dhcp242-213 kernel: Freezing user space processes ... (elapsed 0.00 seconds) done.
Jul  6 07:59:17 dhcp242-213 kernel: Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
Jul  6 07:59:17 dhcp242-213 kernel: Suspending console(s) (use no_console_suspend to debug)
Jul  6 07:59:17 dhcp242-213 kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Jul  6 07:59:17 dhcp242-213 kernel: sd 0:0:0:0: [sda] Stopping disk
Jul  6 07:59:17 dhcp242-213 kernel: ------------[ cut here ]------------
Jul  6 07:59:17 dhcp242-213 kernel: WARNING: at net/mac80211/util.c:536 ieee80211_can_queue_work+0x35/0x50 [mac80211]() (Not tainted)
Jul  6 07:59:17 dhcp242-213 kernel: Hardware name: 2537CS3
Jul  6 07:59:17 dhcp242-213 kernel: queueing ieee80211 work while going to suspend
Jul  6 07:59:17 dhcp242-213 kernel: Modules linked in: fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat rfcomm sco bridge stp llc bnep l2cap autofs4 sunrpc cpufreq_ondemand acpi_cpufreq freq_table xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables 
be2iscsi bnx2i cnic uio cxgb3i cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr ipv6 iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi dm_mirror dm_region_hash dm_log vhost_net macvtap macvlan tun kvm_intel kvm uinput thinkpad_acpi hwmon wmi sg uvcvideo 
videodev v4l2_compat_ioctl32 btusb bluetooth i2c_i801 iTCO_wdt iTCO_vendor_support arc4 ecb iwlagn iwlcore mac80211 cfg80211 rfkill snd_hda_codec_intelhdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_
page_alloc e1000e ext4 mbcache jbd2 fpu aesni_intel cryptd aes_x86_64 aes_generic xts gf128mul dm_crypt sr_mod cdrom sd_mod crc_t10dif ahci sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t i
Jul  6 07:59:17 dhcp242-213 kernel: 915 drm_kms_helper drm i2c_algo_bit i2c_core video output dm_mod [last unloaded: microcode]
Jul  6 07:59:17 dhcp242-213 kernel: Pid: 0, comm: swapper Not tainted 2.6.32-42.el6.x86_64 #1
Jul  6 07:59:17 dhcp242-213 kernel: Call Trace:
Jul  6 07:59:17 dhcp242-213 kernel: <IRQ>  [<ffffffff8106a883>] warn_slowpath_common+0x83/0xc0
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff8106a921>] warn_slowpath_fmt+0x41/0x50
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff8101ae25>] ? native_sched_clock+0x15/0x70
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffffa02efed5>] ieee80211_can_queue_work+0x35/0x50 [mac80211]
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffffa02f0ef1>] ieee80211_queue_work+0x21/0x40 [mac80211]
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffffa02e15c7>] ieee80211_sta_timer+0x37/0x40 [mac80211]
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff8107ce47>] run_timer_softirq+0x197/0x340
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff810a0580>] ? tick_sched_timer+0x0/0xc0
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff8102f49d>] ? lapic_next_event+0x1d/0x30
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff81072c17>] __do_softirq+0xb7/0x1e0
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff81094b00>] ? hrtimer_interrupt+0x140/0x250
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff810142cc>] call_softirq+0x1c/0x30
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff81015f15>] do_softirq+0x65/0xa0
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff81072a15>] irq_exit+0x85/0x90
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff814df781>] smp_apic_timer_interrupt+0x71/0x9c
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff81013c93>] apic_timer_interrupt+0x13/0x20
Jul  6 07:59:17 dhcp242-213 kernel: <EOI>  [<ffffffff812dcd3a>] ? acpi_idle_enter_bm+0x285/0x2b9
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff812dcd33>] ? acpi_idle_enter_bm+0x27e/0x2b9
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff813e1767>] cpuidle_idle_call+0xa7/0x140
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff81011e96>] cpu_idle+0xb6/0x110
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff814c0deb>] rest_init+0x6b/0x80
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff818dce9a>] start_kernel+0x401/0x40d
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff818dc33a>] x86_64_start_reservations+0x125/0x129
Jul  6 07:59:17 dhcp242-213 kernel: [<ffffffff818dc438>] x86_64_start_kernel+0xfa/0x109
Jul  6 07:59:17 dhcp242-213 kernel: ---[ end trace e1b9d8f4db4b01ce ]---



Version-Release number of selected component (if applicable):
Linux dhcp242-213.rdu.redhat.com 2.6.32-42.el6.x86_64 #1 SMP Wed Jun 30 15:15:28 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
unknown as of yet, so far it's happened once

Steps to Reproduce:
1. Suspend
2. Resume 4 minutes later.
Comment 2 RHEL Product and Program Management 2010-07-15 10:35:08 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 John W. Linville 2010-07-16 10:47:46 EDT
Marking this one as the duplicate since bug 614275 is from abrt and will (hopefully) catch more abrt-generated duplicates automatically...

*** This bug has been marked as a duplicate of bug 614275 ***

Note You need to log in before you can comment on or make changes to this bug.